Bug 52434 - up2date --nox as a user prompts for root password in an X window
Summary: up2date --nox as a user prompts for root password in an X window
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: roswell
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On: 52532
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-23 18:36 UTC by Tommy McNeely
Modified: 2015-01-07 23:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-10 13:41:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tommy McNeely 2001-08-23 18:36:31 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
When running up2date as a user, and the '--nox' option, it still prompts
for the root password through an X window (as opposed to something in the
terminal window).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. login as a user
2. up2date --nox (--list)

	

Actual Results:  The system realizes that you are not root and prompts you
for the root password.. but it does so in an X window even though I
specifically said no X .

Expected Results:  (right in the terminal window... something like this)

up2date must run as root.

Please enter the root password: _



Additional info:

This probably affects all versions of up2date, not just the roswell beta. A
simple workaround is su ing to root.. but nevertheless it is still a bug.
The way I have been reproducing it is ssh ing into my machine from work,
and let me tell you how long it takes for a little X window to fly through
a ssh tunnel all the way back here :)

Comment 1 Jay Turner 2001-08-24 12:18:04 UTC
That GUI box is actually being displayed by consolehelper and not by
rhn_register, so not sure how much control we really have on this one.  In the
case that DISPLAY is unset (or set to a text console) then we do get the TUI
prompting for root password.

Comment 2 Glen Foster 2001-08-24 15:54:29 UTC
We (Red Hat) should try to fix this before next release.

Comment 3 Adrian Likins 2001-08-24 18:57:48 UTC
This will require a change in usermode. See bug #52232

Comment 4 Adrian Likins 2001-08-24 19:04:21 UTC
er, make that bug #52532




Comment 5 Tommy McNeely 2001-08-24 19:22:46 UTC
This is SEV LOW.. and the problem appears to not be up2date at all.. I am not
sure how to re-categorize it, but it also appears there is another bug about
this already. I just BUGGED it cause I was told to on the mailing list.

Tommy

Comment 6 Chris Ricker 2001-09-08 13:55:29 UTC
Well, it's really annoying when you're coming in over SSH and it shoves GTK down
the line....

bug 53417 (in rhn_register; bug accessible by beta only) is the same issue

Comment 7 Tommy McNeely 2001-09-08 17:49:14 UTC
Well...

type "unset DISPLAY" (for bash like shell)

then it wont have a DISPLAY to push it to :p

Tommy

Comment 8 Chris Ricker 2001-09-08 21:21:31 UTC
I can also just not use the -X option with ssh.  That doesn't change the fact
that if an X app pops up after I use the --nox option, then there's a bug.

Comment 9 Jay Turner 2001-09-10 13:40:58 UTC
Again, this is the result of a bug in consolehelper . . . so, as soon as that
issue gets resolved, this one will not be a problem.

Comment 10 Adrian Likins 2001-12-03 20:42:04 UTC
The next version of consolehelper will fix this. 

Since this is a consolehelper bug and not an up2date bug,
and the bug is fixed in current code, I'm going to close this bug.


Note You need to log in before you can comment on or make changes to this bug.