Bug 524528 - Number of translated strings in text version are way less than the strings in PO file
Number of translated strings in text version are way less than the strings in...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: setuptool (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
: Translation
Depends On:
Blocks: 525052
  Show dependency treegraph
 
Reported: 2009-09-21 00:51 EDT by Noriko Mizumoto
Modified: 2009-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-30 19:41:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setuptool English version (219.76 KB, image/png)
2009-09-29 22:31 EDT, Noriko Mizumoto
no flags Details
setuptool Japanese version (221.52 KB, image/png)
2009-09-29 22:32 EDT, Noriko Mizumoto
no flags Details

  None (edit)
Description Noriko Mizumoto 2009-09-21 00:51:54 EDT
Issuing command "setuptool" will bring up text version. The number of strings in this text version seems less than those in PO file.
https://translate.fedoraproject.org/projects/setuptool/master/
Comment 1 Noriko Mizumoto 2009-09-28 22:17:25 EDT
Description of problem:
This is feedback from Fedora 12 software translation review.
Some strings in PO file translated can not be found in this tool. 

Version-Release number of selected component (if applicable):
Live for Fedora 12 Software Translation Review
http://people.redhat.com/petersen/f12-l10n/


How reproducible:
Always

Steps to Reproduce:
1. issue command 'setup'
2. Observe the text version

Actual results:
The following six strings can not be found.
'Configuration tools which run in a terminal', 'Text mode tool menu', 'Mouse configuration', 'Printer configuration', 'Sound card configuration' and 'Timezone configuration'.

Expected results:
Those strings should be available in the tool, or POT should be updated if those are unavailable via the tool.

Additional info:
Observed by ko_KR, fr_FR and ja_JP
Comment 2 Michal Hlavinka 2009-09-29 10:42:45 EDT
/me back from vacation

'Configuration tools which run in a terminal'
-> this will be removed because this was used in *.desktop file which we do not ship anymore

'Text mode tool menu'
-> this will be removed because this was used in *.desktop file which we do not ship anymore

'Mouse configuration'
-> this will be removed because system-config-mouse no longer exists

'Printer configuration'
-> this will be removed because system-config-printer-tui no longer exists

'Sound card configuration'
-> this will be removed because system-config-soundcard no longer exists



'Timezone configuration'
-> this is listed in english menu and seems also translated for ko_KR, fr_FR, ja_JP 

^^^ ??? ^^^^
Comment 3 Noriko Mizumoto 2009-09-29 22:31:04 EDT
Created attachment 363109 [details]
setuptool English version

Livecd for translators' review was created on 20090917.
Comment 4 Noriko Mizumoto 2009-09-29 22:32:23 EDT
Created attachment 363110 [details]
setuptool Japanese version
Comment 5 Michal Hlavinka 2009-09-30 03:19:40 EDT
I don't know if I understand this right, but if you mean that there is no 'Timezone configuration' text visible anywhere, it's because it depends on system-config-* presence. For timezone system-config-date is required.
Comment 6 Noriko Mizumoto 2009-09-30 19:26:53 EDT
Probably livecd we used for QA review would have contained older version of setuptool. As long as your latest setuptool package lists 'Timezone configuration' **with latest translation, we of translators are happy :-)
We have reviewed s-c-date separately. Thank you for your attention.

Note You need to log in before you can comment on or make changes to this bug.