Bug 524532 - Error executing dialogue is popped up
Error executing dialogue is popped up
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-kdump (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Roman Rakus
Fedora Extras Quality Assurance
Catch dbus exceptions
: Translation
Depends On:
Blocks: 524771 525052
  Show dependency treegraph
 
Reported: 2009-09-21 01:11 EDT by Noriko Mizumoto
Modified: 2014-01-12 19:09 EST (History)
4 users (show)

See Also:
Fixed In Version: system-config-kdump-2.0.2-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 524771 577248 (view as bug list)
Environment:
Last Closed: 2010-03-26 10:55:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error executing dialogue (1.08 KB, application/octet-stream)
2009-09-21 01:13 EDT, Noriko Mizumoto
no flags Details
upgrade kdump (278.75 KB, image/png)
2009-10-05 23:14 EDT, Noriko Mizumoto
no flags Details
Error executing dialogue 2 (289.75 KB, image/png)
2009-10-05 23:16 EDT, Noriko Mizumoto
no flags Details

  None (edit)
Description Noriko Mizumoto 2009-09-21 01:11:10 EDT
Trying to issume command "system-config-kdump" to check translation results in Error executing dialogue.
Please see complete error messages contained in the dialogue.
(Reported by Korean translator)
Comment 1 Noriko Mizumoto 2009-09-21 01:13:21 EDT
Created attachment 361861 [details]
Error executing dialogue
Comment 2 Roman Rakus 2009-09-22 07:42:22 EDT
Do you have system-config-kdump rpm installed? (rpm -q system-config-kdump)
Comment 3 Noriko Mizumoto 2009-09-22 22:32:18 EDT
This is the feedback from "Fedora 12 software translation review" [1].
The live used for this review can be found at [2].

[1]:https://www.redhat.com/archives/fedora-trans-list/2009-September/msg00100.html
[2]:http://people.redhat.com/petersen/f12-l10n/
Comment 4 Roman Rakus 2009-10-05 06:40:33 EDT
I'm unable to run live cd on my virtual machine. Can you please check if the problem is still in rawhide? In system-config-kdump-2.0.1-1.fc13
Comment 5 Noriko Mizumoto 2009-10-05 23:14:02 EDT
Created attachment 363767 [details]
upgrade kdump
Comment 6 Noriko Mizumoto 2009-10-05 23:16:27 EDT
Created attachment 363768 [details]
Error executing dialogue 2

I could not fine fc13, but found and upgraded to system-config-kdump-2.0.1-1.fc12.
After upgrading, same error message displayed.
Comment 7 Roman Rakus 2009-10-07 04:38:07 EDT
This looks like dbus doesn't reload the file. Do you have file `/usr/share/dbus-1/system-services/org.fedoraproject.systemconfig.kdump.mechanism.service'? Also I see some AVC denials - is there something interesting for s-c-kdump?
Comment 8 Noriko Mizumoto 2009-10-07 19:03:57 EDT
(In reply to comment #7)
> This looks like dbus doesn't reload the file. Do you have file
> `/usr/share/dbus-1/system-services/org.fedoraproject.systemconfig.kdump.mechanism.service'?
Yes, there is.

> Also I see some AVC denials - is there something interesting for s-c-kdump?  
Sorry I don't understand what you look after...
Comment 9 Roman Rakus 2009-10-08 04:45:53 EDT
Can you please try to restart dbus-daemon? This can stop some applications... (service messagebus restart)

Is there something in /var/log/messages talking about system-config-kdump? (cat /var/log/messages | grep system-config-kdump)
Comment 10 Brian Harrington 2009-10-11 15:07:32 EDT
I've been following this ticket, having identical problems.  I can be of some help here too.

Since updating selinux, not getting selinux errors in /var/log/messages nor any regarding system-config-kdump.

If I do a grep on kdump, i get errors about a lack of a crash kernel (which makes sense as i haven't been able to configure kdump):

Oct 11 14:06:25 kraken kdump: No crashkernel parameter specified for running kernel
Oct 11 14:06:25 kraken kdump: failed to start up
Oct 11 14:51:29 kraken kdump: No crashkernel parameter specified for running kernel
Oct 11 14:51:29 kraken kdump: failed to start up

and I'm not getting relevant dbus errors either:

Oct 11 14:07:01 kraken dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.26" (uid=42 pid=1641 comm="gnome-power-manager) interface="org.freedesktop.Hal.Device.LaptopPanel" member="GetBrightness" error name="(unset)" requested_reply=0 destination=":1.1" (uid=0 pid=1132 comm="hald))
Oct 11 14:07:01 kraken dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.26" (uid=42 pid=1641 comm="gnome-power-manager) interface="org.freedesktop.Hal.Device.LaptopPanel" member="SetBrightness" error name="(unset)" requested_reply=0 destination=":1.1" (uid=0 pid=1132 comm="hald))
Oct 11 14:51:59 kraken dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.26" (uid=42 pid=1732 comm="gnome-power-manager) interface="org.freedesktop.Hal.Device.LaptopPanel" member="GetBrightness" error name="(unset)" requested_reply=0 destination=":1.1" (uid=0 pid=1223 comm="hald))
Oct 11 14:51:59 kraken dbus: Rejected send message, 1 matched rules; type="method_call", sender=":1.26" (uid=42 pid=1732 comm="gnome-power-manager) interface="org.freedesktop.Hal.Device.LaptopPanel" member="SetBrightness" error name="(unset)" requested_reply=0 destination=":1.1" (uid=0 pid=1223 comm="hald))

Anything else you'd like me to check?
Comment 11 Roman Rakus 2009-10-12 04:28:49 EDT
So, after updating selinux (policy I guess), the problem with dbus and s-c-kdump goes away?
Comment 12 Brian Harrington 2009-10-12 10:26:58 EDT
Well, I stop getting AVC denials... but the errors from the screenshot posted and the console are identical.
Comment 13 Bug Zapper 2009-11-16 07:42:04 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 14 Roman Rakus 2009-12-09 10:24:15 EST
Do you still see errors after rebooting system? Restarting dbus should be sufficient.
Comment 15 Jens Petersen 2009-12-09 23:09:58 EST
Yes installing after rebooting and it runs ok.

So guess you want a friendly error dialog saying no dbus service or something?
Comment 16 Roman Rakus 2009-12-10 03:46:36 EST
Well, the problem is, dbus is not (re)loading configuration files when they are added/changed. So you have to restart dbus.
Nevertheless, some friendly error message saying that is expected.
Comment 17 Roman Rakus 2010-03-22 08:07:45 EDT
Can you please try system-config-kdump-2.0.2-2?
Comment 18 Jens Petersen 2010-03-22 23:01:09 EDT
system-config-kdump.noarch 0:2.0.2-2.fc12 gives:

Traceback (most recent call last):
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1760, in <module>
    win = MainWindow()
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 465, in __init__
    self.default_kernel = self.default_kernel_name()[:-1]
  File "/usr/share/system-config-kdump/system-config-kdump.py", line 1392, in default_kernel_name
    default_kernel = self.dbus_object.getdefaultkernel()
  File "<string>", line 2, in getdefaultkernel
  File "/usr/lib/python2.6/site-packages/slip/dbus/polkit.py", line 143, in _enable_proxy
    raise e
DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name :1.65 was not provided by any .service files
Comment 19 Roman Rakus 2010-03-26 10:55:34 EDT
OK, I will do some magic with this bug.
Closing this one as fixed in system-config-kdump-2.0.2-2.
I will clone this bug to track that s-c-kdump is not catching exceptions from dbus.

Note You need to log in before you can comment on or make changes to this bug.