Bug 524609 - kdump kernel hangs at udev
Summary: kdump kernel hangs at udev
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: udev
Version: 5.2
Hardware: All
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Harald Hoyer
QA Contact: BaseOS QE
URL:
Whiteboard:
Depends On:
Blocks: 499522
TreeView+ depends on / blocked
 
Reported: 2009-09-21 13:19 UTC by Jon Thomas
Modified: 2018-10-20 03:34 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-13 14:12:07 UTC


Attachments (Terms of Use)
log of udev hang (590.62 KB, text/plain)
2009-10-12 13:53 UTC, Jon Thomas
no flags Details
log of udev hang (620.00 KB, text/plain)
2009-10-12 13:54 UTC, Jon Thomas
no flags Details

Description Jon Thomas 2009-09-21 13:19:17 UTC
This specific system hangs at udev during a boot to kdump kernel.

* ProLiant DL585 G5 (4 CPUs x Quad = 16 CPUs booted)
 - Quad-Core AMD Opteron(tm) Processor 8354
 - system name: paumaccg101a, RHEL5.2 with 2.6.18-92.el5 (x86_64)

This only happens when the qla driver is loaded. 

The test is symply sysrq to force crash. The kdump kernel will load, but then hangs later during udev. It should write out the core and then reboot.

Everything works when udev is disabled.

We thought we might be hitting https://bugzilla.redhat.com/show_bug.cgi?id=460301, but we have eliminated that.

Comment 1 Jon Thomas 2009-09-21 13:23:58 UTC
Additional info:

We have tested this on our hardware, but could not reproduce this..but we don't have the same storage config. The customer has had a couple different machines (same model) with the issue.

Comment 2 Phil Knirsch 2009-10-12 12:37:58 UTC
Have you run udev in debug mode and logged it via a serial console? That would provide a lot more valuable info on what happens.

Thanks & regards, Phil

Comment 3 Jon Thomas 2009-10-12 13:52:24 UTC
We collected udev debug from serial, but I didn't see anything that stood out and the "hang" didn't appear to happen at a consistent location. I'm been informed of the following tests.



1./ Install From Scratch of RH5.4 (with the customer's Configuration)
   ==>  Crash tests: OK

2./ Update from RH5.2 (customer Configuration)

a)  Kernel update  (2.6.18-164)       ==> Crash tests : Not OK (same problem)
  
   Updating also the following RPMs :
   - RPM "trouser" (not installed in  RH5.2 or RH5.4 From Scratch : needed
     to  update the kernel ? )
   - RPM  "keyutils (update)
   - RPM  " ecryptfs" (update)
   - RPM "KERNEL"

b) Update of Package KEXEC (RHEL 5.4)  ==>  Crash tests  : OK

Comment 4 Jon Thomas 2009-10-12 13:53:26 UTC
Created attachment 364460 [details]
log of udev hang

Comment 5 Jon Thomas 2009-10-12 13:54:19 UTC
Created attachment 364462 [details]
log of udev hang

Attached a couple logs of udev debug output


Note You need to log in before you can comment on or make changes to this bug.