Bug 524776 - DOCS: virsh help docs wrong for vol-key vol-path, vol-name commands
Summary: DOCS: virsh help docs wrong for vol-key vol-path, vol-name commands
Keywords:
Status: CLOSED DUPLICATE of bug 598635
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 06:45 UTC by zhanghaiyan
Modified: 2012-10-14 21:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-10-14 21:00:34 UTC


Attachments (Terms of Use)

Description zhanghaiyan 2009-09-22 06:45:01 UTC
Description of problem:
Describe vol-key vol-path, vol-name commands wrongly in help doc in fedora 12 Alpha

Version-Release number of selected component (if applicable):
- libvirt-0.7.1-4.fc12.x86_64
- qemu-kvm-0.10.91-0.5.rc1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # virsh help vol-key
2. # virsh help vol-path
3. # virsh help vol-name
  
Actual results:
1. output:
  NAME
    vol-key - convert a vol UUID to vol key

  SYNOPSIS
    vol-key <vol>

  OPTIONS
    <vol>            vol uuid
2. output:
   NAME
    vol-path - convert a vol UUID to vol path

  SYNOPSIS
    vol-path [--pool <string>] <vol>

  OPTIONS
    --pool <string>  pool name or uuid
    <vol>            vol name or key

3. output:
   NAME
    vol-name - convert a vol UUID to vol name

  SYNOPSIS
    vol-name <vol>

  OPTIONS
    <vol>            vol key or path


Expected results:

1.   NAME
    vol-key - convert a vol path to vol key

  SYNOPSIS
    vol-key <vol>

  OPTIONS
    <vol>            vol path 
2. output:
   NAME
    vol-path - convert a vol key or vol name to vol path

  SYNOPSIS
    vol-path [--pool <string>] <vol>

  OPTIONS
    --pool <string>  pool name or uuid
    <vol>            vol key or vol name
3. output:
   NAME
    vol-name - convert a vol key or vol path to vol name

  SYNOPSIS
    vol-name <vol>

  OPTIONS
    <vol>            vol key or vol path

Additional info:

Comment 1 Mark McLoughlin 2009-10-02 09:21:12 UTC
Similar to bug #524770

Comment 2 Bug Zapper 2009-11-16 12:44:30 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Cole Robinson 2010-03-16 15:30:00 UTC
Isn't hugely important for fedora, moving to upstream tracker.

Comment 4 Cole Robinson 2012-10-14 21:00:34 UTC

*** This bug has been marked as a duplicate of bug 598635 ***


Note You need to log in before you can comment on or make changes to this bug.