Bug 524818 - Ghostscript v 8.63 unable to interpret a specific PDF
Summary: Ghostscript v 8.63 unable to interpret a specific PDF
Keywords:
Status: CLOSED DUPLICATE of bug 525403
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-22 10:54 UTC by Robert Barre
Modified: 2009-10-01 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-01 16:58:58 UTC


Attachments (Terms of Use)

Description Robert Barre 2009-09-22 10:54:51 UTC
Description of problem:
When I start gs on a specific file , gs exit with an error

Version-Release number of selected component (if applicable):
v 8.63

How reproducible:
gs -dBATCH -dNOPAUSE -sDEVICE=pnggray -r200x200 -sDither=floyd -sOutputFile=x%03d.png P015342.pdf

Steps to Reproduce:
1.
2.
3.
  
Actual results:
   **** File has an unbalanced >> (close dictionary).
   **** Incorrect object count in object stream.
Error: /rangecheck in resolveobjectstream
Operand stack:
   PageCount   178922   12   105   --dict:7/15(L)--   25   --nostringval--   false   --nostringval--   --dict:5/5(L)--   --dict:4/4(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --nostringval--   Contents   --nostringval--   MediaBox   --nostringval--   Parent   --nostringval--      Resources   --dict:2/2(L)--   Type   Page   --dict:5/5(L)--   --dict:3/3(L)--   --dict:4/4(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:5/5(L)--   --dict:4/4(L)--   --dict:5/5(L)--
Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--   --nostringval--   --nostringval--   false   1   %stopped_push   1905   1   3   %oparray_pop   1904   1   3   %oparray_pop   1888   1   3   %oparray_pop   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--   --nostringval--
Dictionary stack:
   --dict:1151/1684(ro)(G)--   --dict:1/20(G)--   --dict:75/200(L)--   --dict:75/200(L)--   --dict:106/127(ro)(G)--   --dict:275/300(ro)(G)--   --dict:20/25(L)--
Current allocation mode is local
GPL Ghostscript 8.63: Unrecoverable error, exit code 1


Expected results: 
=> on V 8.70 on Fedora 11
Processing pages 1 through 21.
Page 1
Substituting font Times-Roman for FAAAAA+Times-Roman.
Can't find (or can't open) font file /usr/share/ghostscript/8.70/Resource/Font/NimbusRomNo9L-Regu.
Can't find (or can't open) font file NimbusRomNo9L-Regu.
Can't find (or can't open) font file /usr/share/ghostscript/8.70/Resource/Font/NimbusRomNo9L-Regu.
Can't find (or can't open) font file NimbusRomNo9L-Regu.
Querying operating system for font files...
Loading NimbusRomNo9L-Regu font from /usr/share/fonts/default/Type1/n021003l.pfb... 3252356 1912729 6945696 5622683 3 done.
Substituting font Times-Roman for JAAAAA+Times-Roman.
Substituting font Times-Roman for NAAAAA+Times-Roman.
Substituting font Times-Roman for RAAAAA+Times-Roman.
Substituting font Times-BoldItalic for VAAAAA+Times-BoldItalic.
Loading NimbusRomNo9L-MediItal font from /usr/share/fonts/default/Type1/n021024l.pfb... 3396460 2057172 7260472 5920146 3 done.



Additional info:
It works like a charm on Ghostscript 8.70 on fedora 11.
I am using fedora 10 in a production environment so I cannot easily update it.
V 8.70 is not available yet on Fedora 10

Comment 1 Tim Waugh 2009-10-01 16:58:58 UTC

*** This bug has been marked as a duplicate of bug 525403 ***


Note You need to log in before you can comment on or make changes to this bug.