Bug 52496 - Panel will not start
Panel will not start
Status: CLOSED DUPLICATE of bug 55119
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-core (Show other bugs)
roswell
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
: 55347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 07:55 EDT by adam.huffman
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-02-25 17:55:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-08-24 07:55:05 EDT
Description of Problem:
The gnome panel crashes repeatedly when gnome is starting up.
Any subsequent attempts to start the panel also crash immediately.

Version-Release number of selected component (if applicable):

gnome-core-1.4.0.4-28

How Reproducible:
Every time

Steps to Reproduce:
1. startx
2. 
3. 

Actual Results:

gnome panel crashes

Expected Results:

gnome panel should appear normally

Additional Information:
Comment 1 Havoc Pennington 2001-08-24 10:52:05 EDT
Will need more info to reproduce; it doesn't crash here.

Do you have a laptop? There are some problems with APM on some laptops.

When you get the crash dialog, if you "submit a bug report" on the second or
third page of that wizard it shows a backtrace; if the backtrace contains more
than ???? 
can you paste it into this bug report?
Comment 2 Glen Foster 2001-08-24 11:54:10 EDT
We (Red Hat) should try to fix this before next release.
Comment 3 adam.huffman 2001-08-24 11:59:06 EDT
I submitted this to the GNOME bugzilla too, the crash information is there at
http://bugzilla.gnome.org/show_bug.cgi?id=59481 but here it is anyway:

Debugging Information:

(no debugging symbols found)...(no debugging symbols found)...(no debugging
+symbols found)...(no debugging symbols found)...(no debugging symbols
found)...(no debugging symbols found)...0x405a64b9 in __wait4 () from /lib/libc.so.6
#0  0x405a64b9 in __wait4 () from /lib/libc.so.6
#1  0x406216e0 in __DTOR_END__ () from /lib/libc.so.6
#2  0x4015bea8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#3  <signal handler called>
#4  0x08078002 in create_menu_at () at eval.c:41
#5  0x0805eca2 in main () at eval.c:41
#6  0x4050f2ae in __libc_start_main (main=0x805ea10 <main>, argc=3,
+ubp_av=0xbffffab4, init=0x8056b50 <_init>, fini=0x80ab690 <_fini>,
    rtld_fini=0x4000cf28 <_dl_fini>, stack_end=0xbffffaac) at
+../sysdeps/generic/libc-start.c:129
#0  0x405a64b9 in __wait4 () from /lib/libc.so.6
No locals.
#1  0x406216e0 in __DTOR_END__ () from /lib/libc.so.6
No symbol table info available.
#2  0x4015bea8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
No symbol table info available.
#3  <signal handler called>
No locals.
#4  0x08078002 in create_menu_at () at eval.c:41
        in eval.c
ap = (void **) 0x80c17f8
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
result = 135010296
result = 135010296
value = (void *) 0xbffff710
#5  0x0805eca2 in main () at eval.c:41
41
in eval.c
ap = (void **) 0x80c17f8
digval = 4294966784
digval = 4294966784
digval = 4294966784
digval = 4294966784
result = 135010296
result = 135010296
value = (void *) 0xbffff710
#6  0x4050f2ae in __libc_start_main (main=0x805ea10 <main>, argc=3,
+ubp_av=0xbffffab4, init=0x8056b50 <_init>, fini=0x80ab690 <_fini>,
    rtld_fini=0x4000cf28 <_dl_fini>, stack_end=0xbffffaac) at
+../sysdeps/generic/libc-start.c:129
        in ../sysdeps/generic/libc-start.c
ubp_av = (char **) 0xbffffab4
fini = (void (*)()) 0x40015874 <_dl_debug_mask>
rtld_fini = (void (*)()) 0xbffff710
ubp_ev = (char **) 0xbffffac4
#0  __strtol_internal (nptr=) at eval.c:36
        in eval.c
nptr = 0xbffff710 "|2\t@\002"
endptr = (char **) 0x8059790
base = 134584208
result = 3
sign =

This is on a laptop, although the panel actually seems to be working fine now (I
have since rebooted for other reasons).
Comment 4 Havoc Pennington 2001-08-24 12:58:54 EDT
Can you see any similarity with:
  http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=52199

Does it happen if you create a new user account with no preexisting configuration?
Comment 5 Havoc Pennington 2001-08-27 14:54:50 EDT
I made some RPMs with debug symbols, the backtrace may be more useful using these:
  http://people.redhat.com/~hp/gnome-core-1.4.0.4-32.i386.rpm
  http://people.redhat.com/~hp/gnome-core-devel-1.4.0.4-32.i386.rpm

If you get a new backtrace that's different please attach it.
Comment 6 adam.huffman 2001-08-28 09:20:57 EDT
I created a new user and the panel worked normally.

Bugzilla wouldn't let me see the older bug you referred to.
Comment 7 Havoc Pennington 2002-02-12 18:48:59 EST
*** Bug 55347 has been marked as a duplicate of this bug. ***
Comment 8 Havoc Pennington 2002-02-25 17:57:01 EST

*** This bug has been marked as a duplicate of 55119 ***

Note You need to log in before you can comment on or make changes to this bug.