Bug 52500 - Impossible to move or resize windows using mouse
Impossible to move or resize windows using mouse
Status: CLOSED DUPLICATE of bug 54491
Product: Red Hat Public Beta
Classification: Retired
Component: sawfish (Show other bugs)
roswell
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 09:14 EDT by Tor Andre Myrvoll
Modified: 2007-04-18 12:36 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 17:24:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The .xsession-errors file (21.12 KB, text/plain)
2001-08-24 11:21 EDT, Tor Andre Myrvoll
no flags Details

  None (edit)
Description Tor Andre Myrvoll 2001-08-24 09:14:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010809

Description of problem:
When trying to move or resize windows using the mouse a continuous series
of beeps comes from the speaker and nothing else happens. Also, the mouse
does not "stick" to the spot I grab.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Log in (I use GDM to start a gnome session using the sawfisk WM)
2.Open a window
3.Try to move it
	

Additional info:

If I log in as root using the GDM nothing of the sort happens. Also, when I
tried removing all my .gnome* .sawfish and .gtkrc files (I suspected they
might be corrupted), I could move my windows, but I couldn't resize them. 

Possibly related item: When I try to change the sawfish appearance by
choosing the menu item from the gnome menu or by clicking the middle button
on the desktop, the window comes up, but just hangs. It can't even be
removed. However, choosing sawfish appearance from the Gnome configuration
tool works fine.
Comment 1 Havoc Pennington 2001-08-24 10:54:28 EDT
Sawfish is no doubt spewing Lisp errors to ~/.xsession-errors - what are those
errors?
Comment 2 Tor Andre Myrvoll 2001-08-24 11:21:51 EDT
Created attachment 29374 [details]
The .xsession-errors file
Comment 3 Havoc Pennington 2001-08-24 11:46:40 EDT
OK, something is really screwed - the X server is not providing the "fixed" font.
Several apps other than sawfish seem to be complaining about that.

Does "xlsfonts | grep fixed" show the line "fixed"?
Comment 4 Glen Foster 2001-08-24 11:54:15 EDT
We (Red Hat) should try to fix this before next release.
Comment 5 Tor Andre Myrvoll 2001-08-24 12:39:23 EDT
The fixed font error messages may have occured when I tried to run
/usr/X11R6/bin/XF86_Mach64 this morning (my X dies every night due to a well
known Mach-64+SMP+XFree86 bug, so I was starting to get a bit desperate).

Anyway, when I do the "xlsfonts | grep fixed" I get two lines containing the
word fixed.
Comment 6 Havoc Pennington 2001-08-24 12:42:50 EDT
.xsession-errors should be restarted (cleared out) each time you log in.

What are the two lines with "fixed"? There's no line with just plain "fixed"?

(My test machine has 1009 lines with "fixed")
Comment 7 Havoc Pennington 2001-08-24 14:03:54 EDT
It looks like this may be a duplicate of
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=51033

Comment 8 Glen Foster 2001-08-24 15:08:17 EDT
Testing -- reporter says they can't post an update to this bug.
Comment 9 Tor Andre Myrvoll 2001-08-24 15:16:46 EDT
I was probably unclear: When running "xlsfonts | grep fixed
" I got two lines containg just the word fixed, but there were 510 lines all in all.
Comment 10 Havoc Pennington 2001-08-24 17:24:48 EDT
does "xlsfonts -fn -*-fixed-medium-r-normal--14-*-*-*-*-*-*-*" list any fonts?
This the Sawfish default font with a recent patch.
If it doesn't list any fonts, that would explain the problem, but I'm not sure
why it wouldn't be listing any fonts.
Comment 11 Havoc Pennington 2001-10-10 00:09:15 EDT

*** This bug has been marked as a duplicate of 54491 ***

Note You need to log in before you can comment on or make changes to this bug.