Bug 54491 - Sawfish beeps and wont resize or reconfigure
Sawfish beeps and wont resize or reconfigure
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sawfish (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
: 52107 52500 53943 54105 55220 56405 57754 60101 60474 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-09 23:02 EDT by Alan Cox
Modified: 2005-10-31 17:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-08 09:35:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2001-10-09 23:02:35 EDT
If your box is updated from older releases the locale ends up as en_US in
some cases. With this locale sawfish doesnt actually resize windows or
configure at all - it simply beeps at you

en_GB works fine
Comment 1 Havoc Pennington 2001-10-10 00:06:56 EDT
Are you sure you have en_US not en.encoding which is an invalid locale?
I think the bug is basically that gdm sets an invalid locale, which results in
fontsets breaking, which is then compounded by sawfish not expecting its fonts
to fail to load.
Comment 2 Havoc Pennington 2001-10-10 00:07:56 EDT
*** Bug  54105 has been marked as a duplicate of this bug. ***
Comment 3 Havoc Pennington 2001-10-10 00:09:10 EDT
*** Bug 52500 has been marked as a duplicate of this bug. ***
Comment 4 Havoc Pennington 2001-10-10 00:09:35 EDT
*** Bug 52107 has been marked as a duplicate of this bug. ***
Comment 5 Alan Cox 2001-10-10 00:22:36 EDT
I printed the environment to check when reporting the bug LANG was set to en_US.
This was startx run rather than gdm in case its relevant. The box has been
everything since about 6.0 or so
Comment 6 Selmer van Alten 2001-10-24 17:45:37 EDT
After getting the latest version from sawfish.sourcefore.net (1.0.1-1) and
upgrading the standard RedHat sawfish with it, the problem
disappeared for me on a RedHat 7.2 release system.(This also envolved getting
more recent versions of librep and readline) and some rpm -Uvh --force 's to
convince rpm gently that the new RPMS really were newer.

Comment 7 Havoc Pennington 2001-10-24 18:13:41 EDT
The reason it works is that you lose the Red Hat patch causing the problem when
you upgrade. The problem patch sets a font which doesn't load for some reason.
Comment 8 Havoc Pennington 2001-10-28 09:43:43 EST
*** Bug 55220 has been marked as a duplicate of this bug. ***
Comment 9 Havoc Pennington 2001-11-01 10:16:55 EST
There's now a fixed package in ftp://people.redhat.com/hp/gnomehide and one 
should appear in rawhide soon. But it probably breaks CJK, so the fix 
isn't really quite right.
Comment 10 Havoc Pennington 2002-01-16 16:48:02 EST
*** Bug 56405 has been marked as a duplicate of this bug. ***
Comment 11 Havoc Pennington 2002-01-16 17:34:37 EST
One report on testers-list (Paul Iadonisi, mail has "56405" in subject)
that the bug happens only when LANG is unset and startx is used to start
X; with gdm LANG is set properly so no bug.

Still need to track down why we get a system with no LANG, and why 
the XLFD we had in Sawfish failed to load with the locale unset.
Comment 12 Havoc Pennington 2002-01-16 17:35:46 EST
Paul used kickstart to install the systems.
Comment 13 Havoc Pennington 2002-02-21 00:35:55 EST
*** Bug 60101 has been marked as a duplicate of this bug. ***
Comment 14 Edmund Lam 2002-02-28 07:08:03 EST
I have found that this bug (or a very similar one) still affects sawfish under
Red Hat Linux 7.2

I'm using the x386 architecture and have kept up to date with the RH72 errata. I
am also using gdm and have not unset LANG.

I have found a few preconditions (all must be satisfied)
- gdm should set the locale to C/POSIX. en_US and en_AU does NOT trigger the bug
- the sawfish configuration must define the move-show-position and
error-destination.
- No other files (not even ~/.bash*) are needed in the user's home directory.

The effect I've observed is that any attempt to move a window will cause an
infinite of beeps and a keyboard lockup. If the user is quick enough, they can
change to a virtual terminal before lockup. Otherwise, sawfish can also be
killed via a remote login or reboot.

I have also replicated (as per bug-history) this bug by starting X from a
virtual terminal with LANG unset. The bug also occurs when X is started from a
virtual terminal with LANG=C

I have not included the contents of ~/.sawfish/custom but can do so if required.
Comment 15 Havoc Pennington 2002-02-28 08:30:22 EST
Does the sawfish at the gnomehide url work for you?

It's quite simple really; if the locale is oddball, sawfish can't load the
default font added for 7.2. Sawfish beeps and aborts the current operation when
it has an error, such as failing to load fonts.
Comment 16 Havoc Pennington 2002-02-28 11:46:03 EST
*** Bug 60474 has been marked as a duplicate of this bug. ***
Comment 17 Havoc Pennington 2002-03-01 10:20:39 EST
*** Bug 57754 has been marked as a duplicate of this bug. ***
Comment 18 Havoc Pennington 2002-03-01 10:28:30 EST
*** Bug 53943 has been marked as a duplicate of this bug. ***
Comment 19 Edmund Lam 2002-03-07 05:59:33 EST
Yes sawfish-1.0.1-1 and dependencies resolved all known problems.
Comment 20 Ron Yorston 2002-03-08 04:47:36 EST
So is there going to be an update to Red Hat 7.2 to fix this?  Not having the
ability to resize windows is quite a serious drawback in a window manager.  And
locking up my system, as happened yesterday, is an even more serious drawback.
Comment 21 Alan Cox 2002-03-08 08:40:28 EST
Run the localeconfig tool and that should sort the problem out after you
restart again. The problem isnt so much sawfish as incorrectly set country
codes.

Sawfish can't freeze your machine - can you file that as a seperate bug and it
can get looked at too.

Alan
Comment 22 Havoc Pennington 2002-03-08 09:35:14 EST
As Alan says, AFAIK it only breaks if your locale isn't set.

Locking up the system is not something Sawfish can do, that is either an X or
kernel bug typically.
Comment 23 Havoc Pennington 2002-03-08 14:58:47 EST
1.0.1-5 should resolve this issue. 

For CJK, the issue is still unresolved because translations for the fonts need
to go in.
Comment 24 Edmund Lam 2002-04-06 10:17:00 EST
I did a bit more investigation after Alan's suggestion of reporting the
system lockup as a X fault.

To clarify, on one of my system (the one other system I've tested on is
unaffected) when one moves a window using an older version of sawfish
(eg 0.38-11), sawfish starts emitting a never-ending stream of beeps.
As a result, it also locks up the keyboard. If one is quick enough
(sub-second), one can switch to a virtual terminal, otherwise, the only
way to get shell is remotely (eg ssh). Regardless, the beeping (via the
internal PC speaker) continues.

A ``top'' while the system is beeping will reveal that it is sawfish
consuming most of the CPU cycles. With the X server consuming the rest
(20%). So I decided to attach a gdb session while sawfish was running.
I then observed that if I suspended sawfish from gdb, I could return to
my X session at will without any keyboard lockups. Indeed, I was able
to continue using my current X processes (eg xterm) and even start new
X processes (as discovered via ps) -- with the cavet that no new
windows would be displayed as the window manager was suspended.

If I then killed sawfish, I could then return to my X session at will,
starting new processes and generally using the computer, just without a
window manager. Therefore, any keyboard lockups were only temporary.
Indeed, I could (within X) start a new sawfish session which would work
perfectly fine -- other than the abovementioned bugs like moving windows.

To me, it doesn't sound like a X bug at all. Can someone (alan/hp?)
confirm that this is still a X (or kernel) bug? And if so, what details
could I possibly include in the bug report?
Comment 25 Havoc Pennington 2002-04-09 06:55:15 EDT
AFAIK this was never a kernel bug, just Sawfish getting a bad font. The Sawfish
in Rawhide should be entirely fixed.

Note You need to log in before you can comment on or make changes to this bug.