Bug 525023 - Crash while searching for stroage device
Summary: Crash while searching for stroage device
Keywords:
Status: CLOSED DUPLICATE of bug 525095
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:65d01639950171f12...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-23 04:04 UTC by A S Alam
Modified: 2013-07-03 00:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-23 14:17:15 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (65.34 KB, text/plain)
2009-09-23 04:04 UTC, A S Alam
no flags Details
Attached traceback automatically from anaconda. (57.29 KB, text/plain)
2009-09-23 09:13 UTC, Morgan Olausson
no flags Details
Attached traceback automatically from anaconda. (70.81 KB, text/plain)
2009-09-24 18:51 UTC, A.J. Werkman
no flags Details

Description A S Alam 2009-09-23 04:04:51 UTC
The following was filed automatically by anaconda:
anaconda 12.27 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/device.py", line 52, in __init__
    self.__device = _ped.device_get(path)
  File "/usr/lib/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in __init__
  File "/usr/lib/anaconda/storage/devices.py", line 479, in partedDevice
    self._partedDevice = parted.Device(path=self.path)
  File "/usr/lib/anaconda/storage/devices.py", line 615, in currentSize
    if self.exists and self.partedDevice:
  File "/usr/lib/anaconda/storage/devices.py", line 2060, in setup
    self._size = self.currentSize
  File "/usr/lib/anaconda/storage/devicetree.py", line 1506, in handleUdevLVMPVFormat
    lv_device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1731, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1277, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1955, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 328, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 94, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 548, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 981, in <module>
    anaconda.intf.run(anaconda)
PartedException: Unable to determine the dm type of /dev/dm-1.

Comment 1 A S Alam 2009-09-23 04:04:57 UTC
Created attachment 362163 [details]
Attached traceback automatically from anaconda.

Comment 2 Morgan Olausson 2009-09-23 09:13:50 UTC
Created attachment 362219 [details]
Attached traceback automatically from anaconda.

Comment 3 Chris Lumens 2009-09-23 14:17:15 UTC

*** This bug has been marked as a duplicate of bug 525095 ***

Comment 4 A.J. Werkman 2009-09-24 18:51:02 UTC
Created attachment 362555 [details]
Attached traceback automatically from anaconda.


Note You need to log in before you can comment on or make changes to this bug.