Bug 525095 - parted needs to be adjusted for new lvm
parted needs to be adjusted for new lvm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Hans de Goede
Fedora Extras Quality Assurance
anaconda_trace_hash:93dd47d7db8ce0012...
: Triaged
: 525023 525602 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-23 07:04 EDT by Jan Stodola
Modified: 2009-12-18 05:17 EST (History)
12 users (show)

See Also:
Fixed In Version: parted-1.9.0-24.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 05:17:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (59.67 KB, text/plain)
2009-09-23 07:04 EDT, Jan Stodola
no flags Details
Attached traceback automatically from anaconda. (81.48 KB, text/plain)
2009-09-24 21:54 EDT, He Rui
no flags Details
Attached traceback automatically from anaconda. (89.94 KB, text/plain)
2009-09-25 03:42 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Jan Stodola 2009-09-23 07:04:45 EDT
The following was filed automatically by anaconda:
anaconda 12.27 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.6/site-packages/parted/device.py", line 52, in __init__
    self.__device = _ped.device_get(path)
  File "/usr/lib64/python2.6/site-packages/parted/decorators.py", line 30, in localeC
    ret = fn(*args, **kwds)
  File "<string>", line 2, in __init__
  File "/usr/lib/anaconda/storage/devices.py", line 479, in partedDevice
    self._partedDevice = parted.Device(path=self.path)
  File "/usr/lib/anaconda/storage/devices.py", line 615, in currentSize
    if self.exists and self.partedDevice:
  File "/usr/lib/anaconda/storage/devices.py", line 2060, in setup
    self._size = self.currentSize
  File "/usr/lib/anaconda/storage/devicetree.py", line 1506, in handleUdevLVMPVFormat
    lv_device.setup()
  File "/usr/lib/anaconda/storage/devicetree.py", line 1731, in handleUdevDeviceFormat
    self.handleUdevLVMPVFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1277, in addUdevDevice
    self.handleUdevDeviceFormat(info, device)
  File "/usr/lib/anaconda/storage/devicetree.py", line 1955, in populate
    self.addUdevDevice(dev)
  File "/usr/lib/anaconda/storage/__init__.py", line 328, in reset
    self.devicetree.populate()
  File "/usr/lib/anaconda/storage/__init__.py", line 94, in storageInitialize
    storage.reset()
  File "/usr/lib/anaconda/dispatch.py", line 204, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 127, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1205, in nextClicked
    self.anaconda.dispatch.gotoNext()
PartedException: Unable to determine the dm type of /dev/dm-0.
Comment 1 Jan Stodola 2009-09-23 07:04:50 EDT
Created attachment 362280 [details]
Attached traceback automatically from anaconda.
Comment 2 Jan Stodola 2009-09-23 07:39:04 EDT
This bug is from x86_64 in kvm using boot.iso, rawhide-20090922.
I'm not sure how to create image of the disk - I tried rawhide-20090922, selected "Use entire drive" and closed qemu window during "Checking dependencies in packages selected for installation". Next time I started installation of rawhide-20090922 the traceback appeared. I have copy of the disk image to verify this bug when fixed.
Comment 3 Chris Lumens 2009-09-23 10:17:15 EDT
*** Bug 525023 has been marked as a duplicate of this bug. ***
Comment 4 Morgan Olausson 2009-09-23 12:08:21 EDT
Not sure if I should write here or in the closed duplicate where my
anaconda-traceback is?

My computer has two hard discs. On sda there is no working system and nothing
is booted from there. On sdb there is f12 rawhide (updated from f11 via
changing to rawhide repo and update) and I think the system is booted from a
separate boot partition which for sure is also located on sdb. I had to change in bios settings for system to boot from sdb. Chip is i810e.
Comment 5 Richard Ryniker 2009-09-24 14:14:56 EDT
Also in anaconda 12.29 which is used in Fedora-20090923-x86_64-DVD.iso built for the Beta Test Compose.  Full console log at http://ryniker.ods.org/errors/Fedora-20090923-x86_64-DVD.console_01

Entering debugger...
> /usr/lib64/python2.6/site-packages/parted/device.py(52)__init__()
-> self.__device = _ped.device_get(path)
(Pdb) bt
  /usr/bin/anaconda(981)<module>()
-> anaconda.intf.run(anaconda)
  /usr/lib/anaconda/text.py(502)run()
-> anaconda.dispatch.gotoNext()
  /usr/lib/anaconda/dispatch.py(123)gotoNext()
-> self.moveStep()
  /usr/lib/anaconda/dispatch.py(200)moveStep()
-> rc = stepFunc(self.anaconda)
  /usr/lib/anaconda/storage/__init__.py(94)storageInitialize()
-> storage.reset()
  /usr/lib/anaconda/storage/__init__.py(328)reset()
-> self.devicetree.populate()
  /usr/lib/anaconda/storage/devicetree.py(1961)populate()
-> self.addUdevDevice(dev)
  /usr/lib/anaconda/storage/devicetree.py(1283)addUdevDevice()
-> self.handleUdevDeviceFormat(info, device)
  /usr/lib/anaconda/storage/devicetree.py(1737)handleUdevDeviceFormat()
-> self.handleUdevLVMPVFormat(info, device)
  /usr/lib/anaconda/storage/devicetree.py(1512)handleUdevLVMPVFormat()
-> lv_device.setup()
  /usr/lib/anaconda/storage/devices.py(2060)setup()
-> self._size = self.currentSize
  /usr/lib/anaconda/storage/devices.py(615)currentSize()
-> if self.exists and self.partedDevice:
  /usr/lib/anaconda/storage/devices.py(479)partedDevice()
-> self._partedDevice = parted.Device(path=self.path)
  <string>(2)__init__()
  /usr/lib64/python2.6/site-packages/parted/decorators.py(30)localeC()
-> ret = fn(*args, **kwds)
> /usr/lib64/python2.6/site-packages/parted/device.py(52)__init__()
-> self.__device = _ped.device_get(path)
(Pdb)
Comment 6 A.J. Werkman 2009-09-24 15:04:45 EDT
My traceback is in bug 525023.

Found this bug on a two disk system where the second disk has a ext3 partition on which I have the vmlinuz and initrd.img. On the first disc is an 'old' rawhide installation with a logical volume partitioning scheme that I want to overwrite with a new installation. I boot with 'vmlinuz nomodeset text'. I use the i386 version.
Comment 7 Denise Dumas 2009-09-24 15:09:25 EDT
Current thinking is that this is a symptom of the lvm update 9/21, specifically the udev changes.  More as debugging continues ...
Comment 8 He Rui 2009-09-24 21:54:49 EDT
Created attachment 362602 [details]
Attached traceback automatically from anaconda.
Comment 9 Joachim Frieben 2009-09-25 03:42:20 EDT
Created attachment 362629 [details]
Attached traceback automatically from anaconda.
Comment 10 Jan Stodola 2009-09-25 04:14:54 EDT
Created attachment 362638 [details]
traceback from anaconda 12.29

There is an easy way how to reproduce this bug with rawhide rawhide-20090924, anaconda 12.29:
dd if=/dev/zero of=2GB.img bs=1G count=2
qemu-kvm -cdrom boot.iso -hda 2GB.img -m 512 -net nic,model=virtio -net user -boot d

During installation select "Re-initialize drive", "Use entire drive" and "Review and modify partitioning layout". Do not make any changes on the second partitioning screen, select Next and confirm formatting and writing changes to disk and now you will get the traceback (see attachment).
You have to select "Review and modify partitioning layout", otherwise you won't get this traceback.
Comment 11 Jan Stodola 2009-09-25 04:20:48 EDT
update of comment 10: You will get the traceback even if you don't select "Review and modify partitioning layout", but the traceback will appear before packages are being installed.
Comment 12 Peter Rajnoha 2009-09-25 05:15:53 EDT
(In reply to comment #7)
> Current thinking is that this is a symptom of the lvm update 9/21, specifically
> the udev changes.

Yes, it seems to be another utility that has problems with /dev/mapper symlinks.

Parted works OK with nodes in /dev/mapper but fails with that error when symlinks are used instead.

Anyway, we have reverted the changes in rawhide for now, so could you please check if it's OK now?

(If there's anyone who is interested in why we use symlinks in /dev/mapper and have the nodes in /dev now, then you should know it's because of udev requirements -- they require the nodes for block devices to be in /dev directly. So we had to do this painful change..)
Comment 13 Chris Lumens 2009-09-25 09:10:47 EDT
*** Bug 525602 has been marked as a duplicate of this bug. ***
Comment 14 Morgan Olausson 2009-09-26 00:25:31 EDT
Perhaps there are hidden bugs that affects some hardware? The upside is that those might get fixed now when these utilities are forced to be used, and the systems provide quite good automatic bugtraces from lots of hardware? Better than what I as a user would be able to anyway.
Comment 15 Morgan Olausson 2009-09-26 15:37:52 EDT
I have now upgraded my system using boot.iso (anaconda 12.30). There were no problems.
(I used the second harddisc this time, so it was not exactly the same case as before.)
Comment 16 Hans de Goede 2009-11-03 06:00:38 EST
This is an issue with parted, which gets caused by changes in the new lvm, there
is a workaround in the newer new lvm which is going into F-13, and I have patches
to make parted do the right thing even without the workaround.

Changing component to parted and assigning to me (to track getting the
parted fixes into F-13).
Comment 17 Bug Zapper 2009-11-16 07:48:11 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Hans de Goede 2009-12-18 05:17:04 EST
Fixed in parted-1.9.0-24.fc13

Note You need to log in before you can comment on or make changes to this bug.