Bug 525029 - Kdump section appears in English
Kdump section appears in English
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kexec-tools (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Neil Horman
Fedora Extras Quality Assurance
: Translation
Depends On:
Blocks: 525052
  Show dependency treegraph
 
Reported: 2009-09-23 00:29 EDT by Noriko Mizumoto
Modified: 2010-05-03 10:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-05-03 10:03:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2009-09-23 00:29:17 EDT
Description of problem:
This is feedback from Fedora 12 software translation review.
Kdump section appears in English.

Version-Release number of selected component (if applicable):
Live for Fedora 12 Software Translation Review
http://people.redhat.com/petersen/f12-l10n/


How reproducible:
Always

Steps to Reproduce:
1. issue command "firstboot"
2.
3.
  
Actual results:
Under Kdump section, the content appears in English even PO file has been fully translated.

Expected results:
Kdump section appears in translated languages

Additional info:
Observed by it-IT, ru-RU, zh-TW
Comment 1 Neil Horman 2009-09-23 10:33:39 EDT
SIgh, looks like firstboot_kdump has changed sufficiently that the po files no longer relate very closely to the strings they reference.  Do you have a link to how to regenerate the po files?  Its been a few years
Comment 2 Noriko Mizumoto 2009-09-23 23:29:25 EDT
When POT is updated, POs will be automatically updated with POT via Transifex. Here are the repositories where Transifex is looking at. (dimitris added in cc)
ssh://git.fedorahosted.org/git/firstboot.git
ssh://git.fedorahosted.org/git/system-config-kdump.git
Comment 3 Neil Horman 2009-09-24 09:38:06 EDT
neither of those repositories house the firstboot_kdump.py module for which I need to update the translations.  I'm looking for the pot file for firstboot_kdump.py which is packaged with the kexec-tools rpm, but there is no git tree there for kexec-tools
Comment 4 Noriko Mizumoto 2009-09-24 21:32:08 EDT
Aha... how about here; http://cvs.fedoraproject.org/viewvc/kexec-tools/po/?root=elvis
POT file contain the missing string below.
44 #: firstboot_kdump.py:251
45 msgid ""
46 "Kdump is a kernel crash dumping mechanism. In the event of a system crash, "
47 "kdump will capture information from your system that can be invaluable in "
48 "determining the cause of the crash. Note that kdump does require reserving a "
49 "portion of system memory that will be unavailable for other uses."
50 msgstr ""
Comment 5 Neil Horman 2009-09-25 11:49:58 EDT
That doesn't make any sense either.  That erpository does seem to have been updated since 2007,. and I thought the translation team was updating all the rawhide translations just last week.

Look, if you can just point me to a howto for the process for getting a tranlation started, I can likely figure it out from there (since It seem I pretty well need to start from scratch anyway).
Comment 6 Noriko Mizumoto 2009-09-25 20:05:00 EDT
I do not know much about the process but hope this link can help a bit. 
http://fedoraproject.org/wiki/L10N/FAQ#How_do_I_add_a_module_to_Transifex.3F_.28.23add-transifex.29

When more info needed ping us. Dimitris (glezos) who understands both side very well, I (noriko) and many more will be #fedora-l10n channel of freenode.
Comment 7 Neil Horman 2009-10-05 15:29:19 EDT
Ok, I've missed the freeze on this, but I've requested an unfreeze so that I can update the pot file and get the translations up to date.
Comment 8 Noriko Mizumoto 2009-10-05 23:22:10 EDT
Great, once an unfreeze is approved and POT/POs updated, please ping me or drop the notice in fedora-trans-list. Thank you!
Comment 9 Neil Horman 2009-10-07 13:34:19 EDT
I've commited the pot file changes, so whenever your ready, go for it.  Thanks!
Comment 10 Noriko Mizumoto 2009-10-07 19:08:20 EDT
Neil and Dimitris
I can not see POT update here;
http://cvs.fedoraproject.org/viewvc/kexec-tools/po/?root=elvis

Currently POs have not received any update from POT here;
https://translate.fedoraproject.org/projects/kexec-tools/HEAD/

Am I missing something?
Comment 11 Neil Horman 2009-10-08 09:09:58 EDT
Thats because I committed it to the cvs pkgs in the po directory.  It was my understanding from speaking with glezos that transifex would pick it up there and move it over to elvis when the freeze was broken:
http://cvs.fedora.redhat.com/viewvc/devel/kexec-tools/po/firstboot_kdump.pot?view=log
Comment 12 Bug Zapper 2009-11-16 07:46:54 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Piotr Drąg 2010-05-03 10:03:18 EDT
Closing, as F12 has been released a long time ago.

Note You need to log in before you can comment on or make changes to this bug.