Bug 525035 - Selected language is not implemented
Selected language is not implemented
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-language (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: Translation
Depends On:
Blocks: 525052
  Show dependency treegraph
 
Reported: 2009-09-23 00:58 EDT by Noriko Mizumoto
Modified: 2009-10-27 03:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-06 01:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for gdm/daemon/Makefile.am gdm/daemon/gdm.in (1.25 KB, patch)
2009-09-28 03:24 EDT, fujiwara
no flags Details | Diff
patch for gdm/daemon/Makefile.am gdm/daemon/gdm-display.c gdm/daemon/gdm.in (1.86 KB, patch)
2009-09-28 04:10 EDT, fujiwara
no flags Details | Diff

  None (edit)
Description Noriko Mizumoto 2009-09-23 00:58:40 EDT
Description of problem:
This is feedback from Fedora 12 software translation review.
The selected language upon reboot will not be implemented.

Version-Release number of selected component (if applicable):
Live for Fedora 12 Software Translation Review
http://people.redhat.com/petersen/f12-l10n/

How reproducible:
always

Steps to Reproduce:
1. system => administration => languages
2. Select Italian
3.
  
Actual results:
Upon reboot, Italian is not implemented but English is used.

Expected results:
Upon reboot, Italian should be implemented.

Additional info:
Observed by it-IT
Comment 1 Pravin Satpute 2009-09-25 01:22:43 EDT
i think your gdm lang. selection, menu overwriting system-config-lanaguage changes,

can you check what is selected in GDM same time?
Comment 2 Matthias Clasen 2009-09-25 08:06:06 EDT
You need to clarify what you mean with 'implemented', maybe.

The language thats selected in system-config-language is expected to be used

a) in boot messages

b) on the login screen itself

Once you are logged in, the used language should be whatever you selected on the login screen.
Comment 3 Noriko Mizumoto 2009-09-27 21:46:11 EDT
ok, I've retried in my language of Japanese.

1. system => administration => languages => Choose 'Japanese'.
2. The message window popped up which says; 'The network or the Repos of Yum has some problems, do you want to continue? Yes will change the language but not install it. No will exit without changing the language.'
3. Clicked 'Yes'.
4. Another message window popped up which says; 'The change will take effect the next time you log in'.
5. clicked 'OK'.
6. Logged out manually.
7. In the login screen, clicked 'Log In'.
8. English was chosen.

In the '7' of the login screen, 'Language' selection at the bottom was 'English (United States)'. As the message of '4' says, this selection should be 'Japanese'. So that without re-selecting language at the login, but just clicking 'Log In' button will log into Japanese.
Comment 4 fujiwara 2009-09-28 03:24:56 EDT
Created attachment 362863 [details]
patch for gdm/daemon/Makefile.am gdm/daemon/gdm.in

After you click Log-in button, the language is based on the user but not the system.
So you should modify on the greeter GUI or $HOME/.dmrc directly.

The patch fixed the GDM login before you click Log-in button.
We had fixed the same issue in GDM 2.20 but it was lost in the latest.
Comment 5 fujiwara 2009-09-28 04:10:44 EDT
Created attachment 362864 [details]
patch for gdm/daemon/Makefile.am gdm/daemon/gdm-display.c gdm/daemon/gdm.in

Revised the patch so that $LANG can be set after users log out the session.
Comment 6 Pravin Satpute 2009-09-29 06:09:30 EDT
(In reply to comment #2)
> You need to clarify what you mean with 'implemented', maybe.
> 
> The language thats selected in system-config-language is expected to be used
> 
> a) in boot messages
> 
> b) on the login screen itself
> 
> Once you are logged in, the used language should be whatever you selected on
> the login screen.  

Matthias exactly this is what i wanted to say :)
Thanks for same

Noriko,

Just do a reboot instead of log off at 7 step in comment #3. you can see changes as written in comment #2.

i will modify that string is should be restart or next boot
Comment 7 Pravin Satpute 2009-09-29 06:22:02 EDT
(In reply to comment #4)
> Created an attachment (id=362863) [details]
> patch for gdm/daemon/Makefile.am gdm/daemon/gdm.in
> 
> After you click Log-in button, the language is based on the user but not the
> system.
> So you should modify on the greeter GUI or $HOME/.dmrc directly.
> 

Yep, it is good to have a default system language selection in GDM, when first time user login, then onward it will be as per his preference(whatever language he selected), since there can be many users whose language preferences can be different from system wide language.

> The patch fixed the GDM login before you click Log-in button.
> We had fixed the same issue in GDM 2.20 but it was lost in the latest.  

if system wide lang. @ reporters end working fine, we will change component to GDM for this bug 
or might be better to file a new bug for same
Comment 8 Noriko Mizumoto 2009-09-29 22:07:04 EDT
(In reply to comment #6)
> Just do a reboot instead of log off at 7 step in comment #3. you can see
> changes as written in comment #2.

Steps to Reproduce:
1. system => administration => languages => Choose 'Japanese'.
2. The message window popped up which says; 'The network or the Repos of Yum
has some problems, do you want to continue? Yes will change the language but
not install it. No will exit without changing the language.'
3. Clicked 'Yes'.
4. Another message window popped up which says; 'The change will take effect
the next time you log in'.
5. clicked 'OK'.
NOW-----
6. Rebooted manually.
7. Usual login screen came up (language selection was 'English'), and clicked 'Log In'.
8. English was chosen.

Actual results:
English was chosen.

Expected results:
Japanese should be chosen.

> 
> i will modify that string is should be restart or next boot  
Unfortunately, the change never take effect in this way.
Comment 9 fujiwara 2009-09-29 23:04:38 EDT
I'll separate a GDM bug in bugzilla.gnome.org in 2.30 timeframe.
If you wish s-c-l updates $HOME/.dmrc, I would think a new GUI would be needed in s-c-l.
Comment 10 Matthias Clasen 2009-09-29 23:12:12 EDT
s-c-l has no business updating .dmrc
Comment 11 Pravin Satpute 2009-10-01 06:13:44 EDT
Noriko,

can you put output of 
$cat /etc/sysconfig/i18n 
after step 6 

thanks
Comment 12 Noriko Mizumoto 2009-10-05 19:56:32 EDT
(In reply to comment #11)
> Noriko,
> 
> can you put output of 
> $cat /etc/sysconfig/i18n 
> after step 6 

Sure,

6. Rebooted manually.
7. Usual login screen came up (language selection was 'English'), and clicked
'Log In'.
8. English was chosen.
9. $cat /etc/sysconfig/i18n
   LANG="en_US.UTF-8"
Comment 13 Pravin Satpute 2009-10-06 01:42:07 EDT
Noriko, yep, restarting will not work in Live CD case as it will start new instance. Though as s-c-l modified /etc/sysconfig/i18n file

i have tested this with live cd mentioned in Bug
and things are working fine,
after selecting Japanese language from s-c-l it working fine.
$cat /etc/sysconfig/i18n gives me
LANG="ja_JP.UTF-8"

if got anything more on this please reopen this
Comment 14 Noriko Mizumoto 2009-10-06 03:49:41 EDT
Pravin, thank you for finding the cause!
I now fully understood what happened. 'liveinst' was failed and the bug 525022 has been filed.  This has already been resolved. Thus next review for F13, we should have successful 'liveinst' first, then we can get working s-c-l. Thank you again.
Comment 15 Jens Petersen 2009-10-27 03:18:13 EDT
If you want to have persistence with a Live image you can create it
with "livecd-iso-to-disk --overlay-size-mb ..." (a few hundred may
be enough).

Note You need to log in before you can comment on or make changes to this bug.