Bug 5252 - RHEA1999036 boot.img cannot complete installation without supp disk.
RHEA1999036 boot.img cannot complete installation without supp disk.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jay Turner
:
: 5417 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-09-20 12:30 EDT by bre
Modified: 2015-01-07 18:38 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-09-20 12:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bre 1999-09-20 12:30:47 EDT
The RHEA1999036 boot.img image from 9. sept. cannot complete
the installation (neither create a boot disk or install lilo to the HDD),
because the "loop.o" module found in /modules/ (during installation)
is compiled for the wrong kernel.

A workaround is to force the supp disk, it contains a usable loop.o
module.  Discovered when installing from floppy, I don't know if it is
a problem with CD-boot installations, although I'd assume it is since
they use the same image.

Thanks for RedHat... but please test your boot disks before releasing
them next! :-)
Comment 1 Bill Nottingham 1999-09-20 12:53:59 EDT
That is the intended behavior. From the announcement:
--
8. Solution:
   Three disks are needed for Intel based computers: "boot.img" or
"bootnet.img", "supp.img", and "modules.img". Choose "boot.img" for
local
   installs (CD-Rom, hard drive) or "bootnet.img" for network installs
(NFS, FTP, HTTP). Copy the three images to 1.44 MB floopy disks using:
dd
   if=file.img of=/dev/fd0 bs=72k under Linux or "rawrite.exe" under
DOS or Windows.

   After preparing the disk images, insert the appropriate boot disk
and boot the computer. At the boot prompt type "linux supp" and press
Enter.
   This tells the installer to load changes from the supplemental and
modules disks. The installer will prompt the user to insert the
supplemental
   disk and modules disk during the installation process.
Comment 2 Bill Nottingham 1999-09-21 15:22:59 EDT
*** Bug 5282 has been marked as a duplicate of this bug. ***

Unable to do the LILO portion of the install when just using
the bootnet.img boot disk.  Did not use the supp option for
using the supp and modules disks.

Discovered that the loop.o module on the bootnet.img disk
was compiled for kernel version: 2.2.5-14BOOT

While the kernel on the bootnet.img disk is version:
2.2.12-2.6.0BOOT

insmod refuses to load the loopback device driver which
appears to be causing the lilo and create boot disk portion
of the install to fail.
Comment 3 john.l.villalovos 1999-09-21 15:30:59 EDT
So the intended behaviour is for the install to go all the way to the
end and then fail because they didn't use the supp option?  And also
have the failure give no reason to the user on why it failed.

That seems like very poor intended behavior to me.  It is very low on
the user friendliness scale and I believe the install is supposed to
be user friendly :)

Can't you at least have it do the "linux supp" option by default?
Comment 4 Bill Nottingham 1999-09-24 23:41:59 EDT
*** Bug 5342 has been marked as a duplicate of this bug. ***

The september 9th boot image update for RH 6 doesn't work
correctly.  I updated my RH 6 CD with those updates. and
installed a system using the bootnet bootdisk, everything
went fine until I got to the "creating boot disk" and the
"lilo installation" sections.  The loop.o module would not
load due to a version conflict (loop.o is compiled for
2.2.5-15, and the kernel is ver 2.2.12)   So i couldn't
create a bootdisk nor install lilo.  I am right now trying a
bootdisk from another RH 6 dist with 2.2.5 and it won't
work. (I'll get it to boot, but please fix the boot disk
and/or update the kernel modules)
Comment 5 Bill Nottingham 1999-09-28 17:25:59 EDT
*** Bug 5417 has been marked as a duplicate of this bug. ***

The bootdisks are now based on kernel 2.2.12 but some
modules are based on 2.2.5, thus when I tried to install
using the new images, it reached up to the LILO
configuration and was trying to insert the module "loop.o"
and the LILO configurator was giving an error. I tried to
insert the module manually, and it gave me an error on the
kernel version.
Comment 6 Bill Nottingham 1999-11-11 15:45:59 EST
*** Bug 6880 has been marked as a duplicate of this bug. ****** Bug 6932 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.