Bug 525363 - Execute locale with a non existent locale name return success
Summary: Execute locale with a non existent locale name return success
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 525365 525367 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 03:31 UTC by Yang Ren
Modified: 2009-10-14 07:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-14 07:36:07 UTC


Attachments (Terms of Use)

Description Yang Ren 2009-09-24 03:31:06 UTC
Description of problem:
When execute locale with a non existent local name
the locale command execute success. The exit code should be 1.

And locale should included in glibc-common So I submit a bug here.

locale LC_NO_SUCH_CATEGORY_ANYWHERE

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

glibc-2.10.90-23.x86_64
glibc-common-2.10.90-23.x86_64


How reproducible:
Always

Steps to Reproduce:
1.type "locale LC_NO_SUCH_CATEGORY_ANYWHERE"
2.
3.
  
Actual results:
$? eq 0

Expected results:
$? eq 1

Additional info:
This is a part of POSIX test from opengroup.

Comment 1 Andreas Schwab 2009-09-24 09:35:01 UTC
*** Bug 525365 has been marked as a duplicate of this bug. ***

Comment 2 Andreas Schwab 2009-09-24 09:35:25 UTC
*** Bug 525367 has been marked as a duplicate of this bug. ***

Comment 3 Ulrich Drepper 2009-09-28 17:36:28 UTC
I've fixed this upstream.

Comment 4 Ulrich Drepper 2009-10-14 07:36:07 UTC
Should be in rawhide for a while.  Please test and reopen if necessary.


Note You need to log in before you can comment on or make changes to this bug.