Bug 525365 - Execute locale with a non existent category name return success
Summary: Execute locale with a non existent category name return success
Keywords:
Status: CLOSED DUPLICATE of bug 525363
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 03:37 UTC by Yang Ren
Modified: 2009-09-24 09:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-24 09:35:01 UTC


Attachments (Terms of Use)

Description Yang Ren 2009-09-24 03:37:24 UTC
Description of problem:
Execute locale with a non existent category name return success

Version-Release number of selected component (if applicable):
Linux localhost.localdomain 2.6.29.4-167.fc11.x86_64 #1 SMP Wed May 27 17:27:08
EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

glibc-2.10.90-23.x86_64
glibc-common-2.10.90-23.x86_64


How reproducible:
Always

Steps to Reproduce:
1.locale -c LC_NO_SUCH_CATEGORY_ANYWHERE
2.
3.
  
Actual results:
$? = 0

Expected results:
R? = 1

Additional info:
It's a part of POSIX shell test from opengroup.

Comment 1 Andreas Schwab 2009-09-24 09:35:01 UTC

*** This bug has been marked as a duplicate of bug 525363 ***


Note You need to log in before you can comment on or make changes to this bug.