This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 525477 - (sqlite3BtreeGetMeta) crash at sqlite3BtreeGetMeta()
crash at sqlite3BtreeGetMeta()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
12
i686 Linux
low Severity high
: ---
: ---
Assigned To: Panu Matilainen
Fedora Extras Quality Assurance
:
: gecko-64-crash 528385 533195 536369 537093 537638 537999 538793 539614 539934 540399 540657 540832 541539 541602 541640 541762 542143 542335 542387 542390 542527 543217 543351 543451 544054 544158 572471 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-09-24 10:32 EDT by Hongwen Qiu
Modified: 2010-03-11 14:53 EST (History)
36 users (show)

See Also:
Fixed In Version: 3.6.20-1.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 19:02:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
The ~/.xsession-errors file (91.85 KB, text/plain)
2009-09-24 10:32 EDT, Hongwen Qiu
no flags Details
gdb backtrace (6.29 KB, text/plain)
2009-09-25 04:42 EDT, Hongwen Qiu
no flags Details
gdb backtrace (67.80 KB, text/plain)
2009-09-25 09:52 EDT, Hongwen Qiu
no flags Details
gdb backtrace (34.87 KB, text/plain)
2009-09-25 11:02 EDT, Hongwen Qiu
no flags Details

  None (edit)
Description Hongwen Qiu 2009-09-24 10:32:14 EDT
Created attachment 362505 [details]
The ~/.xsession-errors file

Description of problem:
Firefox crashes every time when manage bookmarks through mouse clicks. Using the menus do not produce this problem, however.

Version-Release number of selected component (if applicable):
firefox-3.5.3-1.fc12.i686 xulrunner-1.9.1.3-1.fc12.i686

How reproducible:
Every time

Steps to Reproduce:
1. Click the star at the right corner of the address bar to add a bookmark of the current url.
2. Click the star again to open the bookmark editor dialog.
3. Click the "Choose..." item from the popup menu of the "folder" combox
  
Actual results:
Firefox crashes.

Expected results:
Let you choose a folder for the current bookmark to be moved into.

Additional info:
Comment 1 Martin Stransky 2009-09-24 14:15:16 EDT
Can you attach back-trace of the crash?
Comment 2 Hongwen Qiu 2009-09-25 00:49:44 EDT
(In reply to comment #1)
> Can you attach back-trace of the crash?  

I'm so sorry, but help is needed. I'm new to program debug. And just find out how to obtain back-trace. I run the following commands:
gdb /usr/lib/firefox-3.5.3/firefox 2>&1 | tee ~/gdb-firefox.txt
(gdb) handle SIG33 pass nostop noprint
(gdb) set pagination 0
(gdb) run
and followed the steps to reproduce the bug result, but firefox didn't crash, it hangs, and I can do nothing else. So I tried to kill the terminal process on another tty, and thought I might be able to do the debug on the other tty, but I do not know how to run a program on a particular tty, since firefox is a gui program. I searched the internet, but didn't see any information about this. I'm so sorry about it.
Comment 3 Martin Stransky 2009-09-25 01:41:07 EDT
Please install firefox-debuginfo (debuginfo-install is from
yum-utils package).

 debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of
gdb debugger. Then use command run and do whatever you did to make firefox
crash. When it happens, you should go back to the gdb and run

 (gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text
editor and attach the file to the bug as an uncompressed attachment.

Thanks in advance.
Comment 4 Hongwen Qiu 2009-09-25 02:04:56 EDT
(In reply to comment #3)
> Please install firefox-debuginfo (debuginfo-install is from
> yum-utils package).
> 
>  debuginfo-install firefox
> 
> Then run firefox with a parameter -g. That will start firefox running inside of
> gdb debugger. Then use command run and do whatever you did to make firefox
> crash. When it happens, you should go back to the gdb and run
> 
>  (gdb) thread apply all backtrace
> 
> This produces usually many screens of the text. Copy all of them into a text
> editor and attach the file to the bug as an uncompressed attachment.
> 
> Thanks in advance.  

Maybe you did not understand me. I mean, I now know how to obtain backtrace, but the firefox running from gdb, did not crash, instead, it hangs, and makes the actions to the current tty have no effects, so I have to kill the terminal in another tty, since the firefox and the tty process ID can not be killed. As a result, I can not obtain the backtrace, for the gdb has already forced out without completed. So, I think, I may have to run gdb on another tty without gui, and then start firefox in gdb but put it on the gui tty, then we can act to produce the bug. But, the problem is that, I don't know the method to specify a tty when execute a command through command line. Ask again for help. And thanks for the reply.
Comment 5 Martin Stransky 2009-09-25 02:17:13 EDT
If the firefox/debugger/whatever hangs you can attach the debugger directly to it by gdb --pid=xxx where xxx is a PID of the process. And then you can gen the backtrace...
Comment 6 Hongwen Qiu 2009-09-25 04:42:38 EDT
Created attachment 362644 [details]
gdb backtrace
Comment 7 Hongwen Qiu 2009-09-25 04:48:51 EDT
(In reply to comment #5)
> If the firefox/debugger/whatever hangs you can attach the debugger directly to
> it by gdb --pid=xxx where xxx is a PID of the process. And then you can gen the
> backtrace...  

Sorry again, but following your instructions produce nothing. I execute the command
gdb --pid=2223, in which 2223 referred to the firefox's PID, and the command
thread apply all backtrace
produced nothing
I tried the command
backtrace full
it said "No stack"
and I tried to point the pid to the gdb that hanged up with firefox, and it generates the result in the attachment.
I think it may be useless. And, I have to know how to execute a gui program on a specified tty, so that maybe the tty running firefox hanged up, but I can still use the gdb to get the results, or maybe there are some thing else I don't know.
So sorry again.
Comment 8 Martin Stransky 2009-09-25 05:45:11 EDT
I wonder why the whole debugging session hangs. Try to run firefox as 'firefox -g" and then try to run it from the debugger (by run gdb command). You should be able to break the debugging session by CTRL+C (from the gdb console).
Comment 9 Matěj Cepl 2009-09-25 06:25:11 EDT
(In reply to comment #4)
> Maybe you did not understand me. I mean, I now know how to obtain backtrace,

Are you sure? Nothing against you, but firefox is a strange beast -- running

gdb /usr/lib64/firefox*/firefox

gives very different results than

firefox -g

(which is the canonical way how to run firefox inside of gdb)
Comment 10 Hongwen Qiu 2009-09-25 09:30:11 EDT
(In reply to comment #9)
> (In reply to comment #4)
> > Maybe you did not understand me. I mean, I now know how to obtain backtrace,
> 
> Are you sure? Nothing against you, but firefox is a strange beast -- running
> 
> gdb /usr/lib64/firefox*/firefox
> 
> gives very different results than
> 
> firefox -g
> 
> (which is the canonical way how to run firefox inside of gdb)  

Really the result is different? Anyhow, actually, I followed the two procedures, but the results are almost the same. And, Firefox on my system is the 32 version.
Comment 11 Hongwen Qiu 2009-09-25 09:52:20 EDT
Created attachment 362677 [details]
gdb backtrace
Comment 12 Hongwen Qiu 2009-09-25 09:57:48 EDT
(In reply to comment #1)
> Can you attach back-trace of the crash?  

The backtrace is attached. Finally, I find out the tips about specify a particular tty for a program. And I run the following command from tty2
firefox -g --display :0 2>&1 | tee gdb-firefox.txt
(gdb)run
and shifted to tty1 to follow the steps to produce the bug results, and turned to tty1, in which I haven't to do CTRL-C, for gdb gave me the prompt, and I run
thread apply all backtrace
so now, due to the backtrace result.
Thanks for your attention.
Comment 13 Martin Stransky 2009-09-25 10:26:39 EDT
0x05bcdcbe in ?? () from /usr/lib/libsqlite3.so.0

The crash is inside sqlite (a database engine). Please install sqlite-debuginfo package and try to get the backtrace again (we need symbols from /usr/lib/libsqlite3.so.0)
Comment 14 Hongwen Qiu 2009-09-25 11:02:54 EDT
Created attachment 362683 [details]
gdb backtrace
Comment 15 Martin Stransky 2009-09-25 11:06:44 EDT
Cool. Moving to sqlite component...
Comment 16 Martin Stransky 2009-09-29 06:18:41 EDT
*** Bug 524504 has been marked as a duplicate of this bug. ***
Comment 17 Bug Zapper 2009-11-16 07:51:30 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 18 Stephen P. Schaefer 2009-11-17 03:21:59 EST
Needless to say, this needs to be fixed.

Meanwhile:

For those of us who need to file a bookmark, I found that
(a) backup/exporting my bookmarks
(b) exiting firefox
(c) removing $HOME/.mozilla/firefox/12345678.default/places.sqlite*
(d) restarting firefox

...managed to preserve my bookmarks and make the crash go away.  The bookmarks must be stored in some alternate form elsewhere, because I never needed to explicitly restore them.
Comment 19 Panu Matilainen 2009-11-17 04:28:28 EST
*** Bug 537093 has been marked as a duplicate of this bug. ***
Comment 20 Panu Matilainen 2009-11-17 04:29:40 EST
*** Bug 536369 has been marked as a duplicate of this bug. ***
Comment 21 Panu Matilainen 2009-11-17 04:32:43 EST
*** Bug 528385 has been marked as a duplicate of this bug. ***
Comment 22 Panu Matilainen 2009-11-17 04:34:27 EST
*** Bug 533195 has been marked as a duplicate of this bug. ***
Comment 23 Matěj Cepl 2009-11-17 07:29:48 EST
*** Bug 537999 has been marked as a duplicate of this bug. ***
Comment 24 Martin Stransky 2009-11-18 09:26:16 EST
*** Bug 537638 has been marked as a duplicate of this bug. ***
Comment 25 Panu Matilainen 2009-11-19 07:37:10 EST
A possible (although sledgehammerish) fix is to update sqlite to 3.6.20 which doesn't seem to have this issue. Test reports welcome, until it becomes available in rawhide you can grab 3.6.20 from here: http://koji.fedoraproject.org/koji/taskinfo?taskID=1816182
Comment 26 Matěj Cepl 2009-11-20 11:00:27 EST
*** Bug 538793 has been marked as a duplicate of this bug. ***
Comment 27 Matěj Cepl 2009-11-23 20:01:58 EST
*** Bug 539934 has been marked as a duplicate of this bug. ***
Comment 28 Fedora Update System 2009-11-24 02:19:03 EST
sqlite-3.6.20-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/sqlite-3.6.20-1.fc12
Comment 29 Mihai Harpau 2009-11-24 15:19:04 EST
With sqlite-3.6.20-1.fc12 I can save any url page in any bookmark sub-menu from "Bookmarks Menu". Many thanks!
Comment 30 Fedora Update System 2009-11-25 10:30:26 EST
sqlite-3.6.20-1.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update sqlite'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12178
Comment 31 Matěj Cepl 2009-11-25 11:46:07 EST
*** Bug 540399 has been marked as a duplicate of this bug. ***
Comment 32 Matěj Cepl 2009-11-25 11:58:17 EST
*** Bug 540657 has been marked as a duplicate of this bug. ***
Comment 33 Matěj Cepl 2009-11-25 12:40:25 EST
*** Bug 540832 has been marked as a duplicate of this bug. ***
Comment 34 Matěj Cepl 2009-11-25 18:43:45 EST
*** Bug 539614 has been marked as a duplicate of this bug. ***
Comment 35 Matěj Cepl 2009-12-02 09:47:03 EST
*** Bug 541602 has been marked as a duplicate of this bug. ***
Comment 36 Matěj Cepl 2009-12-02 09:47:57 EST
*** Bug 541539 has been marked as a duplicate of this bug. ***
Comment 37 Matěj Cepl 2009-12-02 09:48:21 EST
*** Bug 541640 has been marked as a duplicate of this bug. ***
Comment 38 Matěj Cepl 2009-12-02 09:48:45 EST
*** Bug 541762 has been marked as a duplicate of this bug. ***
Comment 39 Matěj Cepl 2009-12-02 09:49:08 EST
*** Bug 542335 has been marked as a duplicate of this bug. ***
Comment 40 Matěj Cepl 2009-12-02 09:49:46 EST
*** Bug 542390 has been marked as a duplicate of this bug. ***
Comment 41 Matěj Cepl 2009-12-02 09:50:29 EST
*** Bug 542527 has been marked as a duplicate of this bug. ***
Comment 42 Matěj Cepl 2009-12-02 09:50:50 EST
*** Bug 543217 has been marked as a duplicate of this bug. ***
Comment 43 Matěj Cepl 2009-12-02 17:39:12 EST
*** Bug 543351 has been marked as a duplicate of this bug. ***
Comment 44 Fedora Update System 2009-12-04 19:02:20 EST
sqlite-3.6.20-1.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 45 Matěj Cepl 2009-12-05 20:41:12 EST
*** Bug 544054 has been marked as a duplicate of this bug. ***
Comment 46 Matěj Cepl 2009-12-05 20:41:46 EST
*** Bug 544158 has been marked as a duplicate of this bug. ***
Comment 47 Matěj Cepl 2009-12-09 18:49:11 EST
*** Bug 542387 has been marked as a duplicate of this bug. ***
Comment 48 Matěj Cepl 2009-12-09 18:49:11 EST
*** Bug 542143 has been marked as a duplicate of this bug. ***
Comment 49 Matěj Cepl 2009-12-14 10:30:21 EST
*** Bug 543451 has been marked as a duplicate of this bug. ***
Comment 50 Chris Campbell 2010-03-11 14:53:55 EST
*** Bug 572471 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.