Bug 528385 - Attempting to add Bookmarks crashes FFox
Summary: Attempting to add Bookmarks crashes FFox
Keywords:
Status: CLOSED DUPLICATE of bug 525477
Alias: None
Product: Fedora
Classification: Fedora
Component: sqlite
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-11 19:22 UTC by Robert Lightfoot
Modified: 2018-04-11 11:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-11-17 09:32:43 UTC
Type: ---


Attachments (Terms of Use)
Terminal Output from gdb during a test (5.62 KB, application/x-bzip)
2009-10-17 02:16 UTC, Robert Lightfoot
no flags Details
Pictures of the Terminal and FireFox when it crashed (4.35 MB, application/x-bzip)
2009-10-17 02:20 UTC, Robert Lightfoot
no flags Details
A screenshot from the tarball (1.64 MB, image/jpeg)
2009-10-21 07:21 UTC, Matěj Cepl
no flags Details
A screenshot from the tarball (1.75 MB, image/jpeg)
2009-10-21 07:22 UTC, Matěj Cepl
no flags Details
A screenshot from the tarball (1012.19 KB, image/jpeg)
2009-10-21 07:23 UTC, Matěj Cepl
no flags Details
Uncompressed attempt to catch backtrace (30.00 KB, text/plain)
2009-10-21 07:24 UTC, Matěj Cepl
no flags Details
mcepl's requested Firefox Backtrace 2009-10-27 (1.86 KB, text/plain)
2009-10-28 02:50 UTC, Robert Lightfoot
no flags Details
mcepl's requested Firefox Backtrace 2009-10-27 Attempt Number 2 (19.22 KB, text/plain)
2009-10-28 03:33 UTC, Robert Lightfoot
no flags Details
/var/log/Xorg.0.log (224.42 KB, text/plain)
2009-10-29 02:01 UTC, Robert Lightfoot
no flags Details
/home/Bob/testing/dmesg.txt (37.38 KB, text/plain)
2009-10-29 02:04 UTC, Robert Lightfoot
no flags Details
/tmp/firefox-backtrace3.txt (20.87 KB, text/plain)
2009-10-29 02:08 UTC, Robert Lightfoot
no flags Details

Description Robert Lightfoot 2009-10-11 19:22:16 UTC
Description of problem:
Select Bookmarks -- Bookmark this Page and then try to select a location.  Firefox will crash.

Version-Release number of selected component (if applicable):
vERSION 3.5.3

How reproducible:
Select Bookmarks -- Bookmark this Page and then try to select a location.  Firefox will crash.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Matěj Cepl 2009-10-14 14:13:21 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

First of all, could we get output of the command

	rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

Please also install firefox-debuginfo (debuginfo-install is from
yum-utils package).

	debuginfo-install firefox

Then run firefox with a parameter -g. That will start firefox running inside of gdb debugger. Then use command run and do whatever you did to make firefox crash. When it happens, you should go back to the gdb and run

	(gdb) thread apply all backtrace

This produces usually many screens of the text. Copy all of them into a text editor and attach the file to the bug as an uncompressed attachment.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 2 Robert Lightfoot 2009-10-16 02:10:56 UTC
REQUEST FOR DATA RESPONSE TO 
rpm -qa *xulrun* *firefox* *mozilla* *flash* *plugin*

xfce4-battery-plugin-0.5.1-4.fc12.i686
xfce4-xkb-plugin-0.5.3.3-1.fc12.i686
xfce4-quicklauncher-plugin-1.9.4-7.fc12.i686
alsa-plugins-pulseaudio-1.0.21-2.fc12.i686
claws-mail-plugins-vcalendar-3.7.2-3.fc12.i686
setroubleshoot-plugins-2.1.23-1.fc12.noarch
mozilla-filesystem-1.9-5.fc12.i686
xfce4-places-plugin-1.2.0-1.fc12.i686
xfce4-clipman-plugin-1.1.0-1.fc12.i686
xfce4-sensors-plugin-0.10.99.6-5.fc12.i686
xfce4-cpugraph-plugin-0.4.0-6.fc12.i686
claws-mail-plugins-pgp-3.7.2-2.fc12.i686
claws-mail-plugins-att-remover-3.7.2-3.fc12.i686
claws-mail-plugins-rssyl-3.7.2-3.fc12.i686
plymouth-plugin-two-step-0.8.0-0.2009.29.09.9.fc12.i686
swfdec-mozilla-0.9.2-3.fc12.i686
PackageKit-yum-plugin-0.5.3-1.fc12.i686
abrt-plugin-kerneloopsreporter-0.0.9-2.fc12.i686
yum-plugin-fastestmirror-1.1.23-3.fc12.noarch
gstreamer-plugins-base-0.10.25-1.fc12.i686
anaconda-yum-plugins-1.0-5.fc12.noarch
xulrunner-1.9.1.3-1.fc12.i686
xfce4-dict-plugin-0.5.3-3.fc12.i686
xfce4-cellmodem-plugin-0.0.5-2.fc12.i686
xfce4-verve-plugin-0.3.6-4.fc12.i686
xfce4-mailwatch-plugin-1.1.0-4.fc12.i686
xfce4-screenshooter-plugin-1.6.0-2.fc12.i686
xfce4-smartbookmark-plugin-0.4.2-10.fc12.i686
xfce4-fsguard-plugin-0.4.2-4.fc12.i686
xfce4-genmon-plugin-3.2-4.fc12.i686
claws-mail-plugins-attachwarner-3.7.2-3.fc12.i686
claws-mail-plugins-bogofilter-3.7.2-2.fc12.i686
claws-mail-plugins-fetchinfo-3.7.2-3.fc12.i686
claws-mail-plugins-newmail-3.7.2-3.fc12.i686
firefox-3.5.3-1.fc12.i686
abrt-plugin-sqlite3-0.0.9-2.fc12.i686
thunar-archive-plugin-0.2.4-7.fc12.i686
xfce4-netload-plugin-0.4.0-12.fc12.i686
xfce4-weather-plugin-0.7.3-1.fc12.i686
xfce4-timer-plugin-0.6.1-4.fc12.i686
xfce4-datetime-plugin-0.6.1-4.fc12.i686
xfce4-notes-plugin-1.7.1-1.fc12.i686
java-1.6.0-openjdk-plugin-1.6.0.0-31.b16.fc12.i686
totem-mozplugin-2.28.1-3.fc12.i686
claws-mail-plugins-notification-3.7.2-3.fc12.i686
claws-mail-plugins-archive-3.7.2-3.fc12.i686
claws-mail-plugins-spam-report-3.7.2-3.fc12.i686
claws-mail-plugins-mailmbox-3.7.2-3.fc12.i686
xfce4-time-out-plugin-0.1.1-4.fc12.i686
xfce4-diskperf-plugin-2.2.0-5.fc12.i686
xfce4-systemload-plugin-0.4.2-8.fc12.i686
claws-mail-plugins-tnef-3.7.2-3.fc12.i686
claws-mail-plugins-smime-3.7.2-2.fc12.i686
plymouth-plugin-label-0.8.0-0.2009.29.09.9.fc12.i686
abrt-plugin-bugzilla-0.0.9-2.fc12.i686
flash-plugin-10.0.32.18-release.i386
thunar-media-tags-plugin-0.1.2-7.fc12.i686
xfce4-mount-plugin-0.5.5-4.fc12.i686
xfce4-eyes-plugin-4.4.0-7.fc12.i686
xfce4-websearch-plugin-0.1.1-0.12.20070428svn2704.fc12.i686
claws-mail-plugins-cachesaver-3.7.2-3.fc12.i686
gstreamer-plugins-good-0.10.16-1.fc12.i686
gstreamer-plugins-flumpegdemux-0.10.15-7.fc12.i686

Comment 3 Robert Lightfoot 2009-10-16 02:52:27 UTC
DON'T THINK I AM DOING SOMETHING CORRECTLY. 
THE FOLLOWING NEVER OPENED FIREFOX - I HAD TO LAUNCH IT FROM THE PANEL
THE APPLY ...BACKTRACE PRODUCES NO OUTPUT

[Bob@D8MNKD81 Desktop]$ firefox -g
MOZILLA_FIVE_HOME=/usr/lib/firefox-3.5.3
  LD_LIBRARY_PATH=/usr/lib/firefox-3.5.3:/usr/lib/firefox-3.5.3/plugins:/usr/lib/firefox-3.5.3
DISPLAY=:0.0
FONTCONFIG_PATH=/etc/fonts:/usr/lib/firefox-3.5.3/res/Xft
DYLD_LIBRARY_PATH=/usr/lib/firefox-3.5.3:/usr/lib/firefox-3.5.3
     LIBRARY_PATH=/usr/lib/firefox-3.5.3:/usr/lib/firefox-3.5.3/components:/usr/lib/firefox-3.5.3
       SHLIB_PATH=/usr/lib/firefox-3.5.3:/usr/lib/firefox-3.5.3
          LIBPATH=/usr/lib/firefox-3.5.3:/usr/lib/firefox-3.5.3
       ADDON_PATH=/usr/lib/firefox-3.5.3
      MOZ_PROGRAM=/usr/lib/firefox-3.5.3/firefox
      MOZ_TOOLKIT=
        moz_debug=1
     moz_debugger=
which: no ddd in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/Bob/bin)
/usr/bin/gdb /usr/lib/firefox-3.5.3/firefox -x /tmp/mozargs.iwLs4C
GNU gdb (GDB) Fedora (6.8.91.20090930-2.fc12)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/firefox-3.5.3/firefox...Reading symbols from /usr/lib/debug/usr/lib/xulrunner-1.9.1/xulrunner-stub.debug...done.
done.
(gdb) thread apply all backtrace
(gdb)

Comment 4 Robert Lightfoot 2009-10-17 02:16:01 UTC
Created attachment 365110 [details]
Terminal Output from gdb during a test

Compilation of Terminal Output during a crash test.

Comment 5 Robert Lightfoot 2009-10-17 02:20:42 UTC
Created attachment 365111 [details]
Pictures of the Terminal and FireFox when it crashed

Since the crash from withing gdb hosed X I took this series of snaps to document what I could.  Sorry for the poor quality.  Only a 3.5 MP Camera available.

Comment 6 Robert Lightfoot 2009-10-17 02:26:06 UTC
Figured out that I need to type run at the first (gdb) to conduct the test at all.  Comments 4 and 5 above go with uploaded files from the test.

Comment 7 Matěj Cepl 2009-10-21 07:21:26 UTC
Created attachment 365468 [details]
A screenshot from the tarball

Comment 8 Matěj Cepl 2009-10-21 07:22:26 UTC
Created attachment 365469 [details]
A screenshot from the tarball

Comment 9 Matěj Cepl 2009-10-21 07:23:10 UTC
Created attachment 365470 [details]
A screenshot from the tarball

Comment 10 Matěj Cepl 2009-10-21 07:24:27 UTC
Created attachment 365471 [details]
Uncompressed attempt to catch backtrace

Comment 11 Robert Lightfoot 2009-10-26 23:25:27 UTC
Recreated this bug running firefox -g from a terminal and it "hoses" the X-session.  Run as root and the problem does not exist.  Anyone with a suggestion how to trap this bug.  It is 100 percent repeatable on my hardware.

Comment 12 Matěj Cepl 2009-10-27 11:23:22 UTC
(In reply to comment #10)
> Created an attachment (id=365471) [details]
> Uncompressed attempt to catch backtrace  

Just to note that the latest readable line from the backtrace is:

Program received signal SIGSEGV, Segmentwtion fault.
0x04512cbe in ?? () from /usr/lib/ligsqlite3.so.0

which is not exactly helpful. a) apparently you don't have -debuginfo packages for sqlite3 (debuginfo-install sqlite3 would take care of that), b) we are missing part of the analysis (actually, most likely the only part) where it gets interesting.

It you didn't try to run in gdb command

thread apply all backtrace

and give us the output from that.

Comment 13 Matěj Cepl 2009-10-27 12:16:02 UTC
Or, I've got an idea ... run firefox, and when it crashes (after reboot if needed), go to /var/cache/abrt/ and find a directory which was created during your crash (by ls -l and comparing time). Enter that directory and run

gdb -nx --batch -ex 'thread apply all backtrace' \
    --core=coredump >/tmp/firefox-backtrace.txt 2>/dev/null

If everything's all right, attach /tmp/firefox-backtrace.txt to this bug.

Thank you very much.

Comment 14 Robert Lightfoot 2009-10-28 02:50:02 UTC
Created attachment 366374 [details]
mcepl's requested Firefox Backtrace 2009-10-27

2009-10-27 - test attempt notes

1.  <debuginfo-install sqlite3> to add requested data collection package responded no debuginfo packages available for install.  I have rawhide, livna, rpmfusion-free and rpmfusion-nonfree repos activated.  

2.   rpm -qa | grep debuginfo output follows:
glib2-debuginfo-2.22.2-1.fc12.i686
gnome-vfs2-debuginfo-2.24.2-1.fc12.i686
kernel-debuginfo-common-i686-2.6.31.5-96.fc12.i686
nspr-debuginfo-4.8-2.fc12.i686
cairo-debuginfo-1.8.8-3.fc12.i686
startup-notification-debuginfo-0.10-2.fc12.i686
pango-debuginfo-1.26.0-1.fc12.i686
glibc-debuginfo-2.10.90-24.i686
atk-debuginfo-1.28.0-1.fc12.i686
freetype-debuginfo-2.3.9-6.fc12.i686
gtk2-debuginfo-2.18.2-2.fc12.i686
GConf2-debuginfo-2.28.0-2.fc12.i686
gcc-debuginfo-4.4.1-20.fc12.i686
libtdb-debuginfo-1.1.5-2.fc12.i686
alsa-lib-debuginfo-1.0.21-3.fc12.i686
firefox-debuginfo-3.5.3-1.fc12.i686
fontconfig-debuginfo-2.7.3-1.fc12.i686
xulrunner-debuginfo-1.9.1.3-1.fc12.i686
kernel-debuginfo-2.6.31.5-96.fc12.i686

3.  Note : rpm -qa |grep firefox
firefox-3.5.3-1.fc12.i686
firefox-debuginfo-3.5.3-1.fc12.i686

4.   Opened Terminal as standard user and ran command <firefox -g>  

5.   When display reached gdb typed run and pressed enter.

6.   Firefox started graphically

7.   Used mouse to select Bookmarks -- Bookmark this Page

8.   Using mouse selected Folder Choose Folder Menu Options

9.   Experienced the "lockup issue" of the graphic session.

10.   Issue <CTRL><ALT><F3> to get command line session

11.  Login command line session and run ps axu | grep firefox.
Bob   4244  0.0  0.2   4952  1172 pts/1    S    22:20   0:00 /bin/sh  /usr/lib/firefox-3.5.3/run-mozilla.sh -g /usr/lib/firefox-3.5.3/firefox
Bob   4265  0.7 16.5  96152 83200 pts/1    S    22:20   0:03 /usr/bin/gdb /usr/lib/firefox-3.5.3/firefox -x /tmp/mozargs.zaYJbc
Bob   4337  1.0 10.5 234016 53016 pts/1    Tl   22:20   0:04 /usr/lib/firefox-3.5.3/firefox
Bob   5408  0.0  0.1   4244   696 tty3     S+   22:27   0:00 grep firefox

12.  Issue kill -9 4244 which made no improvement to graphic session.

13.  Issue kill -9 4265 which recovered the graphic session.

14.  ls -lt /var/cache/abrt produced following
-rw-r--r--. 1 root root 7168 2009-10-27 22:28 abrt-db
drwx------. 2 Bob  Bob  4096 2009-10-27 22:28 ccpp-1256696891-4337
drwx------. 2 root root 4096 2009-10-26 17:37 kerneloops-1256593039-1
drwx------. 2 root root 4096 2009-10-24 12:30 kerneloops-1256401854-1
drwx------. 2 root root 4096 2009-10-23 23:10 kerneloops-1256353838-1
drwx------. 2 root root 4096 2009-10-23 23:02 kerneloops-1256353358-1
drwx------. 2 root root 4096 2009-10-23 23:00 kerneloops-1256353238-1
drwx------. 2 root root 4096 2009-10-23 22:22 kerneloops-1256350958-1
drwx------. 2 root root 4096 2009-10-23 22:20 kerneloops-1256350838-1
drwx------. 2 root root 4096 2009-10-23 22:18 kerneloops-1256350718-1
drwx------. 2 root root 4096 2009-10-23 22:16 kerneloops-1256350598-1
drwx------. 2 root root 4096 2009-10-23 22:12 kerneloops-1256350358-1
drwx------. 2 root root 4096 2009-10-23 22:10 kerneloops-1256350238-1
drwx------. 2 root root 4096 2009-10-23 22:08 kerneloops-1256350118-1
drwx------. 2 root root 4096 2009-10-23 21:43 kerneloops-1256348579-1
drwx------. 2 root root 4096 2009-10-23 20:34 kerneloops-1256344470-1
drwx------. 2 root root 4096 2009-10-20 18:22 pyhook-1256076838-2256
drwx------. 2 root root 4096 2009-10-19 17:30 kerneloops-1255987799-1
drwx------. 2 root root 4096 2009-10-11 17:32 ccpp-1255296760-2876
drwx------. 2 root root 4096 2009-10-11 16:46 ccpp-1255293998-17685
drwx------. 2 root root 4096 2009-10-03 20:18 kerneloops-1254615515-1
drwx------. 2 root root 4096 2009-10-03 14:15 kerneloops-1254593746-1
drwx------. 2 root root 4096 2009-10-03 11:01 kerneloops-1254582064-1
drwx------. 2 root root 4096 2009-10-02 22:46 kerneloops-1254537994-1
drwx------. 2 root root 4096 2009-10-02 20:57 kerneloops-1254531474-1
drwx------. 2 root root 4096 2009-10-01 18:10 kerneloops-1254435011-1
drwx------. 2 root root 4096 2009-09-30 20:28 kerneloops-1254356881-1
drwx------. 2 root root 4096 2009-09-29 23:39 kerneloops-1254281962-1
drwx------. 2 root root 4096 2009-09-28 22:22 kerneloops-1254190945-1
drwx------. 2 root root 4096 2009-09-28 19:35 kerneloops-1254180902-1
drwx------. 2 root root 4096 2009-09-28 19:29 kerneloops-1254180542-1
drwx------. 2 root root 4096 2009-09-28 18:59 kerneloops-1254178746-1

15.   cd /var/cache/abrt/ccpp-1256696891-4337

16.  ran command gdb -nx --batch -ex 'thread apply all backtrace' \
    --core=coredump >/tmp/firefox-backtrace.txt 2>/dev/null

17.  find firefox-backtrace.txt attached

Comment 15 Robert Lightfoot 2009-10-28 03:33:53 UTC
Created attachment 366382 [details]
mcepl's requested Firefox Backtrace 2009-10-27 Attempt Number 2

Found package sqlite-debuginfo.3.6.17-1.fc12.i686 and installed.

Repeated firefox -g thru crash steps

captured this data

Comment 16 Robert Lightfoot 2009-10-29 02:01:46 UTC
Created attachment 366529 [details]
/var/log/Xorg.0.log

mcepl requested /var/log/Xorg.0.log

Comment 17 Robert Lightfoot 2009-10-29 02:04:25 UTC
Created attachment 366530 [details]
/home/Bob/testing/dmesg.txt

/home/Bob/testing/dmesg.txt

Comment 18 Robert Lightfoot 2009-10-29 02:08:24 UTC
Created attachment 366531 [details]
/tmp/firefox-backtrace3.txt

/tmp/firefox-backtrace3.txt

Comment 19 Matěj Cepl 2009-10-29 02:43:14 UTC
Information from IRC chat with reporter:

[03:29:58] mcepl: that /var/log/Xorg.0.log is what you've got AFTER the crash
of Xorg and BEFORE you restarted X?
[03:31:05] BobLfoot: mcepl : after crash of FFox, after Kill -9 of FFox and
before any reboots or restarts of X yes
[03:32:41] mcepl: and just to be sure I understand -- after firefox crashes,
Xorg freezes or they restart?
[03:33:29] BobLfoot: Xorg freezes - the kill -9's of ffox processes thaws it. 
No restarts or reboots
[03:34:04] mcepl: Oh cool
[03:34:28] mcepl: if you wait couple of minutes ... does it thaw by itself or
is it frozen forever?

[03:35:57] BobLfoot: I let it set overnight and no thaw

Comment 20 Matěj Cepl 2009-10-29 03:56:52 UTC
Clicking on "Choose" button is what made the trick for me. When trying on reporter's machine (over vnc) I was able to reproduce it by clicking on the button choose in the bookmark folder.

No process takes 100%CPU, but it is necessary to kill -9 firefox to get it working again. And backtrace says something about sqlite3 as well.

Reassigning there.

Comment 21 Robert Lightfoot 2009-10-29 04:01:39 UTC
(In reply to comment #20)
> Clicking on "Choose" button is what made the trick for me. When trying on
> reporter's machine (over vnc) I was able to reproduce it by clicking on the
> button choose in the bookmark folder.
> 
> No process takes 100%CPU, but it is necessary to kill -9 firefox to get it
> working again. And backtrace says something about sqlite3 as well.
> 
> Reassigning there.  

x11vnc was not added to crashing machine until today - to assist redhat tech.

Comment 22 Matěj Cepl 2009-10-29 11:16:09 UTC
(In reply to comment #21)
> x11vnc was not added to crashing machine until today - to assist redhat tech.  

I was not pointing towards x11vnc, I just first thought Xorg crashes (which it apparently doesn't), which would lead to Xorg bug -- however stupidly behaving app shouldn't make Xorg crash.

Comment 23 Robert Lightfoot 2009-10-29 19:34:17 UTC
I concur - the reference to x11vnc was for the benefit of others and to document when we added it to the mix of software And to establish that it was not present when the "bug" first appeared.

Comment 24 Robert Lightfoot 2009-11-07 04:23:28 UTC
Recent Updates and my additional research may have isolated what is happening with this bug somewhat.

Using Firefox 3.5.4-1; kernel 2.6.31.5-122 and xmarks 3.3.2 will cause the system to crash if you try and add a bookmark.  Without installing xmarks 3.3.2 the system functions normally.  Removing xmarks does not recover the system.  The .mozilla folder must be deleted and a new one restored by Firefox.

Comment 25 Bug Zapper 2009-11-16 13:31:46 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 26 Panu Matilainen 2009-11-17 09:32:43 UTC

*** This bug has been marked as a duplicate of bug 525477 ***


Note You need to log in before you can comment on or make changes to this bug.