Bug 525551 - gnome-do is crashing after a while
Summary: gnome-do is crashing after a while
Keywords:
Status: CLOSED DUPLICATE of bug 530757
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-do
Version: 12
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Sindre Pedersen Bjørdal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-24 19:25 UTC by Renich Bon Ciric
Modified: 2010-03-17 06:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-03-17 06:00:55 UTC


Attachments (Terms of Use)

Description Renich Bon Ciric 2009-09-24 19:25:09 UTC
Description of problem:
gnome-do crashes after login. Tipically, within 30 mins after. Then, after restart, it doesn't return any results (no terminal, no searches, nothing)

Version-Release number of selected component (if applicable):
0.8.2-2

How reproducible:
Install gnome-do and plugins. Activate some. Reboot. Wait for 30 mins and try using gnome-do. If crashed, restart gnome-do again and try using it.

Steps to Reproduce:
1. Install gnome-do and it's plugins
2. Reboot
3. Wait for the crash within 30 mins
4. Restart gnome-do
5. Try using it.
  
Actual results:
gnome-do crashes within 30 mins. When restarted, it doesn't give any results.

Expected results:
gnome-do should not crash... obviously.

Additional info:
I haven't been able to get error messages... but this, while starting from commandline and, btw, super+<spacebar> doesn't work anymore if started like this.

[renich@introdesk Desktop]$ date
Thu Sep 24 14:13:17 CDT 2009
[renich@introdesk Desktop]$ gnome-do

(Do:2877): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

Comment 1 Renich Bon Ciric 2009-11-05 19:32:18 UTC
ping!

Guys, it keeps crashing!

Comment 2 Renich Bon Ciric 2009-11-15 03:53:57 UTC
ahh! it keeps crashing! mayday! mayday! ping! piiiiing!

Comment 3 Bug Zapper 2009-11-16 12:52:23 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 4 Renich Bon Ciric 2009-12-12 20:18:51 UTC
not solved! ping!

Comment 5 Adam Huffman 2010-01-18 12:54:55 UTC
Yes, something similar is still happening for me with the latest version 0.8.3 on F12.

Here's what I see when gnome-do is launched from a terminal:

(/usr/lib64/gnome-do/Do.exe:12529): GLib-WARNING **: g_set_prgname() called multiple times

(/usr/lib64/gnome-do/Do.exe:12529): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.

Delicious.BookmarksItemSource "Del.icio.us bookmarks" encountered an error in Items: System.ArgumentNullException: Argument cannot be null.
Parameter name: source
  at System.Linq.Check.Source (System.Object source) [0x00000] 
  at System.Linq.Enumerable.ToArray[Item] (IEnumerable`1 source) [0x00000] 
  at Do.Universe.Safe.SafeItemSource.get_Items () [0x00000] .
Delicious.BookmarksItemSource "Del.icio.us bookmarks" encountered an error in Items: System.ArgumentNullException: Argument cannot be null.
Parameter name: source
  at System.Linq.Check.Source (System.Object source) [0x00000] 
  at System.Linq.Enumerable.ToArray[Item] (IEnumerable`1 source) [0x00000] 
  at Do.Universe.Safe.SafeItemSource.get_Items () [0x00000] .
[Error 10:08:26.829] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:08:26.837] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:08:26.843] [RTM] Not authorized to use a Remember The Milk account.
@@@ NPAPI PLUGIN NPP_GetValue
@@@ NPAPI PLUGIN NPP_GetValue
[Error 10:12:29.141] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:12:29.141] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:18:31.150] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:18:31.150] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:18:31.150] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:18:31.150] [RTM] Not authorized to use a Remember The Milk account.
[Error 10:18:31.150] [RTM] Not authorized to use a Remember The Milk account.

Unhandled Exception: System.NullReferenceException: Object reference not set to an instance of an object
at NDesk.DBus.Connection.WaitForIOCompletition (NDesk.DBus.Connection) <0x0001c>
at NDesk.DBus.Connection.ReadMessage () <0x0022b>
at NDesk.DBus.Connection.Iterate () <0x00037>
at NDesk.DBus.BusG/<Init>c__AnonStorey0.<>m__0 (intptr,NDesk.GLib.IOCondition,intptr) <0x0003b>
at (wrapper native-to-managed) NDesk.DBus.BusG/<Init>c__AnonStorey0.<>m__0 (intptr,NDesk.GLib.IOCondition,intptr) <0x00077>
at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x00052>
at Gtk.Application.Run () <0x0000b>
at Do.Do.Main (string[]) <0x0022f>

Comment 6 Renich Bon Ciric 2010-03-17 06:00:55 UTC

*** This bug has been marked as a duplicate of bug 530757 ***


Note You need to log in before you can comment on or make changes to this bug.