Bug 525769 - scanner works as root, but not as user.
Summary: scanner works as root, but not as user.
Keywords:
Status: CLOSED DUPLICATE of bug 512516
Alias: None
Product: Fedora
Classification: Fedora
Component: sane-backends
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-25 16:43 UTC by Kevin DeKorte
Modified: 2009-10-22 10:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-22 10:11:15 UTC


Attachments (Terms of Use)
Udev rules (493 bytes, text/plain)
2009-10-13 16:19 UTC, Kevin DeKorte
no flags Details

Description Kevin DeKorte 2009-09-25 16:43:04 UTC
Description of problem:
I have a scanner Epson V200 usb: 04b8:012e

Version-Release number of selected component (if applicable):
udev-145-8.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1. plugin scanner after installing iscan drivers
2. scanner is usable by root user, but not by normal user
3.
  
Actual results:
only root has access

Expected results:
at least someone using X should have rights to use it

Additional info:
worked fine in Fedora 11 prior to preupgrade

Comment 1 Harald Hoyer 2009-09-25 17:43:10 UTC
hmm, don't know how scanner permissions are handled nowadays ..

Comment 2 Kevin DeKorte 2009-10-06 20:28:20 UTC
Any update on this? Would be nice to have the scanner accessible to users in F12.

Even telling me what files I need to alter to fix this would be nice.

Comment 3 Kevin DeKorte 2009-10-13 16:19:57 UTC
Created attachment 364628 [details]
Udev rules

I was able to make my scanner work for non-root users by installing this file, adding a group named scanner and then adding my id to the scanner group.

Comment 4 Alesh Slovak 2009-10-22 08:02:49 UTC
I am a developer working on iscan and after investigating, the only conclusion I can come to is that the problem is a permissions issue in Fedora 12, see my comment here: https://bugzilla.redhat.com/show_bug.cgi?id=527031.

Not installing iscan and using only the epson2 backend provided by sane-backends, I was still unable to use any of the Epson scanners I tried as a regular user.

iscan bases its permissions on the underlying distribution, so if permissions don't work with epson2 they can't work with iscan. I hope this can get fixed for the final Fedora 12 release.

Comment 5 Nils Philippsen 2009-10-22 10:11:15 UTC

*** This bug has been marked as a duplicate of bug 512516 ***


Note You need to log in before you can comment on or make changes to this bug.