Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 525802 - RFE - Request configuration of new broadcast option of openais integrated into conga
Summary: RFE - Request configuration of new broadcast option of openais integrated int...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga
Version: 5.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 492808
Blocks: 629652
TreeView+ depends on / blocked
 
Reported: 2009-09-25 19:50 UTC by Brian Likosar
Modified: 2016-04-26 16:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 624558 (view as bug list)
Environment:
Last Closed: 2011-01-13 22:26:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
fix for bug (3.89 KB, patch)
2010-08-31 21:42 UTC, Ryan McCabe
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0033 0 normal SHIPPED_LIVE conga bug fix and enhancement update 2011-01-12 15:59:22 UTC

Description Brian Likosar 2009-09-25 19:50:36 UTC
Description of problem:
openais now has a broadcast option instead of multicast.  However, this is only configurable by manually modifying cluster.conf.  Requesting that this be added into conga

Version-Release number of selected component (if applicable):
luci-0.12.2-6.el5
ricci-0.12.2-6.el5
openais-0.80.6-8.el5

How reproducible:
n/a

Steps to Reproduce:
1.n/a
2.
3.
  
Actual results:
No options/interface to broadcast configuration

Expected results:
Options to choose broadcast and then specify configuration (IPs, etc.)

Additional info:

Comment 1 Thomas Cameron 2010-08-16 13:28:04 UTC
Adding myself to this BZ, as I think it's an important update to Conga.

Please make this happen...  I have run into many cases where not having/exposing broadcast as an option has soured customers on using our cluster technology.

Comment 2 Perry Myers 2010-08-16 16:48:48 UTC
Broadcast is not meant to be used in a production environment.  We exposed the ability to configure broadcast only to make it easy to set up POC or demos.  Exposing broadcast config via the admin UI will make it far too easy to be misinterpreted as a production quality option.

The problems with broadcast are:
1. you have to isolate your cluster network from any other nodes since you'll flood all other nodes on the network (via physically separate switches or VLANs)
2. you cannot have multiple clusters on the same network/VLAN
3. we have no idea how broadcast holds up when combined with bonding
4. we have no QE testing on broadcast

We also are focusing our efforts on using udpu.  See bug # 568164 and fully supporting broadcast would overlap significantly with udpu, but have the additional restrictions mentioned above.

Given all of this, we explicitly do _not_ want to expose broadcast from luci, so I am going to close this as WONTFIX.

Comment 3 Thomas Cameron 2010-08-16 17:02:42 UTC
Instead of that, why don't we put text in the UI that says something like "Enable broadcast (unsupported/test only, not for production)"

The thing is, it *is* helpful, and we *do* need it, and there *are* cases where it absolutely should be exposed.  We can pretty easily expose this functionality while making clear that it is not to be used in production.

Thanks

Comment 4 Perry Myers 2010-08-16 17:13:47 UTC
(In reply to comment #3)
> Instead of that, why don't we put text in the UI that says something like
> "Enable broadcast (unsupported/test only, not for production)"
> 
> The thing is, it *is* helpful, and we *do* need it, and there *are* cases where
> it absolutely should be exposed.  We can pretty easily expose this
> functionality while making clear that it is not to be used in production.

What are the cases in which it should be exposed?

Comment 8 Perry Myers 2010-08-16 19:53:13 UTC
Actually, here's a good compromise...

We have an environment variable like LUCI_DEBUG that can be set prior to running the luci daemon.  And the presence of this environment variable will cause luci to show some additional UI stuff that will be considered unsupported.

We can change the init script to source smth like /etc/sysconfig/luci in order to get the environment variable set.

So it would be a manual change to enable this debug/demo/POC mode, but it would make it very explicit since normal Luci startup would not be in this mode.

Would like to hear from feist and rmccabe on this to make sure the idea is not completely insane.

Comment 9 Thomas Cameron 2010-08-16 20:39:29 UTC
That actually sounds incredibly good.  Very clearly defined debug state, I like it a lot!  Thanks!

Comment 10 Sayan Saha 2010-08-17 02:53:31 UTC
Added pm_ack+ based on the fact that Luci would need to be run in the demo mode to access the bcast option.

Comment 11 Ryan McCabe 2010-08-31 21:42:14 UTC
Created attachment 442290 [details]
fix for bug

Comment 17 Brian Brock 2010-11-09 17:07:56 UTC
verified in luci-0.12.2-21.el5

Comment 19 errata-xmlrpc 2011-01-13 22:26:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0033.html


Note You need to log in before you can comment on or make changes to this bug.