This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 525924 - anaconda 12.30 does not support NFS iso install
anaconda 12.30 does not support NFS iso install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-09-27 05:55 EDT by Liam Li
Modified: 2009-10-21 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-21 12:06:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Liam Li 2009-09-27 05:55:52 EDT
Description of problem:

anaconda 12.30 does not support NFS iso install f12 beta 
Version-Release number of selected component (if applicable):

anaconda 12.30
How reproducible:
100%

Steps to Reproduce:
when boot, add method=nfs:nfsserver/path_of_ISO  to boot line , anaconda 12.30 does not recognize ISO file, but anaconda 12.29 supports
Comment 1 Chris Lumens 2009-09-28 09:38:17 EDT
There are no differences between 12.29 and 12.30 that should cause this.  Most of the changes are for s390 and ppc64.  Can you please attach /tmp/anaconda.log to this bug report so we can see what's going on?
Comment 2 Liam Li 2009-09-30 02:26:18 EDT
we did not go to the stage2. The changes is when boot from DVD,it will go to text mode first to select language and keyboard by default,and then seems the default select is from hard disk install,have to select "back" to go back to "install from" select,if select nfs, give the nfs iso directory,anaconda can not recognize it,must use a directory with install tree.
Comment 3 Jerry Vonau 2009-10-04 21:16:52 EDT
Two things here, booting from the DVD would cause stage2 on the DVD to be used. The other is method=nfs:nfsserver would expect a tree to be used and results in calling setStage2LocFromCmdline in method.c forcing the looking for images/install.img on the nfs share. 

I thought you need to use method=nfsiso:nfsserver/path_of_ISO to use an iso on a nfs share.
Comment 4 James Laska 2009-10-05 08:53:12 EDT
Lili ... one thing that's tripped me up when doing NFS ISO installs ... is to provide images/install.img file in the same directory containing the DVD ISO.  Not sure if this is related to the issue.
Comment 5 Jerry Vonau 2009-10-05 10:27:58 EDT
It would be better to use repo= in place of method=, method is going away.  Providing images/install.img should not be needed when you pass repo/method=nfsiso instead of repo/method=nfs.
Comment 6 James Laska 2009-10-05 11:58:09 EDT
(In reply to comment #5)
> Providing images/install.img should not be needed when you pass
> repo/method=nfsiso instead of repo/method=nfs.  

In my testing, anaconda must be able to locate images/install.img when doing either an NFS or an NFSISO installation.  Someone on the anaconda development team can confirm what the code expects.  

What I tested ... 
1) PXE Boot system 
2) Provide nfs server + path

> we did not go to the stage2. The changes is when boot from DVD,it will go to
> text mode first to select language and keyboard by default,and then seems the
> default select is from hard disk install,have to select "back" to go back to
> "install from" select,

If booting the DVD with the option "askmethod" is failing, please add feedback to bug#518194.

Lili ... can you confirm your latest findings?
Comment 7 Jerry Vonau 2009-10-05 13:20:01 EDT
> > Providing images/install.img should not be needed when you pass
> > repo/method=nfsiso instead of repo/method=nfs.  
> 

What seems to be the issue is that users are confusing stage2=, method=, and repo=. The text screen that is brought up for ashmethod, is really for the location of the install.img file location only. method/stage2= is meant to be a short cut around askmethod to the location of install.img. 


> In my testing, anaconda must be able to locate images/install.img when doing
> either an NFS or an NFSISO installation.  Someone on the anaconda development
> team can confirm what the code expects.  
> 
> What I tested ... 
> 1) PXE Boot system 
> 2) Provide nfs server + path
>
If you boot with the DVD/boot.iso then stage2 would be mounted from the DVD/CDROM. With any PXE boot, images/install.img would have to live on the nfs share, there would be no other place to mount it from, unlike booting a HD/DVD/CDROM install. stages2=nfs:nfsserver/path_of_ISO (latest syntax) 
which at line 202 in nfsinstall.c would append images/install.img to the path if nfs is used and doesn't end with .img.  

I'd use for tree based install:
stages2=nfs:nfsserver/<path>/images/install.img
repo=nfs:nfsserver/<path>/

For a iso based install:
stages2=nfs:nfsserver/path_of_ISO/images/install.img
repo=nfsiso:nfsserver/path_of_ISO/

> > we did not go to the stage2. The changes is when boot from DVD,it will go to
> > text mode first to select language and keyboard by default,and then seems the
> > default select is from hard disk install,have to select "back" to go back to
> > "install from" select,
> 
> If booting the DVD with the option "askmethod" is failing, please add feedback
> to bug#518194.
> 
That is because the DVD is passing stage2=hd:LABEL=Fedora so it assumes that the DVD/CDROM has stage2, and should not look for it. Think you would have better luck if used repo=nfsiso:nfsserver/path_of_ISO in place of method=nfs:nfsserver/path_of_ISO. 

> Lili ... can you confirm your latest findings?  

and a copy of the anaconda.log file.
Comment 8 Chris Lumens 2009-10-20 09:33:01 EDT
Can you please confirm whether or not this is a bug based on the various comments, especially comment #7?
Comment 9 Liam Li 2009-10-21 06:13:48 EDT
sorry for the belated reply, I tested on f12-beta-rc2 ,this issue was fixed.
Comment 10 James Laska 2009-10-21 12:06:39 EDT
Thanks for the feedback Liam.  Reviewed during F12Blocker review and closing this issue based on test results in comment#9.

Note You need to log in before you can comment on or make changes to this bug.