This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526076 - some virt-manager toolbar icons are blurry
some virt-manager toolbar icons are blurry
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks: F13VirtTarget
  Show dependency treegraph
 
Reported: 2009-09-28 13:08 EDT by Michael Monreal
Modified: 2010-04-19 10:34 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-05 11:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot to compare easily (59.07 KB, image/png)
2009-09-28 13:10 EDT, Michael Monreal
no flags Details
Screenshot (11.51 KB, image/png)
2010-04-19 05:21 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-09-28 13:08:25 EDT
Virt-manager 0.8 now has some beautiful new toolbar icons. However, two of them are blurry:

1.) the icon to create new VMs in the main GUI. The button seems to be too big, not sure if the icon itself is too big or if it is scaled to a bigger size. It should have the configured (by GTK theme) toolbar icon size.

2.) the icon left to the "play" icon in the main GUI. The same icon is used in the VM window and it looks perfect there, so I assume it is scaled to a wrong size here.
Comment 1 Michael Monreal 2009-09-28 13:10:44 EDT
Created attachment 362917 [details]
Screenshot to compare easily
Comment 2 Michael Monreal 2009-09-28 13:13:20 EDT
To 1., I just checked the package and the icon in question is not square, which is a bad idea and causes the problem here.
Comment 3 Mark McLoughlin 2009-10-02 09:54:41 EDT
As little old Irish ladies would say "god bless your eyes" :-)

Thanks for the screenshot, that really shows up the problem
Comment 4 Mark McLoughlin 2009-10-29 11:41:39 EDT
(for reference, bug #529956 is another similar bug from Michael)
Comment 5 Bug Zapper 2009-11-16 08:02:15 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Cole Robinson 2010-04-05 11:57:21 EDT
This is now upstream and in rawhide. Since this this is just polish, closing as RAWHIDE.
Comment 7 Michael Monreal 2010-04-19 05:20:48 EDT
Re-tested this on a recent F13 snapshot now and I still see both problems reported above. The 0.8.4 F14 package _partially_ fixes the problem: the buttons scale down to 16x16 now, but only the "mising image" icon is shown.

I think you are not shipping 16x16 versions of the icons? Anyway it is strange that it doesn't at least show scaled down versions of the bigger size...
Comment 8 Michael Monreal 2010-04-19 05:21:30 EDT
Created attachment 407517 [details]
Screenshot

Here's a screenshot of the 0.8.4 version from F14. I think this has to be reopened.
Comment 9 Michael Monreal 2010-04-19 10:34:40 EDT
I checked the source and RPM package, vm_new and icon_console are available in 16, 22, 24 and 32 px but the icons are still not used for whatever reason.

Note You need to log in before you can comment on or make changes to this bug.