Bug 529956 - 16x16 icon in Virtual Machine Details window
16x16 icon in Virtual Machine Details window
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F12VirtTarget
  Show dependency treegraph
 
Reported: 2009-10-20 17:42 EDT by Michael Monreal
Modified: 2010-04-05 11:57 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-05 11:57:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (8.93 KB, image/png)
2009-10-20 17:42 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-10-20 17:42:13 EDT
Created attachment 365432 [details]
Screenshot

With GTK thems that use 16x16 icons for toolbars, or the global /desktop/gnome/interface/toolbar_icons_size=menu setting, the first icon of the Virtual Machine Details window's toolbar is blurry. I guess virt-manager does not ship a 16x16 version of the icon and scales down the 22x22 or 24x24 version, which looks bad.
Comment 1 Mark McLoughlin 2009-10-29 11:41:55 EDT
Thanks for the report

(for reference, bug #526076 is another similar bug from Michael)
Comment 2 Cole Robinson 2010-03-03 17:15:02 EST
Michael, since I'm not too familiar with this stuff: what are all the icon sizes that should be provided?
Comment 3 Michael Monreal 2010-03-03 17:34:57 EST
A "full set" would include 16, 22, 24, 32 and 48 pixel versions.

Are all sizes really needed? 
- 24 is the GTK default and 22 is virtually the same. 
- 16px is used by some "small form factor" themes 
- either 32px or 48px is used by the LargePrint a11y theme

To be on the save side, all those sizes are needed for every single icon.
Comment 4 Bug Zapper 2010-03-15 08:57:18 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Cole Robinson 2010-04-05 11:57:12 EDT
This is now upstream and in rawhide. Since this this is just polish, closing as RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.