Bug 526131 - lm_sensors 2.10.7 with Asus P5Q motherboard's w83667hg sensors chip
Summary: lm_sensors 2.10.7 with Asus P5Q motherboard's w83667hg sensors chip
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lm_sensors
Version: 5.3
Hardware: x86_64
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Nikola Pajkovsky
QA Contact: BaseOS QE
URL:
Whiteboard:
: 559360 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 00:07 UTC by Simon Wilson
Modified: 2014-02-02 22:13 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-12-07 09:37:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CentOS 3872 0 None None None Never

Description Simon Wilson 2009-09-29 00:07:09 UTC
Description of problem:

CentOS 5.3 x64 (xen kernel) install on an Asus P5Q motherboard - 'official' lm_sensors won't work with the onboard W83667hg sensors chip. (CentOS guys suggested I report a bug here and there). 

yum install lm_sensors (2.10.7) followed by sensors-detect = no sensors found.

Running the latest 'sensors-detect' script from lm-sensors.org detects the chip correctly:

     Found `Winbond W83667HG Super IO Sensors'                   Success!
    (address 0x290, driver `w83627ehf')

but lm_sensors service will not start with the standard driver. 

Installed kmod-w83627ehf-xen driver from elrepo.org, and lm_sensors service starts correctly.

However 'sensors' output reads only:

     w83667hg-isa-0290
     Adapter: ISA adapter

'yum erase lm_sensors' followed by a 'make install' of lm_sensors 3.1.1 from lm-sensors.org works fine. 'sensors' output:

     w83667hg-isa-0290
     Adapter: ISA adapter
     in0:         +1.35 V  (min =  +0.00 V, max =  +1.74 V)
     in1:         +1.74 V  (min =  +1.15 V, max =  +0.30 V)   ALARM
     in2:         +3.28 V  (min =  +0.00 V, max =  +2.56 V)   ALARM
     in3:         +3.25 V  (min =  +2.05 V, max =  +1.25 V)   ALARM
     in4:         +1.67 V  (min =  +0.18 V, max =  +1.48 V)   ALARM
     in5:         +2.04 V  (min =  +0.08 V, max =  +0.73 V)   ALARM
     in7:         +3.38 V  (min =  +1.87 V, max =  +3.14 V)   ALARM
     in8:         +3.28 V  (min =  +3.33 V, max =  +2.16 V)   ALARM
     fan1:        675 RPM  (min = 1016 RPM, div = 16)  ALARM
     fan2:       1222 RPM  (min =  417 RPM, div = 16)
     fan3:          0 RPM  (min = 10546 RPM, div = 128)  ALARM
     fan4:          0 RPM  (min = 10546 RPM, div = 128)  ALARM
     fan5:          0 RPM  (min = 10546 RPM, div = 128)  ALARM
     temp1:       +29.0°C  (high =  +8.0°C, hyst = +89.0°C)  ALARM  sensor = thermistor
     temp2:       +22.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = diode
     temp3:       +18.5°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
     cpu0_vid:   +0.875 V

But means I am now outside RPM which I don't really want to do... 


Version-Release number of selected component (if applicable):

lm_sensors 2.10.7

How reproducible:

Steps to Reproduce:
1. On an Asus P5Q motherboard with 5.3 x64, yum install lm_sensors
2. sensors-detect - no sensors found
3. download and run latest 'sensors-detect' script - finds w83667hg
4. lm_sensors service fails to start
5. install kmod-w83627ehf-xen driver
6. start lm_sensors service
7. 'sensors' output - chip name only, no readings
8. yum erase lm_sensors
9. download and install lm_sensors 3.1.1
10. Fully functional.
  
Actual results:

Sensors output restricted to name of chip only.

Expected results:

Sensor chip's outputs of fan speeds, temps, and voltages as per later lm_sensors install.

Additional info:

Comment 1 Radek Vokál 2009-12-07 09:35:05 UTC
We don't have a hardware to reproduce this issue, thus we don't plan to include it in stable release of RHEL. If you feel that this should be part of the stable release, please contact our support at redhat.com/support

Comment 2 RHEL Program Management 2009-12-07 09:37:29 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Comment 3 Nikola Pajkovsky 2010-04-06 12:17:02 UTC
*** Bug 559360 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.