Bug 52614 - Error reporting routines re-entered in GCC 2.96
Summary: Error reporting routines re-entered in GCC 2.96
Status: CLOSED DUPLICATE of bug 41554
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc   
(Show other bugs)
Version: 7.1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL: http://www.hut.fi/~amsaarel/gccbug.html
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-26 21:18 UTC by Need Real Name
Modified: 2007-04-18 16:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-26 21:18:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-08-26 21:18:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-20mdk i686)

Description of problem:
Tried to compile a file, GCC gave the following error message:
maproute.cc:42: universal-character-name `\u
Internal compiler error: Error reporting routines re-entered.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.


Version-Release number of selected component (if applicable):
2.96

How reproducible:
Always

Steps to Reproduce:
1. Get the file www.hut.fi/~amsaarel/maproute.cc from the web page
2. Try to compile it with "gcc -g -c -o maproute.o maproute.cc"
	

Expected Results:  A more informative error message

Comment 1 Jakub Jelinek 2001-08-27 11:07:16 UTC
This is fixed since gcc-c++2.96-86 (in that it will not ICE on the bogus input).

*** This bug has been marked as a duplicate of 41554 ***


Note You need to log in before you can comment on or make changes to this bug.