Bug 52615 - sshd server won't start
sshd server won't start
Product: Red Hat Public Beta
Classification: Retired
Component: openssh (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2001-08-26 23:13 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-30 18:38:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-08-26 23:13:03 EDT
Description of Problem:

sshd server would not run due to wrong glibc version.
rebuild from source RPM solved problem.

Version-Release number of selected component (if applicable):

How Reproducible:

every time /etc/init.d/sshd was started

Steps to Reproduce:
1. /etc/init.d/sshd start

Actual Results:

Expected Results:

Additional Information:
system was upgraded from RedHat 7.1 to Roswell beta 1 then
Roswell beta 2.  sshd would no longer start.
Comment 1 Nalin Dahyabhai 2001-08-27 18:36:04 EDT
Which version of sshd was installed when it would not restart?  Equivalently,
what is the output of "rpm -q openssh-server"?
Comment 2 Need Real Name 2001-08-27 23:19:15 EDT
Binary openssh-server-2.9p2-5.i386.rpm from Roswell 7.1.94 ISO image 
was installed.

output from 'ldd usr/sbin/sshd':

usr/sbin/sshd: /lib/libc.so.6: version `GLIBC_2.2.4' not found (required by
        libpam.so.0 => /lib/libpam.so.0 (0x40029000)
        libdl.so.2 => /lib/libdl.so.2 (0x40032000)
        libz.so.1 => /usr/lib/libz.so.1 (0x40036000)
        libnsl.so.1 => /lib/libnsl.so.1 (0x40044000)
        libutil.so.1 => /lib/libutil.so.1 (0x4005b000)
        libcrypto.so.2 => /lib/libcrypto.so.2 (0x4005e000)
        libc.so.6 => /lib/libc.so.6 (0x40121000)

'rpm --rebuild openssh-2.9p2-5.src.rpm' created a working
Comment 3 Nalin Dahyabhai 2001-08-27 23:27:01 EDT
This looks like an RPM dependency error, probably due to the anonftp trigger
breaking the glibc upgrade.  If you run "rpm -q glibc", do you get a version
other than "2.2.4-something"?  If so, then this is actually a duplicate of bug
Comment 4 Nalin Dahyabhai 2001-08-27 23:27:56 EDT
Doh.  More accurately, a failed trigger causing an RPM upgrade of glibc to fail.
Comment 5 Need Real Name 2001-08-27 23:37:57 EDT
(44)% rpm -q glibc

This matches the version number on the Roswell ISO image.
Comment 6 Nalin Dahyabhai 2001-08-28 10:19:22 EDT
Can I get you to also verify the contents of the package with:
rpm -y glibc glibc-common
You shouldn't get any output if you're running as root, and a few unverifiable
files as non-root due to file permissions.
Comment 7 Need Real Name 2001-08-28 23:02:50 EDT
That doesn't look good:

S.5....T   /lib/ld-2.2.4.so
S.5....T   /lib/libc-2.2.4.so
..5....T   /lib/libnsl-2.2.4.so
..5....T   /lib/libnss_files-2.2.4.so

I did do the upgrade to the latest beta using 'rpm -F'
in single user mode.  Maybe that's the cause?
Comment 8 Nalin Dahyabhai 2001-08-29 11:53:50 EDT
This sounds more and more like a partially-successful glibc upgrade.  Try
re-upgrading the glibc and glibc-devel packages, using "--force" if need be, and
see if you can get the same error starting sshd once the glibc upgrade is
finished and verifies cleanly.

Note: --force is equivalent to "--replacepkgs --replacefiles", and does not
include the "--nodeps" flag, which should not be needed to fix the glibc upgrade
Comment 9 Need Real Name 2001-08-30 18:38:30 EDT
That fixes sshd.
Comment 10 Nalin Dahyabhai 2001-08-31 16:58:55 EDT
Excellent.  Marking as fixed in Raw Hide, because the offending trigger has been

Note You need to log in before you can comment on or make changes to this bug.