Bug 526229 - Cannot play audio cd for the moment
Summary: Cannot play audio cd for the moment
Keywords:
Status: CLOSED DUPLICATE of bug 513495
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 11
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-09-29 11:35 UTC by Joachim Backes
Modified: 2009-10-26 09:13 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-26 09:13:28 UTC


Attachments (Terms of Use)

Description Joachim Backes 2009-09-29 11:35:43 UTC
Description of problem:
As some months ago, it's no more possible to play audio cd's in the 
moment: looking in /var/log/messages, I found some lines:

Sep 29 13:08:45 eule kernel: Buffer I/O error on device sr1, logical block 1
Sep 29 13:08:45 eule kernel: sr 1:0:1:0: [sr1] Result: hostbyte=DID_OK 
driverbyte=DRIVER_SENSE
Sep 29 13:08:45 eule kernel: sr 1:0:1:0: [sr1] Sense Key : Illegal 
Request [current]
Sep 29 13:08:45 eule kernel: Info fld=0x0, ILI
Sep 29 13:08:45 eule kernel: sr 1:0:1:0: [sr1] Add. Sense: Illegal mode 
for this track
Sep 29 13:08:45 eule kernel: end_request: I/O error, dev sr1, sector 0
Sep 29 13:08:45 eule kernel: Buffer I/O error on device sr1, logical block 0
Sep 29 13:08:45 eule kernel: Buffer I/O error on device sr1, logical block 1

I tried rhythmbox or kscd for example.

But ripping with K3B runs correctly!


Version-Release number of selected component (if applicable):

I'm running kernel 2.6.30.5-43.fc11.i586.

How reproducible:
Each time I try.

Steps to Reproduce:
1. Try to play CD with rhythmbox for example.
2.
3.
  
Actual results:
Error message in /var/log/messages

Expected results:
CD plays.

Additional info:

I remember that some months ago, I had the same problem.

Comment 1 Joachim Backes 2009-09-29 16:39:12 UTC
To be little bit more precise:

1. When using "kscd -s", the message is: "CDROMREADTOCHDR: No medium found"
2. When using kaffeine player, I get a warning popup: "No audio cd found"

I have 3 cd players in my box:

ls -l /dev/sr*
brw-rw----+ 1 root cdrom 11, 0 2009-09-29 19:12 /dev/sr0
brw-rw----+ 1 root cdrom 11, 1 2009-09-29 19:12 /dev/sr1
brw-rw----+ 1 root cdrom 11, 2 2009-09-29 17:12 /dev/sr2

Trying to play the CD's under root fails too:

Checking /dev/cdrom for cdrom...
	Testing /dev/cdrom for SCSI/MMC interface
		SG_IO device: /dev/sr0

CDROM model sensed sensed: TOSHIBA ODD-DVD SD-M1802 1031 

Checking for SCSI emulation...
	Drive is ATAPI (using SG_IO host adaptor emulation)

Checking for MMC style command set...
	Drive is MMC style
Checking /dev/dvd for cdrom...
	Testing /dev/dvd for SCSI/MMC interface
		SG_IO device: /dev/sr0

CDROM model sensed sensed: TOSHIBA ODD-DVD SD-M1802 1031 

Checking for SCSI emulation...
	Drive is ATAPI (using SG_IO host adaptor emulation)

Checking for MMC style command set...
	Drive is MMC style
Launched ok, pid = 3801
Error: "/var/tmp/kdecache-backes" is owned by uid 500 instead of uid 0.
OggS-SEEK: at 0 want 60408 got 51136 (diff-requested 60408)
OggS-SEEK: at 60352 want 520 got 0 (diff-requested -59832)

Comment 2 Feng Yu 2009-10-24 22:42:35 UTC
Please refer to bug 513495.

Comment 3 Nicola Soranzo 2009-10-26 09:13:28 UTC

*** This bug has been marked as a duplicate of bug 513495 ***


Note You need to log in before you can comment on or make changes to this bug.