Bug 526243 - Guest PXE booting doesn't work when using ne2k_pci NIC model
Summary: Guest PXE booting doesn't work when using ne2k_pci NIC model
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: 11
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 526781
Blocks: F11VirtTarget
TreeView+ depends on / blocked
 
Reported: 2009-09-29 13:00 UTC by Eduardo Habkost
Modified: 2009-10-21 00:57 UTC (History)
9 users (show)

Fixed In Version: 0.10.6-7.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-21 00:57:06 UTC


Attachments (Terms of Use)
screenshot of guest trying to boot via PXE (21.68 KB, image/png)
2009-09-29 13:00 UTC, Eduardo Habkost
no flags Details

Description Eduardo Habkost 2009-09-29 13:00:47 UTC
Created attachment 363003 [details]
screenshot of guest trying to boot via PXE

Description of problem:
If using the ne2k_pci NIC model on the guest, PXE booting doesn't work with the packaged etherboot ROM image.


Version-Release number of selected component (if applicable):
etherboot-zroms-kvm-5.4.4-16.fc11.noarch
qemu-system-x86-0.10.6-5.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
[root@mf11 ~]# cat /tmp/pxe
<domain type='qemu'>
  <name>pxe</name>
  <uuid>6812c719-61ac-4ede-dd3d-de9ff3b1a568</uuid>
  <memory>512000</memory>
  <currentMemory>512000</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='pc'>hvm</type>
    <boot dev='network'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <interface type='bridge'>
      <mac address='54:52:00:29:2c:5b'/>
      <source bridge='breth0'/>
      <model type='ne2k_pci'/>
    </interface>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' listen='0.0.0.0'/>
  </devices>
</domain>

[root@mf11 ~]# virsh define /tmp/pxe
Domain pxe defined from /tmp/pxe

[root@mf11 ~]# virsh start pxe
Domain pxe started


  
Actual results:
The etherboot ROM doesn't find the expected NIC. See screenshot.


Expected results:
PXE booting works.


Additional info:
The pxe-ne2k_pci ROM image for Qemu must point to rtl8029.zrom, not ne.zrom. ne.zrom is for ISA NICs.

Comment 1 Eduardo Habkost 2009-09-29 13:06:35 UTC
I noticed this on Fedora 11, but it seems to be present on Fedora 12 and Rawhide, unless the gPXE ne.rom image works for ne2k_pci (which I doubt). From Rawhide qemu.spec:

pxe_link() {
  ln -s ../gpxe/$2.rom %{buildroot}%{_datadir}/%{name}/pxe-$1.bin
}
[...]
pxe_link ne2k_pci ne
[...]

Comment 2 Mark McLoughlin 2009-10-01 18:14:21 UTC
So, we need an update to:

  1) change 'pxe_link ne2k_pci ne' to 'pxe_link ne2k_pci rtl8029'

  2) make qemu-system-x86 require a version of etherboot-zroms-kvm which 
     contains the rtl8029; perhaps it makes sense to just change to file based
     requires ...

Comment 3 Mark McLoughlin 2009-10-05 14:40:49 UTC
Building this for f11:

* Mon Oct  5 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.6-7
- Use rtl8029 PXE rom for ne2k_pci, not ne (#526243)
- Also, replace the etherboot-zroms-kvm pkg requires with file-based requires

Comment 4 Fedora Update System 2009-10-06 08:22:08 UTC
qemu-0.10.6-7.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/qemu-0.10.6-7.fc11

Comment 5 Fedora Update System 2009-10-07 03:15:04 UTC
qemu-0.10.6-7.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qemu'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10314

Comment 6 Fedora Update System 2009-10-21 00:56:58 UTC
qemu-0.10.6-7.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.