Bug 526781 - Add rtl8209 to etherboot-zroms-kvm
Add rtl8209 to etherboot-zroms-kvm
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: etherboot (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 526243
  Show dependency treegraph
 
Reported: 2009-10-01 14:11 EDT by Mark McLoughlin
Modified: 2009-10-20 20:55 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.4.4-17.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-20 20:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-10-01 14:11:40 EDT
The 'ne' PXE ROM isn't the correct one for qemu's ne2k_pci NIC. We need an
update for F-11, F-12 and F-13 which adds rtl8029 to gpxe-roms-qemu

Should be as simple as:

+# ne is included only for compatibility with earlier versions of qemu
 for fmt in rom zrom;do 
-	for rom in ne e1000-82542 pcnet32 rtl8139 virtio-net;do
+	for rom in rtl8209 ne e1000-82542 pcnet32 rtl8139 virtio-net;do

See below for more info:

+++ This bug was initially created as a clone of Bug #526243 +++

Created an attachment (id=363003)
screenshot of guest trying to boot via PXE

Description of problem:
If using the ne2k_pci NIC model on the guest, PXE booting doesn't work with the packaged etherboot ROM image.


Version-Release number of selected component (if applicable):
etherboot-zroms-kvm-5.4.4-16.fc11.noarch
qemu-system-x86-0.10.6-5.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
[root@mf11 ~]# cat /tmp/pxe
<domain type='qemu'>
  <name>pxe</name>
  <uuid>6812c719-61ac-4ede-dd3d-de9ff3b1a568</uuid>
  <memory>512000</memory>
  <currentMemory>512000</currentMemory>
  <vcpu>1</vcpu>
  <os>
    <type arch='x86_64' machine='pc'>hvm</type>
    <boot dev='network'/>
  </os>
  <features>
    <acpi/>
    <apic/>
    <pae/>
  </features>
  <clock offset='utc'/>
  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <devices>
    <emulator>/usr/bin/qemu-system-x86_64</emulator>
    <interface type='bridge'>
      <mac address='54:52:00:29:2c:5b'/>
      <source bridge='breth0'/>
      <model type='ne2k_pci'/>
    </interface>
    <input type='mouse' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' listen='0.0.0.0'/>
  </devices>
</domain>

[root@mf11 ~]# virsh define /tmp/pxe
Domain pxe defined from /tmp/pxe

[root@mf11 ~]# virsh start pxe
Domain pxe started


  
Actual results:
The etherboot ROM doesn't find the expected NIC. See screenshot.


Expected results:
PXE booting works.


Additional info:
The pxe-ne2k_pci ROM image for Qemu must point to rtl8029.zrom, not ne.zrom. ne.zrom is for ISA NICs.

--- Additional comment from ehabkost@redhat.com on 2009-09-29 09:06:35 EDT ---

I noticed this on Fedora 11, but it seems to be present on Fedora 12 and Rawhide, unless the gPXE ne.rom image works for ne2k_pci (which I doubt). From Rawhide qemu.spec:

pxe_link() {
  ln -s ../gpxe/$2.rom %{buildroot}%{_datadir}/%{name}/pxe-$1.bin
}
[...]
pxe_link ne2k_pci ne
[...]
Comment 1 Mark McLoughlin 2009-10-05 11:22:59 EDT
Building this for f11:

* Mon Oct  5 2009 Mark McLoughlin <markmc@redhat.com> - 5.4.4-17
- Include rtl8029 in etherboot-zroms-qemu (#526781)
Comment 2 Fedora Update System 2009-10-06 04:20:43 EDT
etherboot-5.4.4-17.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/etherboot-5.4.4-17.fc11
Comment 3 Fedora Update System 2009-10-06 23:15:56 EDT
etherboot-5.4.4-17.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update etherboot'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10318
Comment 4 Fedora Update System 2009-10-20 20:55:25 EDT
etherboot-5.4.4-17.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.