This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 526573 - Anaconda crashed when deleting an LVM partition
Anaconda crashed when deleting an LVM partition
Status: CLOSED DUPLICATE of bug 498026
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
11
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-30 17:25 EDT by Joe Krahn
Modified: 2009-10-01 11:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-01 11:54:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda crash dump (235.91 KB, text/plain)
2009-09-30 17:25 EDT, Joe Krahn
no flags Details

  None (edit)
Description Joe Krahn 2009-09-30 17:25:43 EDT
Created attachment 363244 [details]
Anaconda crash dump

Description of problem:
Anaconda crashed during partition editing when I attempted to delete an LVM partition.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select option to customize partition layout
2. Delete the volume group containing the root and swap partitions.
3. Attempt to delete the LVM physical partition.
  
Actual results:
Anaconda crashed, creating the attached dump.

Expected results:
Success.

Additional info:
I saw some other anaconda partitioning bug reports, but could not find one that matched.

The automatic partitioning started from the option to use free-space, with 2 small existing partitions containing Dell Utilities and DOS, resulting in /boot being the 3rd primary partition, with one logical partition used for LVM.

I had also tried to set the "force to be a primary partition" flag for the LVM physical partition. That failed, claiming insufficient space. This installation is to a 750G disk. Perhaps DOS partitions cannot create primary partitions that big? Maybe this bug is related to partitioning large disks.
Comment 1 Chris Lumens 2009-10-01 11:54:04 EDT

*** This bug has been marked as a duplicate of bug 498026 ***

Note You need to log in before you can comment on or make changes to this bug.