Bug 526697 - Trying to change encryption status of partition ends with error message: The mount point "" is in use. Please pick another
Trying to change encryption status of partition ends with error message: The ...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
: 527991 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-01 08:44 EDT by Martin Banas
Modified: 2009-10-22 16:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-12.36-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 16:39:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Martin Banas 2009-10-01 08:44:57 EDT
Description of problem:
Trying to change encryption status of partition ends with error message: The mount point "" is in use. Please pick another.

Version-Release number of selected component (if applicable):
rawhide-20090930
anaconda 12.32

How reproducible:
always

Steps to Reproduce:
1. start the installation of latest rawhide
2. proceed to partitioning dialog and select "Create custom layout"
3. Create new partition with mount point (for example /, /boot, /home).
4. Edit the partition - select "Encrypt" and click OK.
5. Edit the partition again - deselect "Encrypt" and click OK.
  
Actual results:
Error message displayed:

Mount point in use

The mount point "/home" is in use. Please pick another.

Expected results:
There should be no such message.

Additional info:
Happens only when "Encrypt" field is selected/deselected. "Force to be a primary partition" and other are not affected by this behaviour.
Comment 1 Chris Lumens 2009-10-08 10:48:45 EDT
*** Bug 527991 has been marked as a duplicate of this bug. ***
Comment 2 James Laska 2009-10-09 14:54:07 EDT
The workaround for now seems to be either ...
 1) remove the partition, and create a new one to match the parameters you need.   
 2) Or, supply a temporary mount point (aka '/opt/foo'), click OK, then reedit that partition supplying the original mount point

Adding to F12Blocker so this doesn't fall off the radar.
Comment 3 David Lehman 2009-10-09 15:19:24 EDT
Will be fixed in anaconda-12.36-1.
Comment 4 James Laska 2009-10-09 16:33:07 EDT
Tested fix as an updates.img on top of anaconda-12.35-1 (http://dlehman.fedorapeople.org/updates-jlaska.img).  Was unable to reproduce the reported problem.  Will retest with anaconda-12.26.
Comment 5 James Laska 2009-10-22 16:39:17 EDT
Tested and confirmed in anaconda-12.37

Note You need to log in before you can comment on or make changes to this bug.