Bug 52682 - finger shows impossible idle time
finger shows impossible idle time
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: finger (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
:
: 55319 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 21:44 EDT by Tommy McNeely
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-01 10:20:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tommy McNeely 2001-08-27 21:44:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76C-CCK-MCD Netscape [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
When running finger I see old logins (that should have been logged out)
with extreemely high (impossible due to low uptime) idle times.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. ssh from work to home firewall (RedHat 7.1)
2. ssh from home firewall to Workstation (Redhat Roswell2)
3. have something go wrong with the connection???
4. login again and finger
	

Actual Results:  [tommy@kyle tommy]$ finger
Login     Name            Tty      Idle  Login Time   Office     Office
Phone
tommy     Tommy McNeely   pts/0   21:12  Aug 23 17:38
(stan.local.redneck.nu)
tommy     Tommy McNeely  *pts/5    239d  Aug 24 19:02
(stan.local.redneck.nu)
tommy     Tommy McNeely   pts/4          Aug 27 13:37
(stan.local.redneck.nu)
[tommy@kyle tommy]$ 

(excess lines from :0 were removed)

Expected Results:  It should have closed the connection.. or at least only
show a smaller idle time.. like line 1

Additional info:

[tommy@kyle tommy]$ uptime
  7:52pm  up 4 days,  2:14,  6 users,  load average: 0.07, 0.09, 0.03
[tommy@kyle tommy]$ 

(although I DID say it was roswell2, just put that in to be verbose)

Trouble is, i'm not sure if its a bug with finger or some other component??
Comment 1 Tommy McNeely 2001-08-27 21:47:39 EDT
[tommy@kyle tommy]$ finger
Login     Name            Tty      Idle  Login Time   Office     Office Phone
tommy     Tommy McNeely   pts/0   21:18  Aug 23 17:38 (stan.local.redneck.nu)
tommy     Tommy McNeely   pts/2   21:17  Aug 26 22:35 (:0)
tommy     Tommy McNeely   pts/3   21:10  Aug 26 22:39 (:0)
tommy     Tommy McNeely  *pts/5    239d  Aug 24 19:02 (stan.local.redneck.nu)
tommy     Tommy McNeely   pts/0   21:18  Aug 26 22:27 (:0)
tommy     Tommy McNeely   pts/4          Aug 27 13:37 (stan.local.redneck.nu)
[tommy@kyle tommy]$ ps -fu tommy | grep 5
tommy     2950  1228  0 Aug23 ?        00:00:01 /usr/bin/gnome-session
tommy     3058     1  0 Aug23 ?        00:00:37 sawfish --sm-client-id 11c0a8000
tommy    15236     1  0 Aug25 ?        00:00:03 gmc
tommy    31369     1  0 Aug26 ?        00:00:05 gnome-terminal --use-factory --s
tommy    31445 31369  0 Aug26 pts/2    00:00:00 bash
tommy    31479 31445  0 Aug26 pts/2    00:00:00 ssh -l root stan
tommy    31503 31369  0 Aug26 pts/3    00:00:00 bash
tommy    31606 31503  0 Aug26 pts/3    00:00:00 ssh stan
tommy    31661     1  0 Aug26 ?        00:00:15 /usr/lib/mozilla/mozilla-bin
tommy     2577  2576  0 13:37 pts/4    00:00:00 -bash
tommy     3923  2577  0 19:56 pts/4    00:00:00 ps -fu tommy
tommy     3924  2577  0 19:56 pts/4    00:00:00 grep 5
[tommy@kyle tommy]$ 


nothing to kill???
Comment 2 Tommy McNeely 2001-08-27 22:44:56 EDT
Subject: 
               Re: strange finger output
         Date: 
               Mon, 27 Aug 2001 19:48:08 -0700
         From: 
               Joshua Andrews <josh@mail.wavefood.com>
     Reply-To: 
               roswell-list@redhat.com
 Organization: 
               Wavefood
           To: 
               roswell-list@redhat.com
   References: 
               1




Tommy McNeely wrote:

> [tommy@kyle tommy]$ finger
> Login     Name            Tty      Idle  Login Time   Office     Office
> Phone
> tommy     Tommy McNeely   pts/0   20:16  Aug 23 17:38 (stan.XXXXX)
> tommy     Tommy McNeely   pts/2   20:15  Aug 26 22:35 (:0)
> tommy     Tommy McNeely   pts/3   20:09  Aug 26 22:39 (:0)
> tommy     Tommy McNeely  *pts/5    239d  Aug 24 19:02 (stan.XXXXX)
> tommy     Tommy McNeely   pts/0   20:16  Aug 26 22:27 (:0)
> tommy     Tommy McNeely   pts/4          Aug 27 13:37 (stan.XXXXX)
> [tommy@kyle tommy]$ uptime
>   6:54pm  up 4 days,  1:17,  6 users,  load average: 0.01, 0.04, 0.00
> [tommy@kyle tommy]$
>
> How can I be idle for 239 days?
>

Must be something magic about 239 days.
This is output from finger josh on seawolf.

On since Fri Jul  6 09:00 (PDT) on tty2    3 days 9 hours idle
On since Fri Aug 24 10:21 (PDT) on pts/1   3 days 9 hours idle
On since Fri Aug 24 10:21 (PDT) on pts/2 from :0
   1 day 21 hours idle
On since Fri Jul  6 09:37 (PDT) on pts/3   239 days 2 hours idle
     (messages off)
On since Fri Aug 24 10:21 (PDT) on pts/4
Last login Wed Aug  8 15:37 (PDT) on pts/8 from mars

You are not the only slacker :)

-Joshua



_______________________________________________
Roswell-list mailing list
Roswell-list@redhat.com
https://listman.redhat.com/mailman/listinfo/roswell-list
Comment 3 Tommy McNeely 2001-08-27 22:49:59 EDT
[tommy@kyle tommy]$ finger tommy
Login: tommy          			Name: Tommy McNeely
Directory: /home/tommy              	Shell: /bin/bash
On since Thu Aug 23 17:38 (MDT) on pts/0 from stan.local.redneck.nu
   22 hours 19 minutes idle
On since Sun Aug 26 22:35 (MDT) on pts/2 from :0
   22 hours 18 minutes idle
On since Sun Aug 26 22:39 (MDT) on pts/3 from :0
   22 hours 12 minutes idle
On since Fri Aug 24 19:02 (MDT) on pts/5 from stan.local.redneck.nu
   239 days 2 hours idle
     (messages off)
On since Sun Aug 26 22:27 (MDT) on pts/0 from :0
   22 hours 19 minutes idle
On since Mon Aug 27 13:37 (MDT) on pts/4 from stan.local.redneck.nu
No mail.
No Plan.
[tommy@kyle tommy]$ 
Comment 4 Tommy McNeely 2001-08-27 23:27:41 EDT
Subject: 
               Re: strange finger output
         Date: 
               Mon, 27 Aug 2001 21:33:25 -0600
         From: 
               Tommy McNeely <Tommy.McNeely@sun.com>
     Reply-To: 
               roswell-list@redhat.com
 Organization: 
               Sun Microsystems - RC Americas
           To: 
               roswell-list@redhat.com
   References: 
               1 , 2 , 3




so now we have all been abducted.. I guess thats our "lost time"

[root@kyle root]# last tommy | grep gone
tommy    pts/5        stan.local.redne Fri Aug 24 19:02   gone  - no
logout 


Devon wrote:
> 
> On Monday 27 August 2001 10:48 pm, Joshua Andrews wrote:
> >
> > Must be something magic about 239 days.
> > This is output from finger josh on seawolf.
> 
> On Seawolf? I don't see the same problem on a Seawolf machine. Roswell
> is another story, see below.
> 
> > On since Fri Jul  6 09:00 (PDT) on tty2    3 days 9 hours idle
> > On since Fri Aug 24 10:21 (PDT) on pts/1   3 days 9 hours idle
> > On since Fri Aug 24 10:21 (PDT) on pts/2 from :0
> >    1 day 21 hours idle
> > On since Fri Jul  6 09:37 (PDT) on pts/3   239 days 2 hours idle
> >      (messages off)
> > On since Fri Aug 24 10:21 (PDT) on pts/4
> > Last login Wed Aug  8 15:37 (PDT) on pts/8 from mars
> >
> > You are not the only slacker :)
> 
> Apparently not, it appears many Roswell users were abducted 239 days
> ago as part of a larger conspiracy.
> 
> [root@roswell root]# finger
> Login     Name       Tty      Idle  Login Time   Office     Office Phone
> devon  Devon    pts/0          Aug 27 00:33 (tuxfan)
> devon  Devon   *pts/1    239d  Aug 23 22:10
> 
> [root@roswell root]# finger devon
> On since Mon Aug 27 00:33 (EDT) on pts/0 from tuxfan
> On since Thu Aug 23 22:10 (EDT) on pts/1   239 days 3 hours idle
>      (messages off)
> 
> [root@roswell root]# last
> devon pts/0        tuxfan           Mon Aug 27 00:33   still logged in
> devon pts/1                         Thu Aug 23 22:10   gone  - no logout
> devon pts/1                         Thu Aug 23 21:58 - 22:10  (00:11)
> 
> [root@roswell root]# uptime
>  11:02pm  up 5 days,  7:41,  2 users,  load average: 0.06, 0.03, 0.01
> 
> -D


****
* IT APPEAR THE ALIENS HAVE ABDUCTED US, AND WE ALL LOST 239 DAYS AND 2 HOURS
****
Comment 5 Alejandro Gonzalez Hernandez - Imoq 2001-08-29 19:47:25 EDT
I have seen this kind of funny idle times as well in my system, it happens 
sometimes when I startx, and then Ctrl-Alt-F1 and do a "finger"
Comment 6 Phil Knirsch 2001-08-30 04:55:16 EDT
Maybe you now know why we called the Beta 'Roswell' :)

But jokes aside, i haven't yet been able to reproduce this problem.

I'll look into it real soon now... :) And perhaps it's really a bug of another
app that only gets manifested if you point (a) finger at it.

Read ya, Phil
Comment 7 Phil Knirsch 2002-01-24 07:54:34 EST
I am still unable to reproduce this problem here on my 7.2 machines.

If anyone could get me a reproducible case i might be able to track it and see
if it is actually finger doing something wrong or /etc/utmp just containing some
garbage left over by some other app.

Read ya, Phil
Comment 8 Phil Knirsch 2002-01-24 07:55:04 EST
*** Bug 55319 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2002-06-19 05:47:32 EDT
I did see an alien mothership fly over that was the shape of a large finger
the other day.  Related perhaps?
Comment 10 Phil Knirsch 2003-09-01 10:20:58 EDT
Closing, as i just can're properly reproduce it. I suspect it's really some KDE
or Gnome app that garbles up utmp.

If there is a reproducible way to generate this bug feel free to reopen it.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.