Bug 55319 - Finger reports inaccurate idle times
Finger reports inaccurate idle times
Status: CLOSED DUPLICATE of bug 52682
Product: Red Hat Linux
Classification: Retired
Component: finger (Show other bugs)
7.1
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-29 12:29 EST by Steve Wilson
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 07:48:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Wilson 2001-10-29 12:29:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)

Description of problem:
I have a RedHat 7.1 DNS server that is reporting inaccurate idle times.  
The server has only been up 9 days, but it says I have two sessions idle 
for 301 days:

[root@pc-22-114 named]# uptime
  9:33am  up 9 days, 22:25,  3 users,  load average: 0.03, 0.01, 0.00

[root@pc-22-114 named]# finger itsssw1
Login: itsssw1                          Name: Steve Wilson
Directory: /home/itsssw1                Shell: /bin/bash
On since Fri Oct 26 10:09 (MST) on pts/0 from sedona
On since Fri Oct 26 11:42 (MST) on pts/1   301 days 16 hours idle
     (messages off)
On since Fri Oct 26 13:04 (MST) on pts/3   301 days 16 hours idle
     (messages off)
Last login Fri Oct 26 11:41 (MST) on :0
New mail received Mon Oct 29 04:05 2001 (MST)
     Unread since Fri Oct 26 10:16 2001 (MST)
No Plan.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. One user logged on.
2. Issue the command "finger" from the command line, with or without a 
user ID to finger.
3. See results.
	

Actual Results:  [root@pc-22-114 named]# finger itsssw1
Login: itsssw1                          Name: Steve Wilson
Directory: /home/itsssw1                Shell: /bin/bash
On since Fri Oct 26 10:09 (MST) on pts/0 from sedona
On since Fri Oct 26 11:42 (MST) on pts/1   301 days 16 hours idle
     (messages off)
On since Fri Oct 26 13:04 (MST) on pts/3   301 days 16 hours idle
     (messages off)
Last login Fri Oct 26 11:41 (MST) on :0
New mail received Mon Oct 29 04:05 2001 (MST)
     Unread since Fri Oct 26 10:16 2001 (MST)
No Plan.


Expected Results:  This ID is only logged on once and SU'd to root, not 
three times.

[root@pc-22-114 named]# finger itsssw1
Login: itsssw1                          Name: Steve Wilson
Directory: /home/itsssw1                Shell: /bin/bash
On since Fri Oct 26 10:09 (MST) on pts/0 from sedona


Additional info:

See above.
Comment 1 Phil Knirsch 2002-01-24 07:48:30 EST
Could you give the latest version 0.17-11 which is available soon via rawhide a
try and tell me if the problem still persists?

I cannot reproduce the problem here on any of our machines, so i am unsure if
this might not be a slighly corrupted /etc/utmp on your machine.

Thanks,

Read ya, Phil
Comment 2 Phil Knirsch 2002-01-24 07:55:10 EST
Has actually been reported previously, so mark it as duplicate.

*** This bug has been marked as a duplicate of 52682 ***

Note You need to log in before you can comment on or make changes to this bug.