Bug 527028 - Unable to open mkv file in totem "Can't play a text file without video."
Unable to open mkv file in totem "Can't play a text file without video."
Status: CLOSED DUPLICATE of bug 518880
Product: Fedora
Classification: Fedora
Component: totem (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-03 09:05 EDT by Robert Laverick
Modified: 2009-10-04 14:14 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-04 14:14:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Laverick 2009-10-03 09:05:13 EDT
Description of problem:
When opening a mkv file with totem I get the following error "Can't play a text file without video."

Version-Release number of selected component (if applicable):
totem-2.28.1-1.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1. open an mkv file in totem
  
Actual results:
Displays an error "Can't play a text file without video."

Expected results:
plays the video

Additional info:
Only related internet result I can find is:
https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10/+bug/426421

mkvinfo output:

+ EBML head
|+ Doc type: matroska
|+ Doc type version: 1
|+ Doc type read version: 1
+ Segment, size 309106186
|+ Seek head (subentries will be skipped)
|+ EbmlVoid (size: 4012)
|+ Segment information
| + Timecode scale: 1000000
| + Muxing application: libebml v0.7.7 + libmatroska v0.8.0
| + Writing application: mkvmerge v1.7.0 ('What Do You Take Me For') built on Apr 28 2006 17:20:19
| + Duration: 1573.390s (00:26:13.390)
| + Date: Wed May  3 00:15:20 2006 UTC
| + Segment UID: 0x8d 0x0e 0x04 0x9f 0x8b 0xf7 0xf9 0xec 0xae 0xfc 0x48 0x8d 0xd3 0xc3 0x96 0xc3
|+ Segment tracks
| + A track
|  + Track number: 1
|  + Track UID: 2432630442
|  + Track type: video
|  + Enabled: 1
|  + Default flag: 1
|  + Forced flag: 0
|  + Lacing flag: 0
|  + MinCache: 1
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: V_MPEG4/ISO/AVC
|  + Codec decode all: 1
|  + CodecPrivate, length 41
|  + Default duration: 41.708ms (23.976 fps for a video track)
|  + Language: und
|  + Name: 
|  + Video track
|   + Pixel width: 768
|   + Pixel height: 432
|   + Interlaced: 0
|   + Display width: 768
|   + Display height: 432
| + A track
|  + Track number: 2
|  + Track UID: 2914304396
|  + Track type: audio
|  + Enabled: 1
|  + Default flag: 1
|  + Forced flag: 0
|  + Lacing flag: 1
|  + MinCache: 0
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: A_AAC/MPEG2/LC/SBR
|  + Codec decode all: 1
|  + Default duration: 46.440ms (21.533 fps for a video track)
|  + Language: jpn
|  + Name: Original Japanese Audio (HE-AAC 5.1)
|  + Audio track
|   + Sampling frequency: 22050
|   + Channels: 6
|   + Output sampling frequency: 44100
| + A track
|  + Track number: 3
|  + Track UID: 2190696065
|  + Track type: audio
|  + Enabled: 1
|  + Default flag: 0
|  + Forced flag: 0
|  + Lacing flag: 1
|  + MinCache: 0
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: A_AAC/MPEG2/LC/SBR
|  + Codec decode all: 1
|  + Default duration: 46.440ms (21.533 fps for a video track)
|  + Language: eng
|  + Name: Dubbed English Audio (HE-AAC 5.1)
|  + Audio track
|   + Sampling frequency: 22050
|   + Channels: 6
|   + Output sampling frequency: 44100
| + A track
|  + Track number: 4
|  + Track UID: 2747758521
|  + Track type: subtitles
|  + Enabled: 1
|  + Default flag: 1
|  + Forced flag: 0
|  + Lacing flag: 0
|  + MinCache: 0
|  + Timecode scale: 1
|  + Max BlockAddition ID: 0
|  + Codec ID: S_TEXT/ASS
|  + Codec decode all: 1
|  + CodecPrivate, length 1375
|  + Language: eng
|  + Name: English Subtitles
|+ EbmlVoid (size: 1024)
|+ Attachments
| + Attached
|  + File name: GalliardStd-Ultra.ttf
|  + Mime type: application/x-truetype-font
|  + File data, size: 45800
|  + File UID: 1474771124
|+ Cluster
Comment 1 Bastien Nocera 2009-10-03 20:05:12 EDT
Gstreamer's missing-plugins support is currently broken, so instead of looking for a codec for the video track, it'll try to play just the text track, which it can't.

That should be fixed when we merge the upstream fixes (see bug 518880).

Do you have any MPEG-4 video decoder installed?
Comment 2 Robert Laverick 2009-10-04 10:55:15 EDT
I've installed xvidcore and gstreamer-plugins-bad and -ugly from fusion, but still get the same error, I would have thought that one of those would add the support I needed, any idea which if there's anything yum can install?  I don't recall having this problem with F10/11...
Comment 3 Robert Laverick 2009-10-04 11:01:54 EDT
Doh, no more than 2 min after posting I found gstreamer-ffmpeg and now it plays, so the only problem is the error message not being very helpful, assuming that is covered in bug 518880 then we can mark this as a duplicate.
Comment 4 Bastien Nocera 2009-10-04 14:14:27 EDT

*** This bug has been marked as a duplicate of bug 518880 ***

Note You need to log in before you can comment on or make changes to this bug.