Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 527092 - KMS: resume from suspend-to-disk broken again on Mobility Radeon X1300 [1002:7149]
Summary: KMS: resume from suspend-to-disk broken again on Mobility Radeon X1300 [1002:...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Dave Airlie
QA Contact: Fedora Extras Quality Assurance
URL: http://www.smolts.org/client/show/pub...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-10-04 11:24 UTC by Stefan Becker
Modified: 2018-04-11 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-06 11:56:48 UTC
Type: ---


Attachments (Terms of Use)
X server log (51.26 KB, text/plain)
2009-10-04 11:42 UTC, Stefan Becker
no flags Details

Description Stefan Becker 2009-10-04 11:24:43 UTC
Description of problem:

After bug #522070 was fixed, suspend-to-disk & resume worked nicely. With the latest updates from rawhide it seems the X server crashes after the resume has been completed. When KMS is disabled resume from suspend-to-disk works fine.

Version-Release number of selected component (if applicable):
kernel-2.6.31.1-56.fc12.i686
xorg-x11-drv-ati-6.13.0-0.6.20090929git7968e1fb8.fc12.i686
libdrm-2.4.14-1.fc12.i686
mesa-libGL-7.6-0.13.fc12.i686
xorg-x11-server-Xorg-1.6.99.903-2.fc12.i686

How reproducible:
always

Additional info:

- compared to bug #522070 these parts have changed since then:
kernel-2.6.31.1-48.fc12.i686
xorg-x11-drv-ati-6.13.0-0.4.20090908git651fe5a47.fc12.i686

Unfortunately I don't know the previous xorg-x11-server version

- when I activate hibernate the system switches to a VT and sometimes there is a warning like "unexpected NMI. You must have a HW problem. Trying to continue".

- the resume completes, i.e. I hear the BIOS beep and the sleep LED flashes shortly. After that it should switch to the locked X session screen, but instead after a short while you see X start up again and gdm appears.

- I couldn't see any "crash" messages in /var/log/Xorg.0.log.old or /var/log/messages. So it is only my guess that the X server crashes. When I login into a tty I can see some of my old processes from the previous X session are still active.

- my xorg.conf:

Section "Device"
        Identifier  "Videocard0"
        Driver      "radeon"
        Option "AccelMethod" "XAA"
EndSection

I have to use "XAA" because of bug #524312

Comment 1 Stefan Becker 2009-10-04 11:42:43 UTC
Created attachment 363593 [details]
X server log

Retested with the kernel from bug #522070: same problem. So the bug must be in the newer xorg-x11-drv-ati.

There was a driver crash recorded in Xorg.0.log.old but I missed it in my cursory check. See attached log file.

Comment 2 Matěj Cepl 2009-10-05 22:02:12 UTC
Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x3c) [0x80e561c]
1: /usr/bin/Xorg (0x8048000+0x5eb26) [0x80a6b26]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xb9040c]
3: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xba1000+0xa2301) [0xc43301]
4: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xba1000+0xd040b) [0xc7140b]
5: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xba1000+0xd050b) [0xc7150b]
6: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xba1000+0xcc499) [0xc6d499]
7: /usr/bin/Xorg (0x8048000+0x1333b2) [0x817b3b2]
8: /usr/bin/Xorg (0x8048000+0x88fb3) [0x80d0fb3]
9: /usr/lib/xorg/modules/extensions/libglx.so (0x5c7000+0x424b5) [0x6094b5]
10: /usr/bin/Xorg (xf86Wakeup+0x513) [0x80b2923]
11: /usr/bin/Xorg (WakeupHandler+0x52) [0x8073792]
12: /usr/bin/Xorg (WaitForSomething+0x1a2) [0x80a0e72]
13: /usr/bin/Xorg (0x8048000+0x25ea0) [0x806dea0]
14: /usr/bin/Xorg (0x8048000+0x1a855) [0x8062855]
15: /lib/libc.so.6 (__libc_start_main+0xe6) [0x882b36]
16: /usr/bin/Xorg (0x8048000+0x1a441) [0x8062441]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Comment 3 Dave Airlie 2009-10-06 08:40:16 UTC
can you please retest with latest -ati and X.org server?

Comment 4 Stefan Becker 2009-10-06 11:56:48 UTC
Needed also latest xorg-x11-server for driver to work correctly. Retested with:

kernel-2.6.31.1-58.fc12.i686
xorg-x11-server-Xorg-1.7.0-1.fc12.i686
xorg-x11-drv-ati-6.13.0-0.7.20091006git457646d73.fc12.i686
libdrm-2.4.14-1.fc12.i686
mesa-libGL-7.6-0.13.fc12.i686

Resume for hibernate seems to work OK again.

But a couple of things I noticed:

 - Option "AccelMethod" "XAA" in xorg.conf seems to be ignored now. Driver uses EXA

 - As far as I can see bug #524312 seems to be fixed, so I wouldn't need XAA anyway any more...

 - Some (KDE) icons are broken with the new driver. Instead of the icon you see a square with random color pixels


Note You need to log in before you can comment on or make changes to this bug.