Bug 527258 - When using NFS installation source - Cannot retrieve repository metadata for respository: UIedited_0.
Summary: When using NFS installation source - Cannot retrieve repository metadata for ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Radek Vykydal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F12Blocker, F12FinalBlocker
TreeView+ depends on / blocked
 
Reported: 2009-10-05 15:36 UTC by James Laska
Modified: 2013-09-02 06:40 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-10-22 19:46:39 UTC


Attachments (Terms of Use)
Screenshot (112.28 KB, image/png)
2009-10-05 15:36 UTC, James Laska
no flags Details
anaconda.log (47.19 KB, text/plain)
2009-10-05 15:37 UTC, James Laska
no flags Details
yum.log (3.84 KB, text/plain)
2009-10-05 15:38 UTC, James Laska
no flags Details
syslog (63.14 KB, text/plain)
2009-10-05 15:39 UTC, James Laska
no flags Details
program.log (11.30 KB, text/plain)
2009-10-05 15:39 UTC, James Laska
no flags Details

Description James Laska 2009-10-05 15:36:35 UTC
Created attachment 363697 [details]
Screenshot

Description of problem:

Initiate an NFS install of rawhide.  At the repo selection screen, attempts to modify the 'install repo' fail. 

Version-Release number of selected component (if applicable):

 * anaconda-12.32

How reproducible:
 * Seems everytime

Steps to Reproduce:
1. Initiate NFS install (adjust command below as needed)

# virt-install -n vguest1 -r 1024 --vcpus 2 --os-variant fedora11 -v --accelerate -b br0 -l nfs:ntap-curly.corp.redhat.com:/vol/fedora/rawhide/nightly/rawhide-20091005/x86_64/os -f /dev/VolGroup00/vguest1-disk0 --arch x86_64 --nographics -x "console=ttyS0 serial lang=en keymap=us ksdevice=link ip=dhcp vnc"

2. Proceed to yum repo selection dialog
3. Click edit on 'install repo'
  
Actual results:

Dialog appears ...

"Unable to read package metadata from repository.  This
may be due to a missing repodata directory.  Please ensure
that your repository has been correctly generated.

Cannot retrieve repository metadata (repomd.xml) for
repository: UIedited_0.  Please verify it's path and try again"

Expected results:

Opening the edit dialog on a repo, and just clicking "OK" shouldn't cause any failures.

Additional info:

 * See attached screenshot

Comment 1 James Laska 2009-10-05 15:37:58 UTC
Created attachment 363698 [details]
anaconda.log

Comment 2 James Laska 2009-10-05 15:38:15 UTC
Created attachment 363699 [details]
yum.log

Comment 3 James Laska 2009-10-05 15:39:05 UTC
Created attachment 363700 [details]
syslog

Comment 4 James Laska 2009-10-05 15:39:22 UTC
Created attachment 363701 [details]
program.log

Comment 5 Radek Vykydal 2009-10-20 09:45:29 UTC
I believe this should be fixed in version 12.38 of anaconda but I don't seem to be able to test it locally due to bug #527257.

Comment 6 Adam Williamson 2009-10-21 16:22:21 UTC
James, please test. Thanks!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 7 James Laska 2009-10-22 19:46:39 UTC
Tested and resolved as of anaconda-12.38


Note You need to log in before you can comment on or make changes to this bug.