Bug 527286 - Disable HDA power management on sound cards which are known to make "plopp" sounds when powering down
Disable HDA power management on sound cards which are known to make "plopp" s...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 539304 548123 (view as bug list)
Depends On:
Blocks: F13Target
  Show dependency treegraph
 
Reported: 2009-10-05 14:37 EDT by Lennart Poettering
Modified: 2013-01-10 03:03 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 572898 (view as bug list)
Environment:
Last Closed: 2010-02-13 02:50:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2009-10-05 14:37:50 EDT
Quite a few HDA (and other sound cards) are known to make faint "plopp" or other noises when powering down/up. For some cards these noises can be suppressed in software, however for others this appears not to be possible (according to some HDA driver devs at least, as discussed a Plumbers conf). It would be nice if we could have a blacklist in the kernel that makes sure power saving is only enabled for those where this plopp sound is known to not exist.
Comment 1 Lennart Poettering 2009-10-05 14:40:46 EDT
As a side note: OpenSuse disables all power management for sound cards on power plug/unplug via a script in/usr/lib/pm-utils/power.d/sound-pm. mjg59 thinks this is not a good idea we should follow, saying that what isn't acceptable in AC mode isn't acceptable in battery mode either. And I guess I agree.
Comment 2 Chuck Ebbert 2009-10-06 04:02:52 EDT
But where is that list? Every release we try to enable the power savings and each time we end up disabling it.

Also, I've got a machine that turns the speaker LED orange to indicated the sound is muted.... and that happens when we turn off the power to the card even though we're not really muted.
Comment 3 Bug Zapper 2009-11-16 08:16:40 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 4 Jaroslav Kysela 2009-11-24 08:21:29 EST
I would prefer an user space solution for this problem. Any default behaviour is not ideal in this case, because:

a) if this function is off - it might be obsolete with new HDA driver code
b) if this function is on - cracks on hw on/off

Perhaps, a mixer control like "Power Save" might be introduced, so users can touch this behaviour in a GUI.
Comment 5 Lennart Poettering 2009-12-17 10:42:34 EST
(In reply to comment #4)
> Perhaps, a mixer control like "Power Save" might be introduced, so users can
> touch this behaviour in a GUI.  

Uh, I dont think forwarding this problem to the user really brings us forward.

We could add a couple of rules for this udev. I am pretty sure I can convince Kay to accept rules into udev for this, although this looks a like a lot of work to maintain...

Alternatively this could be maintained as part of the alsa mixer init db?
Comment 6 Lennart Poettering 2009-12-17 10:43:49 EST
*** Bug 548123 has been marked as a duplicate of this bug. ***
Comment 7 Michal Schmidt 2010-01-05 07:22:08 EST
*** Bug 539304 has been marked as a duplicate of this bug. ***
Comment 8 Michal Schmidt 2010-01-05 07:35:23 EST
This issue is listed as one of the Common F12 bugs:
https://fedoraproject.org/wiki/Common_F12_bugs#hda-clicks

In the absence of a list of known good/bad models we really should default to the safe choice (e.g. disable powersaving).
Comment 9 Alex Tunc 2010-01-18 12:26:41 EST
echo 0 > /sys/module/snd_hda_intel/parameters/power_save  first helped but when I change volume sound crackling again! only volume at %100 no crackling. Any clue ?
Comment 10 Christopher Beland 2010-02-12 17:09:30 EST
F13 Beta Blocker criterion 14 says: "In most cases, the installed system must be able to play back sound with gstreamer-based applications".  This bug isn't exactly "sound doesn't work at all" but it is listed on Common Bugs and is apparently fairly visible.  Nominating as F13Target.
Comment 11 Michal Schmidt 2010-02-13 02:50:40 EST
Since kernel builds around 2.6.32.3 HDA powersaving has been disabled by default (CONFIG_SND_HDA_POWER_SAVE_DEFAULT=0) in both F-12 and devel branches.
Comment 12 nucleo 2012-09-15 16:59:49 EDT
SND_HDA powersaving defaults can be changed for kernels in current (F16+) releases (looks like no plopp sounds here)?

Note You need to log in before you can comment on or make changes to this bug.