Bug 539304 - Crackles with F12 kernel - snd_hda_intel - 82801H (ICH8) HD Audio
Crackles with F12 kernel - snd_hda_intel - 82801H (ICH8) HD Audio
Status: CLOSED DUPLICATE of bug 527286
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 15:28 EST by Kai Engert (:kaie)
Modified: 2010-01-05 07:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-05 07:22:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kai Engert (:kaie) 2009-11-19 15:28:37 EST
Boot into F12 live stick:
  crackles on all sound related occassions:
  - before I start playing sound (the crackle may "eat" the first sound)
  - shortly after I stop playing sound
  - when I change volume level

I get the same crackles on my f12 installed system which I had upgraded from f11.

As a test, I installed an older kernel from Fedora "11".
Booting a F12 installation with an F11 kernel => no crackles

pulseaudio-0.9.19-2.fc12

no crackles: kernel-PAE-2.6.30.9-96.fc11.i686

   crackles: kernel-PAE-2.6.31.5-127.fc12.i686


$ lspci |grep -i audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Lenovo Thinkpad R61
Comment 1 Kai Engert (:kaie) 2009-12-04 02:40:49 EST
No change with newer kernel 2.6.18-164.el5

I had tried to boot the f12 system with a 2.6.32 kernel from rawhide, but it fails to start up on my system.

Is there anything I could trace so you'd get a clue what's failing?
Comment 2 Kai Engert (:kaie) 2009-12-04 06:49:03 EST
I worked with Zoltan Hopper on #fedora and we iterated all the possible configurations for pulseaudio, and none of the tweaks helped (this was expected, as keeping all configuration the same, but using the f11 kernel, works).

I concluded the cause must be a kernel module. My best bet was the snd-hda-intel module.

I compiled multiple versions of kernel source directory sound/pci/hda myself and for each compiled snapshot I replaced the contents of /lib/modules/<v>/kernel/sound/pci/hda then rebooted and tried it.

During all my attempts it still crackled.

To my surprise, even using the source from fedora-11-kernel-source-rpm and applying the hda* patches found there didn't work.

I had tried sound/pci/hda from 2.6.30 plain, 2.6.31 plain, 2.6.32 plain, 2.6.30-fedora-11

I have to conclude that some kernel part is responsible for the crackles. Does that make sense?

Could you please propose other modules I could try to replace from the older kernel version?

I am now running the 2.6.30 fedora 11 kernel, because the phat crackle sound produced by the f12 kernel every couple of seconds is unbearable.
Comment 3 Michal Schmidt 2009-12-04 07:39:12 EST
It could be caused by something in the core ALSA layer.
If plain 2.6.30 works and 2.6.31 crackles, and if noone has a better suggestion, there's always the possibility to try git bisect ...
Comment 4 Kai Engert (:kaie) 2009-12-04 07:58:25 EST
After spending more than 6 hours in total, I just found the solution.

# grep CONFIG_SND_HDA_POWER_SAVE_DEFAULT config-generic
CONFIG_SND_HDA_POWER_SAVE_DEFAULT=5

In F11, it was 0, in F12 it was changed to 5.

At runtime I can use
  echo 0 > /sys/module/snd_hda_intel/parameters/power_save
to stop the crackles.

I'll add a note to the f12-common-bugs wiki page.


Would you like to consider to reset this value back to 0, until the chipset is able to powersave without crackling?
Comment 5 Kai Engert (:kaie) 2009-12-07 17:20:42 EST
https://fedoraproject.org/wiki/Common_F12_bugs#hda-clicks
Comment 6 Petr Šplíchal 2010-01-05 03:04:20 EST
> Would you like to consider to reset this value back to 0, until
> the chipset is able to powersave without crackling?  

+1 to disable this until the chipset is ready.
Comment 7 Michal Schmidt 2010-01-05 07:22:07 EST

*** This bug has been marked as a duplicate of bug 527286 ***

Note You need to log in before you can comment on or make changes to this bug.