Bug 52748 - Sound server fatal error (CPU overload) when starting KDE
Sound server fatal error (CPU overload) when starting KDE
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Doug Ledford
:
: 52637 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 14:05 EDT by kfrechet
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-16 13:14:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kfrechet 2001-08-28 14:05:50 EDT
Description of Problem:
When logging into KDE, the system halts for several seconds, then resumes 
operation and displays the error dialog, "Sound server fatal error: cpu 
overload, aborting". When the user presses OK to continue, "KNotify" 
crashes and causes a crash dialog to be displayed. The description 
reported in the crash dialog is: "The application KNotify (knotify) 
crashed and caused the signal 6 (SIGABRT)."

Version-Release number of selected component (if applicable):
KDE 2.2. I don't know exactly which component is failing.

How Reproducible:
100%

Steps to Reproduce:
1. Boot RH 7.2 Roswell-2 (7.1.94)
2. Type userid and password, and log into KDE
3. (failure occurs at this point)

Actual Results:
The sound server aborts. Apps that use the sound server don't work, 
including system sounds.

Expected Results:
Apps that use the sound server should work, including system sounds.

Additional Information:
The failure doesn't occur with Gnome.
Comment 1 Glen Foster 2001-08-28 14:54:18 EDT
What sound card do you have?  Can you send "lspci" and "lspci -v" output,
please?
Comment 2 kfrechet 2001-08-28 23:35:55 EDT
The system uses Intel's new 830M (Almador) chip set, which uses the ICH-3 for 
audio support (AC'97). The other half of the audio is provided by a Crystal 
4299 codec.

Output for lspci.
======
00:00.0 Host bridge: Intel Corporation: Unknown device 3575 (rev 02)
00:01.0 PCI bridge: Intel Corporation: Unknown device 3576 (rev 02)
00:1d.0 USB Controller: Intel Corporation: Unknown device 2482 (rev 01)
00:1d.1 USB Controller: Intel Corporation: Unknown device 2484 (rev 01)
00:1d.2 USB Controller: Intel Corporation: Unknown device 2487 (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801BA PCI (rev 41)
00:1f.0 ISA bridge: Intel Corporation: Unknown device 248c (rev 01)
00:1f.1 IDE interface: Intel Corporation: Unknown device 248a (rev 01)
00:1f.3 SMBus: Intel Corporation: Unknown device 2483 (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation: Unknown device 2485 
(rev 01)
01:00.0 VGA compatible controller: S3 Inc.: Unknown device 8c2e (rev 05)
02:00.0 CardBus bridge: Texas Instruments PCI1420
02:00.1 CardBus bridge: Texas Instruments PCI1420
02:02.0 Communication controller: Lucent Microelectronics WinModem 56k (rev 01)
02:08.0 Ethernet controller: Intel Corporation: Unknown device 1031 (rev 41)
===================================================

Output of lspci -v
======
00:00.0 Host bridge: Intel Corporation: Unknown device 3575 (rev 02)
	Subsystem: IBM: Unknown device 021d
	Flags: bus master, fast devsel, latency 0
	Memory at d0000000 (32-bit, prefetchable) [size=256M]
	Capabilities: [40] #09 [0105]
	Capabilities: [a0] AGP version 2.0

00:01.0 PCI bridge: Intel Corporation: Unknown device 3576 (rev 02) (prog-if 00 
[Normal decode])
	Flags: bus master, 66Mhz, fast devsel, latency 96
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
	Memory behind bridge: c0100000-c01fffff
	Prefetchable memory behind bridge: e0000000-ebffffff

00:1d.0 USB Controller: Intel Corporation: Unknown device 2482 (rev 01) (prog-
if 00 [UHCI])
	Subsystem: IBM: Unknown device 0220
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 1800 [size=32]

00:1d.1 USB Controller: Intel Corporation: Unknown device 2484 (rev 01) (prog-
if 00 [UHCI])
	Subsystem: IBM: Unknown device 0220
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 1820 [size=32]

00:1d.2 USB Controller: Intel Corporation: Unknown device 2487 (rev 01) (prog-
if 00 [UHCI])
	Subsystem: IBM: Unknown device 0220
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 1840 [size=32]

00:1e.0 PCI bridge: Intel Corporation 82801BA PCI (rev 41) (prog-if 00 [Normal 
decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=08, sec-latency=64
	I/O behind bridge: 00002000-00006fff
	Memory behind bridge: c0200000-cfffffff
	Prefetchable memory behind bridge: f0000000-f7ffffff

00:1f.0 ISA bridge: Intel Corporation: Unknown device 248c (rev 01)
	Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation: Unknown device 248a (rev 01) (prog-if 
8a [Master SecP PriP])
	Subsystem: IBM: Unknown device 0220
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 01f0 [size=8]
	I/O ports at 03f4
	I/O ports at 0170 [size=8]
	I/O ports at 0374
	I/O ports at 1860 [size=16]
	Memory at 10000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corporation: Unknown device 2483 (rev 01)
	Subsystem: IBM: Unknown device 0220
	Flags: medium devsel, IRQ 11
	I/O ports at 1880 [size=32]

00:1f.5 Multimedia audio controller: Intel Corporation: Unknown device 2485 
(rev 01)
	Subsystem: IBM: Unknown device 0222
	Flags: bus master, medium devsel, latency 0, IRQ 11
	I/O ports at 1c00 [size=256]
	I/O ports at 18c0 [size=64]

01:00.0 VGA compatible controller: S3 Inc.: Unknown device 8c2e (rev 05) (prog-
if 00 [VGA])
	Subsystem: IBM: Unknown device 01fc
	Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
	Memory at c0100000 (32-bit, non-prefetchable) [size=512K]
	Memory at e8000000 (32-bit, prefetchable) [size=64M]
	Memory at e4000000 (32-bit, prefetchable) [size=64M]
	Memory at e0000000 (32-bit, prefetchable) [size=32M]
	Expansion ROM at <unassigned> [disabled] [size=64K]
	Capabilities: [dc] Power Management version 2
	Capabilities: [80] AGP version 2.0

02:00.0 CardBus bridge: Texas Instruments PCI1420
	Subsystem: IBM: Unknown device 023b
	Flags: bus master, medium devsel, latency 168, IRQ 11
	Memory at c0202000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=02, secondary=03, subordinate=05, sec-latency=176
	Memory window 0: f0000000-f03ff000 (prefetchable)
	Memory window 1: c0400000-c07ff000
	I/O window 0: 00002000-000020ff
	I/O window 1: 00002400-000024ff
	16-bit legacy interface ports at 0001

02:00.1 CardBus bridge: Texas Instruments PCI1420
	Subsystem: IBM: Unknown device 023b
	Flags: bus master, medium devsel, latency 168, IRQ 11
	Memory at c0203000 (32-bit, non-prefetchable) [size=4K]
	Bus: primary=02, secondary=06, subordinate=08, sec-latency=176
	Memory window 0: f0400000-f07ff000 (prefetchable)
	Memory window 1: c0800000-c0bff000
	I/O window 0: 00002800-000028ff
	I/O window 1: 00002c00-00002cff
	16-bit legacy interface ports at 0001

02:02.0 Communication controller: Lucent Microelectronics WinModem 56k (rev 01)
	Subsystem: AMBIT Microsystem Corp.: Unknown device 0410
	Flags: bus master, medium devsel, latency 0, IRQ 11
	Memory at c0201000 (32-bit, non-prefetchable) [size=256]
	I/O ports at 6440 [size=8]
	I/O ports at 6000 [size=256]
	Capabilities: [f8] Power Management version 2

02:08.0 Ethernet controller: Intel Corporation: Unknown device 1031 (rev 41)
	Subsystem: IBM: Unknown device 0209
	Flags: bus master, medium devsel, latency 66, IRQ 11
	Memory at c0200000 (32-bit, non-prefetchable) [size=4K]
	I/O ports at 6400 [size=64]
	Capabilities: [dc] Power Management version 2
===================================================
Comment 3 Bernhard Rosenkraenzer 2001-08-29 06:43:41 EDT
Looks like a sound driver issue to me, especially since it just works on 
pretty much all other soundcards.
Arjan, are there any known problems with this card?

Comment 4 Bernhard Rosenkraenzer 2001-08-29 06:44:42 EDT
*** Bug 52637 has been marked as a duplicate of this bug. ***
Comment 5 Arjan van de Ven 2001-08-29 06:46:15 EDT
Not really; we do have minor upgrade for it, but no real bugs
Comment 6 passon 2001-09-03 09:55:49 EDT
Hi,
I have the equal error here on my Toshiba Satellite Pro 4600 Laptop with
different Intel onboard chipset (lspci -v output):
---------------------
00:1f.5 Multimedia audio controller: Intel Corporation: Unknown device 2445 (rev 03)
Subsystem: Toshiba America Info Systems: Unknown device 0001
Flags: bus master, medium devsel, latency 0, IRQ 11
I/O ports at ce00 [size=256]
I/O ports at cdc0 [size=64]
---------------------
 
The error didn't occured with RedHat kernel-2.4.2-2 from 7.1. Upgrade to newer
kernels up to 2.4.7-2 (from rawhide) resulted in described error.

With the actual kernel-2.4.7-2.9 (from rawhide) the error vanished, but now
another error message bails out:

---------------------
     Sound server fatal error:

     Error while initializing the sound driver:
     audio device doesn't support number of requested channels
---------------------

Hope this is kind of helpful information fo you

Cheers,

Chris
Comment 7 passon 2001-09-16 13:14:02 EDT
If I run GNOME Desktop sound is working properly with kernel-2.4.7-2.9. Thus it 
seems to be a problem with the artsd. 

So short,

Chris
Comment 8 Doug Ledford 2001-09-19 09:48:25 EDT
This is an interaction between the artsd daemon and the i810 sound driver.  A
fix has been included in the kernel.  Marking this as closed.
Comment 9 passon 2001-09-30 06:50:21 EDT
Sorry, 

but the recent kernel-2.4.9 and artsd from rawhide (date 09/17/01) don't help. 
The sound server (artsd) is again consuming 100% CPU and aborts after a while 
with the well known dialog. 
Hope that will be fixed in 7.2.

Cheers,

Chris

Note You need to log in before you can comment on or make changes to this bug.