This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 52774 - Install failed on two machines at gui process python step unknown reason.
Install failed on two machines at gui process python step unknown reason.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-28 19:00 EDT by C. J. Croucher
Modified: 2007-04-18 12:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-21 12:22:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bug report issued by annaconda (1.08 KB, patch)
2001-08-28 19:01 EDT, C. J. Croucher
no flags Details | Diff
Anaconda Dump file from fail of install on 08/09/2001 (1.08 KB, text/plain)
2001-09-08 19:19 EDT, C. J. Croucher
no flags Details
F1 error results (1.69 KB, patch)
2001-09-08 19:20 EDT, C. J. Croucher
no flags Details | Diff
F2 error results (53 bytes, patch)
2001-09-08 19:21 EDT, C. J. Croucher
no flags Details | Diff
F3 error results (1.22 KB, patch)
2001-09-08 19:23 EDT, C. J. Croucher
no flags Details | Diff
F4 error results (1.68 KB, patch)
2001-09-08 19:23 EDT, C. J. Croucher
no flags Details | Diff
F5 error results (1.25 KB, patch)
2001-09-08 19:23 EDT, C. J. Croucher
no flags Details | Diff

  None (edit)
Description C. J. Croucher 2001-08-28 19:00:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

Description of problem:
After Disk two is done installing I get the following message from two 
separate (and wildly different machines, can provide complete hardware 
profile on demand (Summary one is a Tyan Tiger133 running 512 MB SDRAM and 
2 10GByte drives each system has a SIIG SCSI card, the other system is an 
Intel VC820 with a 128 MB RIMM)

Was attempting a Server install with Webserver (tried with all servers and 
no servers), KDE and XWindows of Red hat v7.1.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Server Install
2.KDE
3.XWindows
4.WebServer (or all servers or no servers)
	

Actual Results:  Crashed consecutively and predictably at the position 
indicated in "Additional Information".

Rebooting brings up "missing operating system" message. :P

Expected Results:  Reboots and KDE or XWindow GUI comes up, I'm a happy 
camper and the world is a better place. :)

Additional info:

This is the error described by anaconda or whatever the app is at the 
installation phase:
Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 
19, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 2081, in 
doInstall
    self.hdList, self.upgrade, langlist)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 404, in 
install
    initrd = self.makeInitrd (kernelTag, instRoot)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 256, in 
makeInitrd
    root = instRoot)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py", line 48, in 
execWithRedirect
    raise RuntimeError, command + " can not be run"
RuntimeError: /sbin/mkinitrd can not be run

Local variables in innermost frame:
argv: ['/sbin/mkinitrd', '--ifneeded', '-f', '/boot/initrd-2.4.2-
2.img', '2.4.2-2']
root: /mnt/sysimage
stdin: 0
newPgrp: 0
stdout: 29
stderr: 29
command: /sbin/mkinitrd
searchPath: 1
ignoreTermSigs: 0

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S'1280x1024'
p4
sS'progressWindow'
p5
(igui
ProgressWindow
(dp6
S'total'
p7
I435
sS'window'
p8
(igtk
GtkWindow
(dp9
S'_o'
p10
<failed>
Comment 1 C. J. Croucher 2001-08-28 19:01:15 EDT
Created attachment 30014 [details]
Bug report issued by annaconda
Comment 2 Francesco 2001-08-29 08:36:50 EDT
Hello, I've got a very similar problem installing Reh Hat 7.1 on a HP Omnibook 
5700CTX. The installation failed every time, I've even tryed to install in 
every way, I mean using text, expert, specifing the memory on the omnibook 
(64M), installing just the kernel but every time it fails.

Thanks
Francesco
Comment 3 Brent Fox 2001-08-29 14:52:57 EDT
psychotica.rex, when the installer crashes, can you press <Ctrl><Alt><F4> and
see if there are any error related to the cdrom?
Comment 4 C. J. Croucher 2001-08-29 20:37:47 EDT
I tried adding a comment but your page died on me. :P

Well I'm going to Re-type the last  6 lines instead of the whole thing this 
time, sorry but I hate typography. ;)

<4>SCSI device sdb: 17755614 512-byte hdwr sectors (9091 MB)
<6> sdb: sdb1
<4>SCSI device sdb: 17755614 512-byte hdwr sectors (9091 MB)
<6> sdb: sdb1
<6>Adding SWap: 1052216k swap-space (priority -1)
<7>ISO 9660 Extensions: RRIP_1991A

There, does this indicate something to you about my current delema?
Comment 5 C. J. Croucher 2001-08-29 21:16:05 EDT
Using:
<alt><ctrl><F3> I found that the 
* Mounting /proc/bus/usb in install path
* Mount of USB failed

were the last two lines in the list..... :(

I do infact have on board usb support though....

Worse still I don't really WANT Usb support. :P



<alt><ctrl><F1> brings up an interesting list:
RuntimeError: /sbin/mskinitrd can not be run

is the last line of it the rest is identical to the previous errors list posted 
firstly.


Clicking on "Debug" brings up a few interesting things which seem to be a 
ritteration of the f1 command....

> /var/tmp/anaconda-7.1//usr/lib/anaconda/iutil.py(48)execWithRedirect()
-> raise RuntimeError, command + " can not be run"


I dunno....anything?


Comment 6 Francesco 2001-08-30 12:50:13 EDT
Hi, below the text into the anacdump.txt, I don't understand it at all :-(( 
sorry. Hope this can help to find a solution.
Ciao, F


Traceback (innermost last):
  File "/usr/bin/anaconda", line 520, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1126, in run
    rc = apply (step[1](), args)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 551, in __call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1852, in 
doInstall
    (p, self.intf.messageWindow, pkgTimer))
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1564, in 
instCallback
    fn = self.method.getFilename(h, pkgTimer)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/image.py", line 87, in 
getFilename
    isys.umount("/mnt/source")
  
File "/mnt/redhat/test/qa0408.4/i386/RedHat/instimage/usr/lib/anaconda/isys.py",
 line 140, in umount
    rc = _isys.umount(what)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
what: /mnt/source
removeDir: 1

ToDo object:
(itodo
ToDo
p1
(dp2
S'resState'
p3
S''
sS'progressWindow'
p4
(itext
ProgressWindow
(dp5
S'scale'
p6
NsS'screen'
p7
(isnack
SnackScreen
p8
(dp9
S'height'
p10
I37
sS'width'
p11
I100
sS'helpCb'
p12

<failed>
Comment 7 Brent Fox 2001-09-06 10:32:44 EDT
francescopace@virgilio.it, the bug you are seeing looks like a dupe of bug
#36988, but it is unrelated to this bug report.  Check bug #36988, and if the
info there doesn't help you, please open a new bug report.
Comment 8 Brent Fox 2001-09-06 10:36:18 EDT
 psychotica.rex@sympatico.ca, the output messages that you attached above don't
seem to indicate any obvious problem.  I'm suspicious that the cd #2 might be
bad.  Did you download them, and if so, did you verify the MD5 sum of the ISO
image before you burned the cd?
Comment 9 Francesco 2001-09-07 03:15:05 EDT
OK, I'll try to start the process with "ide=nodma" option.
Sorry for the confusion.

thanks
Francesco

Comment 10 C. J. Croucher 2001-09-08 19:15:38 EDT
I've turned on two USB settings in my CMOS one that assigns an IRQ and one that 
turns on autodetect and as indicated by the results the USB passes (That little 
glitch is now behind us I'd hope).  So it turns out the USB isn't crashing the 
install.

On this install I also tried the command 'linux ide=nodma' at the boot prompt.  
Everything seemed to work ok otherwise.

Same problems though, the "anaconda" installation script program is crashing 
and presenting errors I'll attach the various results of information screens 
and such to this message.

I want to check the ISO I downloaded but don't know how, I downloaded a CRC32e 
program which does a "32bit" checksum on it but it's one fourth the size of the 
checksum inidcated in the file provided on your website...litterally four times 
the number of characters from the "ed9b4e84" I recieved from the program.  So 
how do I do that massive checksum you've gotten to check against?  Nero doesn't 
SEEM to have it, and neither does Adaptecs EZ CD Creator...so how do I check?  
I'd ordinarily use a linux program (at school or work) but at home I'd need to 
install linux, and to do that I need the ISO on CD, and right now it keeps 
crashing on install...so I'm caught in a bit of a tizzy here. :P
Comment 11 C. J. Croucher 2001-09-08 19:19:43 EDT
Created attachment 31374 [details]
Anaconda Dump file from fail of install on 08/09/2001
Comment 12 C. J. Croucher 2001-09-08 19:20:39 EDT
Created attachment 31375 [details]
F1 error results
Comment 13 C. J. Croucher 2001-09-08 19:21:22 EDT
Created attachment 31376 [details]
F2 error results
Comment 14 C. J. Croucher 2001-09-08 19:23:03 EDT
Created attachment 31377 [details]
F3 error results
Comment 15 C. J. Croucher 2001-09-08 19:23:37 EDT
Created attachment 31378 [details]
F4 error results
Comment 16 C. J. Croucher 2001-09-08 19:23:51 EDT
Created attachment 31379 [details]
F5 error results
Comment 17 C. J. Croucher 2001-09-08 19:25:17 EDT
File attachments
Comment 18 Brent Fox 2001-09-13 18:09:39 EDT
You can use a Windows shareware program called MD5sumer that will check the
md5sum of the ISO file.  It can be downloaded from CNET at: 
http://download.cnet.com/downloads/0-10096-100-5902737.html
Comment 19 Brent Fox 2001-09-13 18:13:30 EDT
The attachments you made don't point to any obvious problem either.
Comment 20 C. J. Croucher 2001-09-14 18:55:38 EDT
Just tested the images and they all check out fine! :(
Narf, I'm getting to the end of my tether on this. :(
Comment 21 Brent Fox 2001-09-21 12:22:48 EDT
Sigh...I'm out of ideas.  Would you be interested in trying the Roswell public
beta for the next release of RHL?
Comment 22 C. J. Croucher 2001-09-22 21:19:15 EDT
HA! I laugh in Murphies enigmatic face, I can defeat every problem if I just 
pound my head enough on a system.

After HOURS of installation tactics, setup, cmos and eventually even yes, the 
SCSI cmos I discovered the problem initially looked over because of a forgoten 
issue of zero precedence in the SCSI Array. :P

I'd have tweaked every concievable option in my CMOS, in Linux, etc...it turns 
out that the SCSI CMOS...or ah I can't remember that abbreviation now it's 
catchy though for automatically setting up SCSI cards and systems had a little 
option.  Boot device ID setting WAS set to one (1).  Having glanced at this and 
assuming that LINUX was installed there since it was after all the primary boot 
device I had no thought of changing it.  HOWEVER!  IT turns out Linux installed 
on device 0 (The exact same model number and the serial number is consecutive 
to the other device so it was difficult to distingiush on setup.).  So when I 
arbitrarly was toying with SCSI device settings I thought "what the hell" and 
changed it to ZERO (0).  Turns out that's where it was installing!

Happy days!

It does make sense, it booted off of a flopy fine, it booted off the system 
fine until the DMA check (Afterwhich it seeks a bootable device).  So inother 
words the link to the Harddrives (the scsi card) was the option being off 
kilter.

Thank you for your patience, I appreciate it! :)

G'day!

happy happy happy happy happy happy. :)
Comment 23 Brent Fox 2001-09-24 11:42:24 EDT
Good!  Glad things are working now.

Note You need to log in before you can comment on or make changes to this bug.