Bug 528097 - /sbin/dmraid needs possibly unmounted /usr/lib
/sbin/dmraid needs possibly unmounted /usr/lib
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
NeedsRetesting
:
: 528426 (view as bug list)
Depends On:
Blocks: F12Blocker/F12FinalBlocker
  Show dependency treegraph
 
Reported: 2009-10-08 23:25 EDT by Bruce Jerrick
Modified: 2009-10-30 13:19 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-30 13:19:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bruce Jerrick 2009-10-08 23:25:53 EDT
Description of problem:
At boot time, if /usr is a separate filesystem, /sbin/dmraid (invoked by
rc.sysinit) fails because it needs /usr/lib/libdmraid.so.1.0.0.rc16, which
is not available until /usr is mounted later in rc.sysinit .

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc16-3.fc12

How reproducible:
100%

Steps to Reproduce:
1. Boot an F12 system with /usr on a separate filesystem (suggestion: boot
     single-user mode; message will stay on screen then).
2. Observe error message from /sbin/dmraid.
or:
1. ldd /sbin/dmraid | grep /usr
  
Actual results:
Error message shortly after "Welcome to Fedora":
    /sbin/dmraid: error while loading shared libraries: \
	/usr/lib/libdmraid.so.1.0.0.rc16: cannot open shared object file: \
	No such file or directory
The ldd command will show one .so file under /usr/lib .

Expected results:
No error message.

Additional info:
Changing the dmraid spec file to install libdmraid.so into /lib will probably
suffice to fix this.  (BTW, libdmraid.so used to be in dmraid-libs .)

/sbin/dmraid.static is not the answer; it's just a symlink to the
dynamically-linked version (presumably for "compatibility").

The problem doesn't happen in F11 because its /sbin/dmraid
(dmraid-1.0.0.rc15-7.fc11) does not use libdmraid.so .
Comment 1 Michal Hlavinka 2009-10-12 04:27:13 EDT
*** Bug 528426 has been marked as a duplicate of this bug. ***
Comment 2 Jim Meyering 2009-10-12 10:17:22 EDT
This burned me, too.
In a few minutes I'll try using the nodmraid boot option, since I have no raid-related devices.
Comment 3 Hans de Goede 2009-10-20 02:06:40 EDT
This is fixed in dmraid-1.0.0.rc16-4.fc12:
http://koji.fedoraproject.org/koji/buildinfo?buildID=136909

Rel-eng nominating this for F12Blocker, as without this fix any raidsets not
brought up by the initrd (so not used for /) will not be available after boot, worse in case of mirrors the system may use a single disk of the mirror instead, causing corruption of the mirror without marking it dirty!
Comment 4 Adam Williamson 2009-10-21 13:08:24 EDT
That dmraid has been tagged into F12 Final. Bruce, once it's available from your mirror, can you please test and confirm the fix? Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 5 Adam Williamson 2009-10-30 13:19:20 EDT
As discussed at last week's blocker meeting, we're closing this as fixed, can't wait for feedback forever. Please re-open if you still have trouble. Thanks.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.