Bug 528426 - libdmraid for dmraid is missing during boot
libdmraid for dmraid is missing during boot
Status: CLOSED DUPLICATE of bug 528097
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 02:27 EDT by Michal Hlavinka
Modified: 2009-10-12 04:27 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-12 04:27:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2009-10-12 02:27:57 EDT
Description of problem:
When booting, there is error messages about missing libdmraid.so.1.0.0.rc16 library for dmraid. I'm not using any raid in my system, everything works, but this error definitely should not be there.

Version-Release number of selected component (if applicable):
dracut-002-13.4.git8f397a9b.fc12.noarch
plymouth-0.8.0-0.2009.29.09.9.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1.just boot
2.
3.
  
Actual results:
/sbin/dmraid: error while loading shared libraries: libdmraid.so.1.0.0.rc16: cannot open shared object file: No such file or directory

Expected results:
no missing libraries

Additional info:

this file is installed on my system:
locate libdmraid.so.1.0.0.rc16
/usr/lib64/libdmraid.so.1.0.0.rc16

                Welcome to Fedora
                Press 'I' to enter interactive startup.
Starting udev: [  OK  ]
Setting hostname localhost.localdomain:  [  OK  ]
Key slot 0 unlocked.
Key slot 0 unlocked.
/sbin/dmraid: error while loading shared libraries: libdmraid.so.1.0.0.rc16: cannot open shared object file: No such file or directory
Setting up Logical Volume Management: [  OK  ]
Checking filesystems
/dev/mapper/luks-f83ecb70-9c76-4da5-9606-a3da7fa0bfe6: clean, 63512/640848 files, 799257/2561031 blocks
/dev/mapper/luks-b38cce2e-ce51-4980-8e9e-7945030983c1: clean, 152407/17088512 files, 22290981/68335110 blocks
/dev/sda1: clean, 45/51200 files, 76181/204800 blocks
/dev/sda3: clean, 146012/640848 files, 1123049/2560000 blocks
[  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]
Comment 1 Harald Hoyer 2009-10-12 02:40:11 EDT
Everything after 

                Welcome to Fedora

is not dracut anymore!!!
Comment 2 Michal Hlavinka 2009-10-12 04:27:13 EDT
oh, it seems it's run by rc.sysinit 

I found duplicate bug report

*** This bug has been marked as a duplicate of bug 528097 ***

Note You need to log in before you can comment on or make changes to this bug.