Bug 528388 - [abrt] crash detected in firefox-3.5.3-1.fc12
[abrt] crash detected in firefox-3.5.3-1.fc12
Status: CLOSED DUPLICATE of bug 536981
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
abrt_hash:1ae94dc8f499afd7148fa91758f...
:
: 540137 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-11 17:34 EDT by Mads Kiilerich
Modified: 2009-11-24 18:59 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-24 18:59:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (95.64 KB, text/plain)
2009-10-11 17:34 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2009-10-11 17:34:06 EDT
abrt detected a crash.


How to reproduce
-----
1.
2.
3.


Additional information
======


Attached files
----
backtrace

cmdline
-----
/usr/lib/firefox-3.5.3/firefox http://mercurial.selenic.com/bts/issue1864 


component
-----
firefox


executable
-----
/usr/lib/firefox-3.5.3/firefox


kernel
-----
2.6.31.1-56.fc12.i686.PAE


package
-----
firefox-3.5.3-1.fc12


reason
-----
Process was terminated by signal 6
Comment 1 Mads Kiilerich 2009-10-11 17:34:09 EDT
Created attachment 364400 [details]
File: backtrace
Comment 2 Mads Kiilerich 2009-10-11 18:08:50 EDT
This is a firefox stacktrace from a crash as reported in Bug 528390

Looking at it it seems like there is nothing interesting here? Except that signal 6 is strange?
Comment 3 Martin Stransky 2009-10-12 05:18:45 EDT
#6  0x0071339a in abort () at abort.c:92
        act = {__sigaction_handler = {sa_handler = 0x10, sa_sigaction = 0x10}, 
          sa_mask = {__val = {8777716, 3218263424, 3218263636, 7689298, 
    3218263424, 3218263404, 8777716, 2608318272, 134578320, 8777716, 71, 70, 
    3218263596, 7660738, 2608318272, 71, 3218263636, 2608318272, 0, 
    4222451712, 2608318272, 2608318272, 2608318272, 2608318272, 2608318342, 
    2608318372, 2608318272, 2608318372, 0, 0, 0, 0}}, sa_flags = 0, 
          sa_restorer = 0x68}
        sigs = {__val = {32, 0 <repeats 31 times>}}
#7  0x0070ac78 in __assert_fail (assertion=0xb51cdb "ret != inval_id", file=
    0xb51ca9 "xcb_io.c", line=378, function=0xb51e5c "_XAllocID")
    at assert.c:81
        buf = 
    0x9ba315b0 "firefox: xcb_io.c:378: _XAllocID: Assertion `ret != inval_id' failed.\n"
#8  0x00ae1b7a in _XAllocID (dpy=0xb7d5c000) at xcb_io.c:378
        ret = 4294967295
        __PRETTY_FUNCTION__ = "_XAllocID"
#9  0x00185bd8 in XRenderCreatePicture () from /usr/lib/libXrender.so.1
No symbol table info available.
#10 0x002e5f7a in _cairo_xlib_surface_ensure_dst_picture (surface=0x9b3f4560)
    at cairo-xlib-surface.c:887

It's inside cairo...
Comment 4 Bug Zapper 2009-11-16 08:31:52 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Yanko Kaneti 2009-11-23 11:10:13 EST
*** Bug 540137 has been marked as a duplicate of this bug. ***
Comment 6 Yanko Kaneti 2009-11-24 18:59:47 EST

*** This bug has been marked as a duplicate of bug 536981 ***

Note You need to log in before you can comment on or make changes to this bug.