Bug 528433 - gdm seems to select keyboard layout at random
gdm seems to select keyboard layout at random
Status: CLOSED DUPLICATE of bug 530452
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-12 04:09 EDT by info@kobaltwit.be
Modified: 2015-01-14 18:23 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-25 09:11:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description info@kobaltwit.be 2009-10-12 04:09:45 EDT
Description of problem:
My native keyboard interface is "Belgium", but I have "US" additionally available. The "Belgium" layout is my preferred layout for normal activities, I only need the "US" layout occasionally.

During login, after clicking on my username, gdm seems to setup a keyboard layout at random. Sometimes it selects "Belgium", sometimes "US". I can't find a pattern in it, although it seems (the incorrect) "US" is selected more often than (the correct) "Belgium".

Version-Release number of selected component (if applicable):
gdm-2.28.0-9.fc12.i686

How reproducible:
Always

Steps to Reproduce:
1. Boot the system into gdm after having setup two keyboard layouts
2. Click on the user
3. Verify the chosen keyboard layout
  
Actual results:
The chosen keyboard layout seems to be selected at random

Expected results:
My preferred keyboard layout should be chosen.

Additional info:
This is a regression. The previous gdm from a couple of weeks ago did not show this behaviour.

If relevant, here is the smolt profile for this machine:
http://www.smolts.org/show?uuid=pub_0077994e-e560-4674-837b-295782cf87ed
Comment 1 info@kobaltwit.be 2009-10-22 12:46:45 EDT
I just upgraded my laptop to F12 Beta.

This problem still persists.
Comment 2 Ville-Pekka Vainio 2009-10-25 05:47:20 EDT
Could this be the same bug as #530452?
Could you try installing gdm-2.28.1-6.fc12 or later from Koji, http://koji.fedoraproject.org/koji/packageinfo?packageID=235

(I'm not a GDM developer, I was just going through the bugs searching for a solution to what was bug 530452.)
Comment 3 info@kobaltwit.be 2009-10-25 09:10:51 EDT
After reading bug 530452, I'm pretty sure my bug is a duplicate. I'll mark it as such and follow up on bug 530452.
Comment 4 info@kobaltwit.be 2009-10-25 09:11:14 EDT

*** This bug has been marked as a duplicate of bug 530452 ***

Note You need to log in before you can comment on or make changes to this bug.