Bug 52847 - xawtv does not work w/ Philips webcam
xawtv does not work w/ Philips webcam
Status: CLOSED DUPLICATE of bug 53711
Product: Red Hat Linux
Classification: Retired
Component: xawtv (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Depends On:
  Show dependency treegraph
Reported: 2001-08-29 19:16 EDT by greg hosler
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-29 19:16:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description greg hosler 2001-08-29 19:16:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-2smp i686; Nav)

Description of problem:
I have a philips webcam PCVC675. I loaded modules pwc and pwcx.

I run xawtv. The screen is black, and on stdout I see the following:

        This is xawtv-3.54, running on Linux/i686 (2.4.7-2smp)
        /dev/video0 [v4l]: no overlay support
        ioctl: VIDIOCMCAPTURE(0,fmt=5,size=128x96): Invalid argument
        ioctl: VIDIOCMCAPTURE(0,fmt=4,size=128x96): Invalid argument
        ioctl: VIDIOCMCAPTURE(0,fmt=1,size=128x96): Invalid argument
        ioctl: VIDIOCMCAPTURE(0,fmt=7,size=128x96): Invalid argument
        no way to get: 384x288 32 bit TrueColor (LE: bgr-)
        no way to get: 384x288 32 bit TrueColor (LE: bgr-)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.see above

Actual Results:  xawtv screen is blank/black

Expected Results:  xawtv should show what the camera sees

Additional info:

The problem is that xawtv 3.54 is too old. The latest snapshot (xawtv-3.61)
available from http://www.in-berlin.de/User/kraxel/xawtv.html
has the support for yuv420p, which is necessary in order to support any
philips webcams
Comment 1 Ngo Than 2001-09-17 15:49:51 EDT

*** This bug has been marked as a duplicate of 53711 ***

Note You need to log in before you can comment on or make changes to this bug.