Bug 528483 - Hplip does not resume printing when network printer comes online
Summary: Hplip does not resume printing when network printer comes online
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 11
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 529906 (view as bug list)
Depends On:
Blocks: 532112
TreeView+ depends on / blocked
 
Reported: 2009-10-12 13:16 UTC by m.oliver
Modified: 2009-11-30 11:02 UTC (History)
4 users (show)

Fixed In Version: 3.9.8-18.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 532112 (view as bug list)
Environment:
Last Closed: 2009-11-13 02:32:21 UTC


Attachments (Terms of Use)
Relevant lines of /var/log/messages (1.08 KB, application/octet-stream)
2009-10-12 13:18 UTC, m.oliver
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 458999 None None None Never

Description m.oliver 2009-10-12 13:16:47 UTC
Description of problem:

Up until early in the Fedora 11 release cycle, jobs in the print queue for a network printer would start printing as soon as a network printer comes online.  Now it is necessary to explicitly resume the printer in CUPS.


Version-Release number of selected component (if applicable):

hplip-3.9.8-12.fc11
(Used on local network with HP Officejet 6315)

How reproducible:

Always

Steps to Reproduce:
1. Switch off printer
2. Print document
3. Switch on printer
  
Actual results:

Nothing happens

Expected results:

Printer will print as soon as it is online (this used to work!)

Additional info:

Opening the cups web interface and explicitly resuming the printer will get the printer started again.

I attach a section of /var/log/messages which was generated by such a failed print attempt.

Comment 1 m.oliver 2009-10-12 13:18:43 UTC
Created attachment 364454 [details]
Relevant lines of /var/log/messages

Comment 2 Tim Waugh 2009-10-22 10:50:59 UTC
*** Bug 529906 has been marked as a duplicate of this bug. ***

Comment 3 Tim Waugh 2009-10-23 11:49:35 UTC
Reported upstream with patch.

Comment 4 Tim Waugh 2009-10-23 12:01:36 UTC
Please try this package:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=137941

Does it fix the problem?

Comment 5 Fedora Update System 2009-10-23 12:09:28 UTC
hplip-3.9.8-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/hplip-3.9.8-15.fc11

Comment 6 Need Real Name 2009-10-23 18:15:17 UTC
Any chance you can push this to Rawhide too?

Comment 7 Tim Waugh 2009-10-23 18:43:52 UTC
If I know it actually fixes the problem, yes. :-)

Does it?

Comment 8 Need Real Name 2009-10-23 19:15:20 UTC
I don't know. I have rawhide hplip-3.9.8-17.fc12

You linked to a F11 Koji build of hplip-3.9.8-15.fc11

What do you want me to install?

Comment 9 Fedora Update System 2009-10-27 06:43:06 UTC
hplip-3.9.8-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

Comment 10 Fedora Update System 2009-10-29 02:54:54 UTC
hplip-3.9.8-16.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

Comment 11 Tim Waugh 2009-10-30 17:02:07 UTC
(In reply to comment #8)
> What do you want me to install?  

Can you try this build please?:
http://koji.fedoraproject.org/koji/buildinfo?buildID=138861

Comment 12 Need Real Name 2009-10-30 21:27:00 UTC
(In reply to comment #11)
> (In reply to comment #8)
> > What do you want me to install?  
> 
> Can you try this build please?:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=138861  

WFM! Thanks :)

btw libsane-hpaio-3.9.8-17.fc12.x86_64 has a dependency on hplip-libs 3.9.8-17.fc12 so needs an update too :/

Comment 13 m.oliver 2009-10-31 05:39:22 UTC
(In reply to comment #16)
(In reply to comment #10)
> hplip-3.9.8-16.fc11 has been pushed to the Fedora 11 testing repository.  If
> problems still persist, please make note of it in this bug report.

Unfortunately, the problem still persists.  What has changed is that I don't get messages in /var/log/messages any more.

Still, when switching on the printer after sending off the print job remains with status 

  Paused - "/usr/lib/cups/backend/hp failed"

in CUPS and starts printing only when manually resumed.

Comment 14 m.oliver 2009-10-31 07:49:48 UTC
(In reply to comment #13)
> (In reply to comment #16)
> (In reply to comment #10)
> > hplip-3.9.8-16.fc11 has been pushed to the Fedora 11 testing repository.  If
> > problems still persist, please make note of it in this bug report.
> 
> Unfortunately, the problem still persists.  What has changed is that I don't
> get messages in /var/log/messages any more.

Update: Reboot necessary.  After reboot, everything is working fine.

Comment 15 Fedora Update System 2009-11-04 12:16:02 UTC
hplip-3.9.8-18.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

Comment 16 Fedora Update System 2009-11-13 02:31:59 UTC
hplip-3.9.8-18.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Need Real Name 2009-11-23 20:38:08 UTC
Problems persist: if I print to the printer when it is off, the printer becomes deactivated. I must reactivate it using as root to get it working again. Instead it should queue the job until the printer is on.

Comment 18 Need Real Name 2009-11-29 10:56:43 UTC
This is not fixed - please can you reopen the bug.

Comment 19 m.oliver 2009-11-30 09:56:02 UTC
Upgraded to F12.  Problem reappears exactly as in my original bug report, now using hplip-3.9.8-21.fc12.

Comment 20 Tim Waugh 2009-11-30 11:02:17 UTC
Fedora 11 contains a fix/workaround for this.  Fedora 12 does not yet because of upstream disagreement with the fix.

See bug #532112 for the Fedora 12 version of this bug, which is still open.


Note You need to log in before you can comment on or make changes to this bug.