Bug 532112 - Hplip does not resume printing when network printer comes online
Summary: Hplip does not resume printing when network printer comes online
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 537771 (view as bug list)
Depends On: 528483
Blocks: 552582
TreeView+ depends on / blocked
 
Reported: 2009-10-30 17:28 UTC by Tim Waugh
Modified: 2010-02-05 01:33 UTC (History)
5 users (show)

Fixed In Version: 3.9.8-28.fc12
Doc Type: Bug Fix
Doc Text:
Clone Of: 528483
: 552582 (view as bug list)
Environment:
Last Closed: 2010-02-05 01:33:05 UTC


Attachments (Terms of Use)

Description Tim Waugh 2009-10-30 17:28:58 UTC
Cloned for Fedora 12, which has had this change reverted for now to see what the upstream maintainers decide.

+++ This bug was initially created as a clone of Bug #528483 +++

Description of problem:

Up until early in the Fedora 11 release cycle, jobs in the print queue for a network printer would start printing as soon as a network printer comes online.  Now it is necessary to explicitly resume the printer in CUPS.


Version-Release number of selected component (if applicable):

hplip-3.9.8-12.fc11
(Used on local network with HP Officejet 6315)

How reproducible:

Always

Steps to Reproduce:
1. Switch off printer
2. Print document
3. Switch on printer
  
Actual results:

Nothing happens

Expected results:

Printer will print as soon as it is online (this used to work!)

Additional info:

Opening the cups web interface and explicitly resuming the printer will get the printer started again.

I attach a section of /var/log/messages which was generated by such a failed print attempt.

--- Additional comment from oliver@member.ams.org on 2009-10-12 09:18:43 EDT ---

Created an attachment (id=364454)
Relevant lines of /var/log/messages

--- Additional comment from twaugh@redhat.com on 2009-10-22 06:50:59 EDT ---

*** Bug 529906 has been marked as a duplicate of this bug. ***

--- Additional comment from twaugh@redhat.com on 2009-10-23 07:49:35 EDT ---

Reported upstream with patch.

--- Additional comment from twaugh@redhat.com on 2009-10-23 08:01:36 EDT ---

Please try this package:
  http://koji.fedoraproject.org/koji/buildinfo?buildID=137941

Does it fix the problem?

--- Additional comment from updates@fedoraproject.org on 2009-10-23 08:09:28 EDT ---

hplip-3.9.8-15.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/hplip-3.9.8-15.fc11

--- Additional comment from lsof@nodata.co.uk on 2009-10-23 14:15:17 EDT ---

Any chance you can push this to Rawhide too?

--- Additional comment from twaugh@redhat.com on 2009-10-23 14:43:52 EDT ---

If I know it actually fixes the problem, yes. :-)

Does it?

--- Additional comment from lsof@nodata.co.uk on 2009-10-23 15:15:20 EDT ---

I don't know. I have rawhide hplip-3.9.8-17.fc12

You linked to a F11 Koji build of hplip-3.9.8-15.fc11

What do you want me to install?

--- Additional comment from updates@fedoraproject.org on 2009-10-27 02:43:06 EDT ---

hplip-3.9.8-15.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

--- Additional comment from updates@fedoraproject.org on 2009-10-28 22:54:54 EDT ---

hplip-3.9.8-16.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-10759

--- Additional comment from twaugh@redhat.com on 2009-10-30 13:02:07 EDT ---

(In reply to comment #8)
> What do you want me to install?  

Can you try this build please?:
http://koji.fedoraproject.org/koji/buildinfo?buildID=138861

Comment 1 Bug Zapper 2009-11-16 14:43:01 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 2 Need Real Name 2009-11-18 12:50:39 UTC
Not sure if this bug should still be open. It works for me.

Comment 3 Tim Waugh 2009-11-18 13:02:14 UTC
Although the Fedora 11 package has the fix included, Fedora 12 doesn't yet.  I pulled it out until I can get upstream to agree on how (and whether) it should be fixed.

Comment 4 Tim Waugh 2009-11-27 16:15:13 UTC
*** Bug 537771 has been marked as a duplicate of this bug. ***

Comment 5 Tim Waugh 2010-01-05 15:20:13 UTC
OK, upstream seem to be going their own way on it rather than using common sense.  We'll apply our patch for Fedora.

Comment 6 Fedora Update System 2010-01-07 00:54:10 UTC
hplip-3.9.8-26.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12253

Comment 7 Fedora Update System 2010-01-14 01:19:13 UTC
hplip-3.9.8-27.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12253

Comment 8 Fedora Update System 2010-01-22 22:42:44 UTC
hplip-3.9.8-28.fc12 has been pushed to the Fedora 12 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2009-12253

Comment 9 Fedora Update System 2010-02-05 01:32:47 UTC
hplip-3.9.8-28.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.