This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 528744 - Patch for btusb (linux-2.6-bluetooth-autosuspend.diff) breaks my bluetooth mouse
Patch for btusb (linux-2.6-bluetooth-autosuspend.diff) breaks my bluetooth mouse
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
i686 Linux
low Severity medium
: ---
: ---
Assigned To: John Feeney
Fedora Extras Quality Assurance
:
: 516756 (view as bug list)
Depends On:
Blocks: F12Target
  Show dependency treegraph
 
Reported: 2009-10-13 10:51 EDT by Martin Decky
Modified: 2013-01-10 02:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-30 19:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lsusb output (63.22 KB, text/plain)
2009-10-26 14:43 EDT, Andy Burns
no flags Details
lsusb -v output on Lenovo ThinkPad T60 (43.75 KB, text/plain)
2009-10-27 07:49 EDT, Martin Decky
no flags Details

  None (edit)
Description Martin Decky 2009-10-13 10:51:26 EDT
Description of problem:

The patch linux-2.6-bluetooth-autosuspend.diff (which is used in the current rawhide kernel 2.6.31.3-67.fc12.i686) breaks my bluetooth mouse.

With this patch the mouse gets discovered in the GNOME Bluetooth preferences, I can even pair successfully with it and it seems to be working at first. But the cursor movement stops every 2 seconds or so for about 0.5 seconds, which is rather annoying. Moreover, after about 20 - 30 seconds the mouse stops responding at all and this can be seen in dmesg:

usb 5-1: reset full speed USB device using uhci_hcd and address 4
btusb 5-1:1.0: no reset_resume for driver btusb?
btusb 5-1:1.1: no reset_resume for driver btusb?

All attempts to make the mouse (or any other bluetooth communication) to work again fail. I have tried "hciconfig hci0 reset" (also down/reset/up), turning the dongle off and on via a hardware kill switch (it is an integrated USB bluetooth adapter inside Lenovo ThinkPad T60), rmmoding and insmoding the btusb module. Only rebooting the machine helps, but the mouse works again for just a limited time.

After recompiling 2.6.31.3-67.fc12.i686 with the linux-2.6-bluetooth-autosuspend.diff patch removed (I didn't touch anything else) everything works perfectly again. The mouse cursor is moving smoothly and the mouse has been working for 2 hours now without any troubles. The mouse also worked in Fedora 10 and 11 without any problems.


Version-Release number of selected component (if applicable):

kernel-PAE-2.6.31.3-67.local.fc12.i686
bluez-4.55-1.fc12.i686
bluez-libs-4.55-1.fc12.i686
gnome-bluetooth-2.28.1-1.fc12.i686
gnome-bluetooth-libs-2.28.1-1.fc12.i686


How reproducible:

Always, if the kernel is compiled with linux-2.6-bluetooth-autosuspend.diff.


Steps to Reproduce:

Just use the bluetooth mouse in the usual way in GNOME (discover, connect, use).

  
Actual results:

Mouse cursor movements are not smooth and the bluetooth communication dies unexpectedly.


Expected results:

The bluetooth mouse should work flawlessly as in previous Fedora releases.


Additional info:

Bus 005 Device 002: ID 0a5c:2110 Broadcom Corp. Bluetooth Controller
(integrated inside Lenovo ThinkPad 60 with a kill switch, see http://www.thinkwiki.org/wiki/ThinkPad_Bluetooth_with_Enhanced_Data_Rate_%28BDC-2%29)

Microsoft Bluetooth Notebook Mouse 5000
generic-bluetooth 0005:045E:0700.0001: input,hidraw0: BLUETOOTH HID v1.00 Mouse
Comment 1 Chuck Ebbert 2009-10-17 08:54:20 EDT
Updated the autosuspend patch to the latest upstream version in kernel-2.6.31.4-87.fc12. That may or may not fix the problems.
Comment 2 Chuck Ebbert 2009-10-21 06:03:44 EDT
*** Bug 516756 has been marked as a duplicate of this bug. ***
Comment 3 Martin Decky 2009-10-21 08:06:04 EDT
I have been testing kernel-2.6.31.4-88.fc12 for several hours now and everything works without any problems. I consider the bug fixed.
Comment 4 Andy Burns 2009-10-24 17:01:55 EDT
Working again for me with 2.6.31.5-96.fc12
Comment 5 Jared Smith 2009-10-26 14:15:53 EDT
This also seems to have fixed the problem for me as well... thank you!
Comment 6 Matthew Garrett 2009-10-26 14:27:20 EDT
Updated patch fixes the problem by disabling autosuspend by default, which kind of defeats the object. Could those of you who had it broken before please provide the output of lsusb -v when run as root?
Comment 7 Andy Burns 2009-10-26 14:43:33 EDT
Created attachment 366139 [details]
lsusb output

Dell mini9 with internal Bluetooth and a Microsoft Intellimouse bluetooth mouse.
Comment 8 Matthew Garrett 2009-10-26 14:48:57 EDT
Andy,

And with previous kernels, it's broken in the way described above?
Comment 9 Andy Burns 2009-10-26 15:10:41 EDT
Yes, fine with 2.6.29.x and 2.6.30.x in F11, broken in rawhide from 2.6.31-14 to 2.6.31.1-56, then 2.6.31.5-96 fixed it.
Comment 10 Martin Decky 2009-10-27 07:49:28 EDT
Created attachment 366248 [details]
lsusb -v output on Lenovo ThinkPad T60

(In reply to comment #6)

This is the output of lsusb -v on my machine (further hardware details in comment #0). Like I have written in comment #0, bt worked in Fedora 11 and the breakage was connected with the indicated patch. In the current kernel (2.6.31.5-96.fc12.i686.PAE) bt is working.

I understand the objective of autosuspend, but somehow I prefer a driver which works (but without autosuspend) than a driver which does not work (but with autosuspend) :)
Comment 11 Martin Decky 2009-11-30 19:34:00 EST
I have not encountered any more problems with my bluetooth mouse since this bug was fixed. Therefore I suggest closing this report.
Comment 12 Andy Burns 2009-11-30 19:38:58 EST
(In reply to comment #11)

> I have not encountered any more problems with my bluetooth mouse since this bug
> was fixed. Therefore I suggest closing this report.  

The way I read it, the bug has only been "fixed" by disabling the autosuspend code, so should it really be re-opened pending a proper fix of the code?
Comment 13 Martin Decky 2009-11-30 19:56:20 EST
(In reply to comment #12)

Like I have already written in comment #10, the basic functionality of the bluetooth mouse and the possibility to make use of autosuspend are probably two more-or-less separate issues.

This bug was about the basic functionality and I believe that it would be wiser to create a separate bug report concerning the autosuspend issue, rather than transforming this report. But that's just my humble opinion, so please feel free to reopen this bug if you really think that it is the best way to track the progress of making the autosuspend feature work flawlessly.

Note You need to log in before you can comment on or make changes to this bug.