Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 528809 - Can't just dd boot.iso to usbkey
Can't just dd boot.iso to usbkey
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Radek Vykydal
Fedora Extras Quality Assurance
:
: 529900 530710 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-13 16:02 EDT by Jerry Vonau
Modified: 2011-03-07 11:56 EST (History)
5 users (show)

See Also:
Fixed In Version: anaconda 14.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-07 11:56:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (2.27 KB, text/plain)
2009-10-14 12:08 EDT, Jerry Vonau
no flags Details
anaconda.log (2.12 KB, text/plain)
2009-10-14 12:09 EDT, Jerry Vonau
no flags Details

  None (edit)
Description Jerry Vonau 2009-10-13 16:02:58 EDT
Description of problem:
I get prompted for the drive and the path to install.img

Version-Release number of selected component (if applicable):
12.37

How reproducible:
boot the install from a usbkey

Steps to Reproduce:
1.dd boot.iso to usbkey
2.boot the usbkey
3.
  
Actual results:
I get prompted for the drive and path to install.img. 

Expected results:
The installer would mount install.img without prompting for the drive and path based on the passing of stage2=hd:LABEL=Fedora, this breaks kickstart driven installs that use a usbkey. 

Additional info:
If I edit the stage2 line to be stage2=hd:LABEL=Fedora:/images/install.img
I'm not prompted for the location of install.img
Comment 1 Chris Lumens 2009-10-14 08:33:29 EDT
Please attach /tmp/anaconda.log to this bug report.
Comment 2 Jerry Vonau 2009-10-14 12:08:22 EDT
Created attachment 364775 [details]
anaconda.log 

anaconda log with stage2 as is..
Comment 3 Jerry Vonau 2009-10-14 12:09:55 EDT
Created attachment 364776 [details]
anaconda.log 

with stage2 appending :/images/install.img
Comment 4 Radek Vykydal 2009-10-23 05:39:41 EDT
*** Bug 529900 has been marked as a duplicate of this bug. ***
Comment 5 Radek Vykydal 2009-10-26 09:52:46 EDT
I sent a patch to anaconda-devel-list for review.
Comment 6 Chris Lumens 2009-10-26 10:42:19 EDT
*** Bug 530710 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Qarras 2009-11-01 07:17:39 EST
I'm wondering that shouldn't this be a F12 Blocker? Because now USB installation is impossible and fixing the installer after the release is also more or less impossible.
Comment 8 Jerry Vonau 2009-11-01 07:58:20 EST
Should be a F12 Blocker now that livecd-iso-to-disk.sh is featuring that option.

http://git.fedorahosted.org/git/?p=livecd;a=commitdiff;h=09678eb9284f2df7618c4609998fd3bd95787251
Comment 9 Adam Williamson 2009-11-04 13:21:21 EST
clumens, wdyt? I am still not entirely clear on whether this is the 'right' way to do an install from a USB stick or what.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 10 Adam Williamson 2009-11-04 13:23:33 EST
<adamw> clumens: denise: oxf13: jlaska: would be good to get your opinions on whether https://bugzilla.redhat.com/show_bug.cgi?id=528809 should be blocker
<buggbot> Bug 528809: medium, low, ---, rvykydal, ASSIGNED, Can't just dd boot.iso to usbkey
<adamw> i am not 100% clear on it
<Oxf13> yeah, that's something new, not a well tested feature
 not a blocker IMHO
<denise> +1

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Jesse Keating 2009-11-04 13:39:02 EST
That livecd-iso-to-disk uses a different method than dd, and would not suffer this issue, however we are not tagging a build with that in, we're still in discussion upstream about whether or not to put that code in that script.

dd of boot.iso is a relatively new and very much untested feature.  It should not be an advertised option outside of the Live images.  As such I would not block the release for this.
Comment 12 Bug Zapper 2009-11-16 08:37:58 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 13 Daniel Qarras 2010-01-20 10:54:13 EST
Just tested this with Fedora 12 installer and it is broken as expected.

Could somebody please switch the version to Rawhide since Fedora 12 installer won't be fixed anymore.

Thanks.
Comment 14 Daniel Qarras 2010-03-11 02:40:55 EST
USB installation still broken with Fedora 13 Alpha, in year 2010 :(
Comment 15 Bug Zapper 2010-03-15 08:56:36 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 13 development cycle.
Changing version to '13'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Radek Vykydal 2010-04-12 09:14:32 EDT
Should be fixed in anaconda 14.4-1.
Path /images/install.img is checked automatically if there is no other in stage2=hd: parameter.
Comment 17 Adam Williamson 2010-04-12 14:55:52 EDT
for the record, that only fixes it for F14, I believe; F13 will still have this restriction.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Daniel Qarras 2010-09-15 14:00:22 EDT
Good news, one can now just dd the F14ß ISO (netboot) image to a USB stick and install from there!

I noticed a minor usability when comparing CD vs USB (see bug 634285) but that's pretty harmless.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.